aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/newview/llvoiceclient.cpp
diff options
context:
space:
mode:
authorDavid Walter Seikel2013-08-30 21:42:45 +1000
committerDavid Walter Seikel2013-08-30 21:42:45 +1000
commit56a1de48ee43bfacbd3ef2859f392082a26bc814 (patch)
tree03bd6092dab42985e536b84d2f311a3a12e4edb4 /linden/indra/newview/llvoiceclient.cpp
parentAdded a licensing note about gpg.vs, as used to build OTR on Windows. (diff)
parentMerge remote-tracking branch 'origin/next' into WL-refactor (diff)
downloadmeta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.zip
meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.tar.gz
meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.tar.bz2
meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.tar.xz
Merge remote-tracking branch 'imprudence/next' into next
Unless otherwise stated, Imprudence changes accepted. The three images seem to be the same. Conflicts: .gitignore linden/indra/develop.py linden/indra/llcommon/llsdserialize_xml.cpp linden/indra/newview/CMakeLists.txt Manually combined MOAP, OTR, and WL changes from both. linden/indra/newview/app_settings/default_grids.xml Manually merged the grid collection. Also updated IG info. linden/indra/newview/hippoupdate.cpp linden/indra/newview/llettherebelight.cpp Just used the Imprudence copy. linden/indra/newview/llviewermessage.cpp Keep unbranding. linden/indra/newview/llvoavatar.cpp Manually merge client tags. linden/indra/newview/res/viewerRes.rc Manually merge version from Impy. linden/indra/newview/skins/dark/colors_base.xml Keep unbranding. linden/indra/newview/skins/default/html/unabletoconnect.png linden/indra/newview/skins/default/textures/icon_top_pick.tga linden/indra/newview/skins/default/xui/en-us/floater_about.xml Manual merging of contributors. linden/indra/newview/skins/gemini/colors_base.xml Keep unbranding. linden/indra/newview/skins/gemini/textures/icon_top_pick.tga linden/indra/newview/viewer_manifest.py Manually merged boost, gstreamer, OTR, and name. linden/indra/newview/viewerinfo.cpp Manually merge the comment.
Diffstat (limited to 'linden/indra/newview/llvoiceclient.cpp')
-rw-r--r--linden/indra/newview/llvoiceclient.cpp10
1 files changed, 1 insertions, 9 deletions
diff --git a/linden/indra/newview/llvoiceclient.cpp b/linden/indra/newview/llvoiceclient.cpp
index 559bc31..409bb68 100644
--- a/linden/indra/newview/llvoiceclient.cpp
+++ b/linden/indra/newview/llvoiceclient.cpp
@@ -3160,7 +3160,7 @@ void LLVoiceClient::giveUp()
3160 3160
3161static void oldSDKTransform (LLVector3 &left, LLVector3 &up, LLVector3 &at, LLVector3d &pos, LLVector3 &vel) 3161static void oldSDKTransform (LLVector3 &left, LLVector3 &up, LLVector3 &at, LLVector3d &pos, LLVector3 &vel)
3162{ 3162{
3163 F32 nat[3], nup[3], nl[3], nvel[3]; // the new at, up, left vectors and the new position and velocity 3163 F32 nat[3], nup[3], nl[3]; // the new at, up, left vectors and the new position and velocity (velocity was not used, so I deleted it)
3164 F64 npos[3]; 3164 F64 npos[3];
3165 3165
3166 // The original XML command was sent like this: 3166 // The original XML command was sent like this:
@@ -3210,10 +3210,6 @@ static void oldSDKTransform (LLVector3 &left, LLVector3 &up, LLVector3 &at, LLVe
3210 npos[1] = pos.mdV[VZ]; 3210 npos[1] = pos.mdV[VZ];
3211 npos[2] = pos.mdV[VY]; 3211 npos[2] = pos.mdV[VY];
3212 3212
3213 nvel[0] = vel.mV[VX];
3214 nvel[1] = vel.mV[VZ];
3215 nvel[2] = vel.mV[VY];
3216
3217 for(int i=0;i<3;++i) { 3213 for(int i=0;i<3;++i) {
3218 at.mV[i] = nat[i]; 3214 at.mV[i] = nat[i];
3219 up.mV[i] = nup[i]; 3215 up.mV[i] = nup[i];
@@ -3264,10 +3260,6 @@ static void oldSDKTransform (LLVector3 &left, LLVector3 &up, LLVector3 &at, LLVe
3264 npos[1] = pos.mdV[VZ]; 3260 npos[1] = pos.mdV[VZ];
3265 npos[2] = pos.mdV[VY] * -1.0; 3261 npos[2] = pos.mdV[VY] * -1.0;
3266 3262
3267 nvel[0] = vel.mV[VX];
3268 nvel[1] = vel.mV[VZ];
3269 nvel[2] = vel.mV[VY];
3270
3271 for(int i=0;i<3;++i) { 3263 for(int i=0;i<3;++i) {
3272 at.mV[i] = nat[i]; 3264 at.mV[i] = nat[i];
3273 up.mV[i] = nup[i]; 3265 up.mV[i] = nup[i];