diff options
author | Robin Cornelius | 2010-10-10 21:53:54 +0100 |
---|---|---|
committer | Robin Cornelius | 2010-10-10 21:53:54 +0100 |
commit | c0034c520c6e61b64822e276316651ec6912bd98 (patch) | |
tree | 910442027b6a2c1406d80ca93949755b54badf5c /linden/indra/newview/llviewerobject.h | |
parent | Use all those cores for compile (diff) | |
parent | Thickbrick Sleaford, Soft Linden: STORM-164 make gcc-4.4 happy about llvosky.h (diff) | |
download | meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.zip meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.gz meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.bz2 meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.xz |
Merge branch 'mccabe-plugins' into plugins_merge
Conflicts:
linden/doc/contributions.txt
linden/indra/cmake/GStreamer.cmake
linden/indra/cmake/LLMedia.cmake
linden/indra/cmake/OPENAL.cmake
linden/indra/llmedia/CMakeLists.txt
linden/indra/llprimitive/material_codes.h
linden/indra/newview/chatbar_as_cmdline.cpp
linden/indra/newview/llappviewer.cpp
linden/indra/newview/llfloatertos.cpp
linden/indra/newview/llstartup.cpp
linden/indra/newview/llviewerwindow.cpp
linden/indra/newview/llvoavatar.cpp
linden/indra/newview/pipeline.cpp
linden/indra/newview/pipeline.h
linden/indra/newview/viewer_manifest.py
linden/install.xml
Diffstat (limited to 'linden/indra/newview/llviewerobject.h')
-rw-r--r-- | linden/indra/newview/llviewerobject.h | 11 |
1 files changed, 8 insertions, 3 deletions
diff --git a/linden/indra/newview/llviewerobject.h b/linden/indra/newview/llviewerobject.h index 33e8da2..a227f2d 100644 --- a/linden/indra/newview/llviewerobject.h +++ b/linden/indra/newview/llviewerobject.h | |||
@@ -74,6 +74,7 @@ class LLViewerPartSourceScript; | |||
74 | class LLViewerRegion; | 74 | class LLViewerRegion; |
75 | class LLViewerObjectMedia; | 75 | class LLViewerObjectMedia; |
76 | class LLVOInventoryListener; | 76 | class LLVOInventoryListener; |
77 | class LLVOAvatar; | ||
77 | 78 | ||
78 | typedef enum e_object_update_type | 79 | typedef enum e_object_update_type |
79 | { | 80 | { |
@@ -116,7 +117,7 @@ public: | |||
116 | 117 | ||
117 | //============================================================================ | 118 | //============================================================================ |
118 | 119 | ||
119 | class LLViewerObject : public LLPrimitive, public LLRefCount | 120 | class LLViewerObject : public LLPrimitive, public LLRefCount, public LLGLUpdate |
120 | { | 121 | { |
121 | protected: | 122 | protected: |
122 | ~LLViewerObject(); // use unref() | 123 | ~LLViewerObject(); // use unref() |
@@ -143,6 +144,8 @@ public: | |||
143 | BOOL isOrphaned() const { return mOrphaned; } | 144 | BOOL isOrphaned() const { return mOrphaned; } |
144 | BOOL isParticleSource() const; | 145 | BOOL isParticleSource() const; |
145 | 146 | ||
147 | virtual LLVOAvatar* asAvatar(); | ||
148 | |||
146 | static void initVOClasses(); | 149 | static void initVOClasses(); |
147 | static void cleanupVOClasses(); | 150 | static void cleanupVOClasses(); |
148 | 151 | ||
@@ -189,11 +192,12 @@ public: | |||
189 | S32 getNumFaces() const { return mNumFaces; } | 192 | S32 getNumFaces() const { return mNumFaces; } |
190 | 193 | ||
191 | // Graphical stuff for objects - maybe broken out into render class later? | 194 | // Graphical stuff for objects - maybe broken out into render class later? |
192 | virtual void updateTextures(); | 195 | virtual void updateTextures(LLAgent &agent); |
193 | virtual void boostTexturePriority(BOOL boost_children = TRUE); // When you just want to boost priority of this object | 196 | virtual void boostTexturePriority(BOOL boost_children = TRUE); // When you just want to boost priority of this object |
194 | 197 | ||
195 | virtual LLDrawable* createDrawable(LLPipeline *pipeline); | 198 | virtual LLDrawable* createDrawable(LLPipeline *pipeline); |
196 | virtual BOOL updateGeometry(LLDrawable *drawable); | 199 | virtual BOOL updateGeometry(LLDrawable *drawable); |
200 | virtual void updateGL(); | ||
197 | virtual void updateFaceSize(S32 idx); | 201 | virtual void updateFaceSize(S32 idx); |
198 | virtual BOOL updateLOD(); | 202 | virtual BOOL updateLOD(); |
199 | virtual BOOL setDrawableParent(LLDrawable* parentp); | 203 | virtual BOOL setDrawableParent(LLDrawable* parentp); |
@@ -218,6 +222,7 @@ public: | |||
218 | 222 | ||
219 | virtual BOOL isFlexible() const { return FALSE; } | 223 | virtual BOOL isFlexible() const { return FALSE; } |
220 | virtual BOOL isSculpted() const { return FALSE; } | 224 | virtual BOOL isSculpted() const { return FALSE; } |
225 | virtual BOOL hasLightTexture() const { return FALSE; } | ||
221 | 226 | ||
222 | // This method returns true if the object is over land owned by | 227 | // This method returns true if the object is over land owned by |
223 | // the agent. | 228 | // the agent. |
@@ -468,7 +473,7 @@ public: | |||
468 | 473 | ||
469 | virtual S32 getLOD() const { return 3; } | 474 | virtual S32 getLOD() const { return 3; } |
470 | virtual U32 getPartitionType() const; | 475 | virtual U32 getPartitionType() const; |
471 | virtual void dirtySpatialGroup() const; | 476 | virtual void dirtySpatialGroup(BOOL priority = FALSE) const; |
472 | virtual void dirtyMesh(); | 477 | virtual void dirtyMesh(); |
473 | 478 | ||
474 | virtual LLNetworkData* getParameterEntry(U16 param_type) const; | 479 | virtual LLNetworkData* getParameterEntry(U16 param_type) const; |