diff options
author | Robin Cornelius | 2010-10-10 21:53:54 +0100 |
---|---|---|
committer | Robin Cornelius | 2010-10-10 21:53:54 +0100 |
commit | c0034c520c6e61b64822e276316651ec6912bd98 (patch) | |
tree | 910442027b6a2c1406d80ca93949755b54badf5c /linden/indra/newview/llviewerimage.h | |
parent | Use all those cores for compile (diff) | |
parent | Thickbrick Sleaford, Soft Linden: STORM-164 make gcc-4.4 happy about llvosky.h (diff) | |
download | meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.zip meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.gz meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.bz2 meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.xz |
Merge branch 'mccabe-plugins' into plugins_merge
Conflicts:
linden/doc/contributions.txt
linden/indra/cmake/GStreamer.cmake
linden/indra/cmake/LLMedia.cmake
linden/indra/cmake/OPENAL.cmake
linden/indra/llmedia/CMakeLists.txt
linden/indra/llprimitive/material_codes.h
linden/indra/newview/chatbar_as_cmdline.cpp
linden/indra/newview/llappviewer.cpp
linden/indra/newview/llfloatertos.cpp
linden/indra/newview/llstartup.cpp
linden/indra/newview/llviewerwindow.cpp
linden/indra/newview/llvoavatar.cpp
linden/indra/newview/pipeline.cpp
linden/indra/newview/pipeline.h
linden/indra/newview/viewer_manifest.py
linden/install.xml
Diffstat (limited to 'linden/indra/newview/llviewerimage.h')
-rw-r--r-- | linden/indra/newview/llviewerimage.h | 31 |
1 files changed, 30 insertions, 1 deletions
diff --git a/linden/indra/newview/llviewerimage.h b/linden/indra/newview/llviewerimage.h index c82b68b..7d646be 100644 --- a/linden/indra/newview/llviewerimage.h +++ b/linden/indra/newview/llviewerimage.h | |||
@@ -41,11 +41,13 @@ | |||
41 | #include <map> | 41 | #include <map> |
42 | #include <list> | 42 | #include <list> |
43 | 43 | ||
44 | class LLFace; | 44 | |
45 | #define MIN_VIDEO_RAM_IN_MEGA_BYTES 32 | 45 | #define MIN_VIDEO_RAM_IN_MEGA_BYTES 32 |
46 | #define MAX_VIDEO_RAM_IN_MEGA_BYTES 512 // 512MB max for performance reasons. | 46 | #define MAX_VIDEO_RAM_IN_MEGA_BYTES 512 // 512MB max for performance reasons. |
47 | 47 | ||
48 | class LLViewerImage; | 48 | class LLViewerImage; |
49 | class LLTextureAtlas ; | ||
50 | class LLFace ; | ||
49 | 51 | ||
50 | typedef void (*loaded_callback_func)( BOOL success, LLViewerImage *src_vi, LLImageRaw* src, LLImageRaw* src_aux, S32 discard_level, BOOL final, void* userdata ); | 52 | typedef void (*loaded_callback_func)( BOOL success, LLViewerImage *src_vi, LLImageRaw* src, LLImageRaw* src_aux, S32 discard_level, BOOL final, void* userdata ); |
51 | 53 | ||
@@ -261,8 +263,29 @@ public: | |||
261 | void setMinDiscardLevel(S32 discard) { mMinDesiredDiscardLevel = llmin(mMinDesiredDiscardLevel,(S8)discard); } | 263 | void setMinDiscardLevel(S32 discard) { mMinDesiredDiscardLevel = llmin(mMinDesiredDiscardLevel,(S8)discard); } |
262 | 264 | ||
263 | // Host we think might have this image, used for baked av textures. | 265 | // Host we think might have this image, used for baked av textures. |
266 | void setTargetHost(LLHost host) { mTargetHost = host; } | ||
264 | LLHost getTargetHost() const { return mTargetHost; } | 267 | LLHost getTargetHost() const { return mTargetHost; } |
265 | 268 | ||
269 | enum | ||
270 | { | ||
271 | BOOST_NONE = 0, | ||
272 | BOOST_AVATAR_BAKED = 1, | ||
273 | BOOST_AVATAR = 2, | ||
274 | BOOST_CLOUDS = 3, | ||
275 | BOOST_SCULPTED = 4, | ||
276 | |||
277 | BOOST_HIGH = 10, | ||
278 | BOOST_TERRAIN = 11, // has to be high priority for minimap / low detail | ||
279 | BOOST_SELECTED = 12, | ||
280 | BOOST_HUD = 13, | ||
281 | BOOST_AVATAR_BAKED_SELF = 14, | ||
282 | BOOST_UI = 15, | ||
283 | BOOST_PREVIEW = 16, | ||
284 | BOOST_MAP = 17, | ||
285 | BOOST_MAP_LAYER = 18, | ||
286 | BOOST_AVATAR_SELF = 19, // needed for baking avatar | ||
287 | BOOST_MAX_LEVEL | ||
288 | }; | ||
266 | void setBoostLevel(S32 level); | 289 | void setBoostLevel(S32 level); |
267 | S32 getBoostLevel() { return mBoostLevel; } | 290 | S32 getBoostLevel() { return mBoostLevel; } |
268 | 291 | ||
@@ -295,6 +318,10 @@ public: | |||
295 | S32 getOriginalWidth() { return mOrigWidth; } | 318 | S32 getOriginalWidth() { return mOrigWidth; } |
296 | S32 getOriginalHeight() { return mOrigHeight; } | 319 | S32 getOriginalHeight() { return mOrigHeight; } |
297 | 320 | ||
321 | BOOL insertToAtlas() ; | ||
322 | void resetFaceAtlas() ; | ||
323 | void invalidateAtlas(BOOL rebuild_geom = FALSE); | ||
324 | |||
298 | BOOL isForSculptOnly() const ; | 325 | BOOL isForSculptOnly() const ; |
299 | void setForSculpt(); | 326 | void setForSculpt(); |
300 | 327 | ||
@@ -313,6 +340,7 @@ public: | |||
313 | 340 | ||
314 | void addFace(LLFace* facep) ; | 341 | void addFace(LLFace* facep) ; |
315 | void removeFace(LLFace* facep) ; | 342 | void removeFace(LLFace* facep) ; |
343 | BOOL isReferenced()const {return mFaceList.size() > 0 ; } | ||
316 | 344 | ||
317 | friend class LocalBitmap; // tag: vaa emerald local_asset_browser | 345 | friend class LocalBitmap; // tag: vaa emerald local_asset_browser |
318 | 346 | ||
@@ -418,6 +446,7 @@ private: | |||
418 | typedef std::list<LLFace*> ll_face_list_t ; | 446 | typedef std::list<LLFace*> ll_face_list_t ; |
419 | ll_face_list_t mFaceList ; //reverse pointer pointing to the faces using this image as texture | 447 | ll_face_list_t mFaceList ; //reverse pointer pointing to the faces using this image as texture |
420 | 448 | ||
449 | BOOL mInCreationList ; | ||
421 | public: | 450 | public: |
422 | static const U32 sCurrentFileVersion; | 451 | static const U32 sCurrentFileVersion; |
423 | // Default textures | 452 | // Default textures |