aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/newview/lltoolpie.h
diff options
context:
space:
mode:
authorRobin Cornelius2010-10-10 21:53:54 +0100
committerRobin Cornelius2010-10-10 21:53:54 +0100
commitc0034c520c6e61b64822e276316651ec6912bd98 (patch)
tree910442027b6a2c1406d80ca93949755b54badf5c /linden/indra/newview/lltoolpie.h
parentUse all those cores for compile (diff)
parentThickbrick Sleaford, Soft Linden: STORM-164 make gcc-4.4 happy about llvosky.h (diff)
downloadmeta-impy-c0034c520c6e61b64822e276316651ec6912bd98.zip
meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.gz
meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.bz2
meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.xz
Merge branch 'mccabe-plugins' into plugins_merge
Conflicts: linden/doc/contributions.txt linden/indra/cmake/GStreamer.cmake linden/indra/cmake/LLMedia.cmake linden/indra/cmake/OPENAL.cmake linden/indra/llmedia/CMakeLists.txt linden/indra/llprimitive/material_codes.h linden/indra/newview/chatbar_as_cmdline.cpp linden/indra/newview/llappviewer.cpp linden/indra/newview/llfloatertos.cpp linden/indra/newview/llstartup.cpp linden/indra/newview/llviewerwindow.cpp linden/indra/newview/llvoavatar.cpp linden/indra/newview/pipeline.cpp linden/indra/newview/pipeline.h linden/indra/newview/viewer_manifest.py linden/install.xml
Diffstat (limited to 'linden/indra/newview/lltoolpie.h')
-rw-r--r--linden/indra/newview/lltoolpie.h2
1 files changed, 1 insertions, 1 deletions
diff --git a/linden/indra/newview/lltoolpie.h b/linden/indra/newview/lltoolpie.h
index 113fba7..54bf409 100644
--- a/linden/indra/newview/lltoolpie.h
+++ b/linden/indra/newview/lltoolpie.h
@@ -51,6 +51,7 @@ public:
51 virtual BOOL handleRightMouseUp(S32 x, S32 y, MASK mask); 51 virtual BOOL handleRightMouseUp(S32 x, S32 y, MASK mask);
52 virtual BOOL handleHover(S32 x, S32 y, MASK mask); 52 virtual BOOL handleHover(S32 x, S32 y, MASK mask);
53 virtual BOOL handleDoubleClick(S32 x, S32 y, MASK mask); 53 virtual BOOL handleDoubleClick(S32 x, S32 y, MASK mask);
54 virtual BOOL handleScrollWheel(S32 x, S32 y, S32 clicks);
54 55
55 virtual void render(); 56 virtual void render();
56 57
@@ -85,7 +86,6 @@ private:
85 LLPickInfo mPick; 86 LLPickInfo mPick;
86 U8 mClickAction; 87 U8 mClickAction;
87 LLSafeHandle<LLObjectSelection> mLeftClickSelection; 88 LLSafeHandle<LLObjectSelection> mLeftClickSelection;
88protected:
89 LLPointer<LLViewerObject> mClickActionObject; 89 LLPointer<LLViewerObject> mClickActionObject;
90}; 90};
91 91