diff options
author | David Seikel | 2011-06-04 00:17:28 +1000 |
---|---|---|
committer | David Seikel | 2011-06-04 00:17:28 +1000 |
commit | 492eaaf4eec82327116f2605e3d8becf94bec1b3 (patch) | |
tree | dcddd674cb4861445c3ec5aaa59325b99a437614 /linden/indra/newview/llpanelnetwork.h | |
parent | Set the real bare minimum prim size to 0.00001, as 0 sized objects cause bugs. (diff) | |
parent | Fixing the menu to actually use its color options reveals how broken the whol... (diff) | |
download | meta-impy-492eaaf4eec82327116f2605e3d8becf94bec1b3.zip meta-impy-492eaaf4eec82327116f2605e3d8becf94bec1b3.tar.gz meta-impy-492eaaf4eec82327116f2605e3d8becf94bec1b3.tar.bz2 meta-impy-492eaaf4eec82327116f2605e3d8becf94bec1b3.tar.xz |
Merge branch 'next' of git://github.com/jacek/imprudence into next
Conflicts (manually merged):
linden/indra/llcommon/llversionviewer.h
linden/indra/llvfs/lldir.cpp
linden/indra/llvfs/lldir_mac.cpp
linden/indra/newview/CMakeLists.txt
linden/indra/newview/English.lproj/InfoPlist.strings
linden/indra/newview/Info-Imprudence.plist
linden/indra/newview/Info-meta-impy.plist
linden/indra/newview/llappviewer.cpp
linden/indra/newview/llpanellogin.cpp
linden/indra/newview/packaging/mac/Info.plist.in
linden/indra/newview/res/viewerRes.rc
linden/indra/newview/skins/default/xui/en-us/floater_about.xml
linden/indra/newview/skins/default/xui/en-us/panel_preferences_advanced.xml
linden/indra/newview/skins/default/xui/en-us/panel_preferences_graphics1.xml
linden/indra/newview/skins/default/xui/en-us/panel_preferences_im.xml
linden/indra/newview/skins/default/xui/en-us/panel_preferences_skins.xml
linden/indra/newview/skins/default/xui/en-us/panel_preferences_web.xml
linden/indra/newview/skins/default/xui/zh/menu_viewer.xml
linden/indra/newview/skins/default/xui/zh/panel_group_general.xml
linden/indra/newview/viewer_manifest.py
linden/indra/newview/viewerversion.cpp
linden/indra/newview/viewerversion.h
linden/install.xml
Also some post merge tweaks.
Diffstat (limited to 'linden/indra/newview/llpanelnetwork.h')
-rw-r--r-- | linden/indra/newview/llpanelnetwork.h | 20 |
1 files changed, 17 insertions, 3 deletions
diff --git a/linden/indra/newview/llpanelnetwork.h b/linden/indra/newview/llpanelnetwork.h index 628f713..b8e5618 100644 --- a/linden/indra/newview/llpanelnetwork.h +++ b/linden/indra/newview/llpanelnetwork.h | |||
@@ -47,9 +47,13 @@ public: | |||
47 | void cancel(); | 47 | void cancel(); |
48 | 48 | ||
49 | private: | 49 | private: |
50 | static void onClickClearCache(void*); | 50 | void refresh(); |
51 | static void onClickSetCache(void*); | 51 | |
52 | static void onClickResetCache(void*); | 52 | static void onCommitSpeedRezCheckBox(LLUICtrl* ctrl, void* user_data); |
53 | |||
54 | static void onClickClearDiskCache(void*); | ||
55 | static void onClickSetDiskCache(void*); | ||
56 | static void onClickResetDiskCache(void*); | ||
53 | static void onCommitPort(LLUICtrl* ctrl, void*); | 57 | static void onCommitPort(LLUICtrl* ctrl, void*); |
54 | static void onCommitXMLRPCProxyEnabled(LLUICtrl* ctrl, void* data); | 58 | static void onCommitXMLRPCProxyEnabled(LLUICtrl* ctrl, void* data); |
55 | static void onCommitSocks5ProxyEnabled(LLUICtrl* ctrl, void* data); | 59 | static void onCommitSocks5ProxyEnabled(LLUICtrl* ctrl, void* data); |
@@ -60,6 +64,16 @@ private: | |||
60 | 64 | ||
61 | static bool sSocksSettingsChanged; | 65 | static bool sSocksSettingsChanged; |
62 | 66 | ||
67 | // formerly the web panel -- MC | ||
68 | static void onClickClearWebCache(void*); | ||
69 | static void onClickClearCookies(void*); | ||
70 | static void onClickSearchDefault(void* user_data); | ||
71 | static void onClickSearchClear(void* user_data); | ||
72 | static bool callback_clear_browser_cache(const LLSD& notification, const LLSD& response); | ||
73 | static bool callback_clear_cookies(const LLSD& notification, const LLSD& response); | ||
74 | static void onCommitCookies(LLUICtrl* ctrl, void* data); | ||
75 | static void onCommitWebProxyEnabled(LLUICtrl* ctrl, void* data); | ||
76 | |||
63 | }; | 77 | }; |
64 | 78 | ||
65 | #endif | 79 | #endif |