diff options
author | David Seikel | 2011-06-04 00:17:28 +1000 |
---|---|---|
committer | David Seikel | 2011-06-04 00:17:28 +1000 |
commit | 492eaaf4eec82327116f2605e3d8becf94bec1b3 (patch) | |
tree | dcddd674cb4861445c3ec5aaa59325b99a437614 /linden/indra/newview/llpanelavatar.cpp | |
parent | Set the real bare minimum prim size to 0.00001, as 0 sized objects cause bugs. (diff) | |
parent | Fixing the menu to actually use its color options reveals how broken the whol... (diff) | |
download | meta-impy-492eaaf4eec82327116f2605e3d8becf94bec1b3.zip meta-impy-492eaaf4eec82327116f2605e3d8becf94bec1b3.tar.gz meta-impy-492eaaf4eec82327116f2605e3d8becf94bec1b3.tar.bz2 meta-impy-492eaaf4eec82327116f2605e3d8becf94bec1b3.tar.xz |
Merge branch 'next' of git://github.com/jacek/imprudence into next
Conflicts (manually merged):
linden/indra/llcommon/llversionviewer.h
linden/indra/llvfs/lldir.cpp
linden/indra/llvfs/lldir_mac.cpp
linden/indra/newview/CMakeLists.txt
linden/indra/newview/English.lproj/InfoPlist.strings
linden/indra/newview/Info-Imprudence.plist
linden/indra/newview/Info-meta-impy.plist
linden/indra/newview/llappviewer.cpp
linden/indra/newview/llpanellogin.cpp
linden/indra/newview/packaging/mac/Info.plist.in
linden/indra/newview/res/viewerRes.rc
linden/indra/newview/skins/default/xui/en-us/floater_about.xml
linden/indra/newview/skins/default/xui/en-us/panel_preferences_advanced.xml
linden/indra/newview/skins/default/xui/en-us/panel_preferences_graphics1.xml
linden/indra/newview/skins/default/xui/en-us/panel_preferences_im.xml
linden/indra/newview/skins/default/xui/en-us/panel_preferences_skins.xml
linden/indra/newview/skins/default/xui/en-us/panel_preferences_web.xml
linden/indra/newview/skins/default/xui/zh/menu_viewer.xml
linden/indra/newview/skins/default/xui/zh/panel_group_general.xml
linden/indra/newview/viewer_manifest.py
linden/indra/newview/viewerversion.cpp
linden/indra/newview/viewerversion.h
linden/install.xml
Also some post merge tweaks.
Diffstat (limited to 'linden/indra/newview/llpanelavatar.cpp')
-rw-r--r-- | linden/indra/newview/llpanelavatar.cpp | 3 |
1 files changed, 3 insertions, 0 deletions
diff --git a/linden/indra/newview/llpanelavatar.cpp b/linden/indra/newview/llpanelavatar.cpp index 6a3a0bd..e3fe141 100644 --- a/linden/indra/newview/llpanelavatar.cpp +++ b/linden/indra/newview/llpanelavatar.cpp | |||
@@ -1990,6 +1990,7 @@ void LLPanelAvatar::processAvatarPropertiesReply(LLMessageSystem *msg, void**) | |||
1990 | LLTextEditor* about_field = self->mPanelSecondLife->getChild<LLTextEditor>("about"); | 1990 | LLTextEditor* about_field = self->mPanelSecondLife->getChild<LLTextEditor>("about"); |
1991 | if (about_field) | 1991 | if (about_field) |
1992 | { | 1992 | { |
1993 | about_field->clear(); | ||
1993 | if (self->mAllowEdit && (self->mAvatarID == agent_id)) | 1994 | if (self->mAllowEdit && (self->mAvatarID == agent_id)) |
1994 | { | 1995 | { |
1995 | about_field->setText(about_text); | 1996 | about_field->setText(about_text); |
@@ -2009,8 +2010,10 @@ void LLPanelAvatar::processAvatarPropertiesReply(LLMessageSystem *msg, void**) | |||
2009 | about_field = self->mPanelFirstLife->getChild<LLTextEditor>("about"); | 2010 | about_field = self->mPanelFirstLife->getChild<LLTextEditor>("about"); |
2010 | if (about_field) | 2011 | if (about_field) |
2011 | { | 2012 | { |
2013 | about_field->clear(); | ||
2012 | if (self->mAllowEdit && (self->mAvatarID == agent_id)) | 2014 | if (self->mAllowEdit && (self->mAvatarID == agent_id)) |
2013 | { | 2015 | { |
2016 | about_field->setText(fl_about_text); | ||
2014 | } | 2017 | } |
2015 | else | 2018 | else |
2016 | { | 2019 | { |