diff options
author | David Seikel | 2011-06-04 00:17:28 +1000 |
---|---|---|
committer | David Seikel | 2011-06-04 00:17:28 +1000 |
commit | 492eaaf4eec82327116f2605e3d8becf94bec1b3 (patch) | |
tree | dcddd674cb4861445c3ec5aaa59325b99a437614 /linden/indra/newview/llfloaterreporter.cpp | |
parent | Set the real bare minimum prim size to 0.00001, as 0 sized objects cause bugs. (diff) | |
parent | Fixing the menu to actually use its color options reveals how broken the whol... (diff) | |
download | meta-impy-492eaaf4eec82327116f2605e3d8becf94bec1b3.zip meta-impy-492eaaf4eec82327116f2605e3d8becf94bec1b3.tar.gz meta-impy-492eaaf4eec82327116f2605e3d8becf94bec1b3.tar.bz2 meta-impy-492eaaf4eec82327116f2605e3d8becf94bec1b3.tar.xz |
Merge branch 'next' of git://github.com/jacek/imprudence into next
Conflicts (manually merged):
linden/indra/llcommon/llversionviewer.h
linden/indra/llvfs/lldir.cpp
linden/indra/llvfs/lldir_mac.cpp
linden/indra/newview/CMakeLists.txt
linden/indra/newview/English.lproj/InfoPlist.strings
linden/indra/newview/Info-Imprudence.plist
linden/indra/newview/Info-meta-impy.plist
linden/indra/newview/llappviewer.cpp
linden/indra/newview/llpanellogin.cpp
linden/indra/newview/packaging/mac/Info.plist.in
linden/indra/newview/res/viewerRes.rc
linden/indra/newview/skins/default/xui/en-us/floater_about.xml
linden/indra/newview/skins/default/xui/en-us/panel_preferences_advanced.xml
linden/indra/newview/skins/default/xui/en-us/panel_preferences_graphics1.xml
linden/indra/newview/skins/default/xui/en-us/panel_preferences_im.xml
linden/indra/newview/skins/default/xui/en-us/panel_preferences_skins.xml
linden/indra/newview/skins/default/xui/en-us/panel_preferences_web.xml
linden/indra/newview/skins/default/xui/zh/menu_viewer.xml
linden/indra/newview/skins/default/xui/zh/panel_group_general.xml
linden/indra/newview/viewer_manifest.py
linden/indra/newview/viewerversion.cpp
linden/indra/newview/viewerversion.h
linden/install.xml
Also some post merge tweaks.
Diffstat (limited to 'linden/indra/newview/llfloaterreporter.cpp')
-rw-r--r-- | linden/indra/newview/llfloaterreporter.cpp | 25 |
1 files changed, 9 insertions, 16 deletions
diff --git a/linden/indra/newview/llfloaterreporter.cpp b/linden/indra/newview/llfloaterreporter.cpp index 7f6386b..1911e4e 100644 --- a/linden/indra/newview/llfloaterreporter.cpp +++ b/linden/indra/newview/llfloaterreporter.cpp | |||
@@ -80,7 +80,7 @@ | |||
80 | #include "llselectmgr.h" | 80 | #include "llselectmgr.h" |
81 | #include "lluictrlfactory.h" | 81 | #include "lluictrlfactory.h" |
82 | #include "llviewernetwork.h" | 82 | #include "llviewernetwork.h" |
83 | #include "viewerversion.h" | 83 | #include "viewerinfo.h" |
84 | 84 | ||
85 | #include "llassetuploadresponders.h" | 85 | #include "llassetuploadresponders.h" |
86 | 86 | ||
@@ -742,13 +742,11 @@ LLSD LLFloaterReporter::gatherReport() | |||
742 | 742 | ||
743 | if ( mReportType == BUG_REPORT) | 743 | if ( mReportType == BUG_REPORT) |
744 | { | 744 | { |
745 | summary << short_platform << " V" << ViewerVersion::getLLMajorVersion() << "." | 745 | summary << short_platform << " " |
746 | << ViewerVersion::getLLMinorVersion() << "." | 746 | << ViewerInfo::terseInfo() |
747 | << ViewerVersion::getLLPatchVersion() << "." | 747 | << " (" << regionp->getName() << ")" |
748 | << ViewerVersion::getLLBuildVersion() | 748 | << "[" << category_name << "] " |
749 | << " (" << regionp->getName() << ")" | 749 | << "\"" << childGetValue("summary_edit").asString() << "\""; |
750 | << "[" << category_name << "] " | ||
751 | << "\"" << childGetValue("summary_edit").asString() << "\""; | ||
752 | } | 750 | } |
753 | else | 751 | else |
754 | { | 752 | { |
@@ -763,10 +761,7 @@ LLSD LLFloaterReporter::gatherReport() | |||
763 | std::ostringstream details; | 761 | std::ostringstream details; |
764 | if (mReportType != BUG_REPORT) | 762 | if (mReportType != BUG_REPORT) |
765 | { | 763 | { |
766 | details << "V" << ViewerVersion::getLLMajorVersion() << "." // client version moved to body of email for abuse reports | 764 | details << ViewerInfo::terseInfo() << std::endl << std::endl; |
767 | << ViewerVersion::getLLMinorVersion() << "." | ||
768 | << ViewerVersion::getLLPatchVersion() << "." | ||
769 | << ViewerVersion::getLLBuildVersion() << std::endl << std::endl; | ||
770 | } | 765 | } |
771 | std::string object_name = childGetText("object_name"); | 766 | std::string object_name = childGetText("object_name"); |
772 | std::string owner_name = childGetText("owner_name"); | 767 | std::string owner_name = childGetText("owner_name"); |
@@ -786,10 +781,8 @@ LLSD LLFloaterReporter::gatherReport() | |||
786 | 781 | ||
787 | std::string version_string; | 782 | std::string version_string; |
788 | version_string = llformat( | 783 | version_string = llformat( |
789 | "%d.%d.%d %s %s %s %s", | 784 | "%s %s %s %s %s", |
790 | ViewerVersion::getLLMajorVersion(), | 785 | ViewerInfo::terseInfo().c_str(), |
791 | ViewerVersion::getLLMinorVersion(), | ||
792 | ViewerVersion::getLLPatchVersion(), | ||
793 | platform, | 786 | platform, |
794 | gSysCPU.getFamily().c_str(), | 787 | gSysCPU.getFamily().c_str(), |
795 | gGLManager.mGLRenderer.c_str(), | 788 | gGLManager.mGLRenderer.c_str(), |