diff options
author | Robin Cornelius | 2010-10-10 21:53:54 +0100 |
---|---|---|
committer | Robin Cornelius | 2010-10-10 21:53:54 +0100 |
commit | c0034c520c6e61b64822e276316651ec6912bd98 (patch) | |
tree | 910442027b6a2c1406d80ca93949755b54badf5c /linden/indra/newview/llfloaterabout.cpp | |
parent | Use all those cores for compile (diff) | |
parent | Thickbrick Sleaford, Soft Linden: STORM-164 make gcc-4.4 happy about llvosky.h (diff) | |
download | meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.zip meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.gz meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.bz2 meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.xz |
Merge branch 'mccabe-plugins' into plugins_merge
Conflicts:
linden/doc/contributions.txt
linden/indra/cmake/GStreamer.cmake
linden/indra/cmake/LLMedia.cmake
linden/indra/cmake/OPENAL.cmake
linden/indra/llmedia/CMakeLists.txt
linden/indra/llprimitive/material_codes.h
linden/indra/newview/chatbar_as_cmdline.cpp
linden/indra/newview/llappviewer.cpp
linden/indra/newview/llfloatertos.cpp
linden/indra/newview/llstartup.cpp
linden/indra/newview/llviewerwindow.cpp
linden/indra/newview/llvoavatar.cpp
linden/indra/newview/pipeline.cpp
linden/indra/newview/pipeline.h
linden/indra/newview/viewer_manifest.py
linden/install.xml
Diffstat (limited to 'linden/indra/newview/llfloaterabout.cpp')
-rw-r--r-- | linden/indra/newview/llfloaterabout.cpp | 27 |
1 files changed, 5 insertions, 22 deletions
diff --git a/linden/indra/newview/llfloaterabout.cpp b/linden/indra/newview/llfloaterabout.cpp index 900f6e7..7aed095 100644 --- a/linden/indra/newview/llfloaterabout.cpp +++ b/linden/indra/newview/llfloaterabout.cpp | |||
@@ -42,7 +42,7 @@ | |||
42 | 42 | ||
43 | #include "llcurl.h" | 43 | #include "llcurl.h" |
44 | #include "llimagej2c.h" | 44 | #include "llimagej2c.h" |
45 | #include "audioengine.h" | 45 | #include "llaudioengine.h" |
46 | 46 | ||
47 | #include "hippoGridManager.h" | 47 | #include "hippoGridManager.h" |
48 | #include "llviewertexteditor.h" | 48 | #include "llviewertexteditor.h" |
@@ -57,7 +57,6 @@ | |||
57 | #include "lltrans.h" | 57 | #include "lltrans.h" |
58 | #include "llappviewer.h" | 58 | #include "llappviewer.h" |
59 | #include "llglheaders.h" | 59 | #include "llglheaders.h" |
60 | #include "llmediamanager.h" | ||
61 | #include "llwindow.h" | 60 | #include "llwindow.h" |
62 | #include "viewerversion.h" | 61 | #include "viewerversion.h" |
63 | 62 | ||
@@ -242,26 +241,10 @@ LLFloaterAbout::LLFloaterAbout() | |||
242 | 241 | ||
243 | support.append("\n"); | 242 | support.append("\n"); |
244 | 243 | ||
245 | LLMediaManager *mgr = LLMediaManager::getInstance(); | 244 | // TODO: Implement media plugin version query |
246 | if (mgr) | 245 | |
247 | { | 246 | support.append("Qt Webkit Version: 4.5.2 "); |
248 | LLMediaBase *gstreamer = mgr->createSourceFromMimeType("http", "audio/mpeg"); | 247 | support.append("\n"); |
249 | if (gstreamer) | ||
250 | { | ||
251 | support.append("GStreamer Version: "); | ||
252 | support.append( gstreamer->getVersion() ); | ||
253 | support.append("\n"); | ||
254 | } | ||
255 | |||
256 | LLMediaBase *media_source = mgr->createSourceFromMimeType("http", "text/html"); | ||
257 | if (media_source) | ||
258 | { | ||
259 | support.append("LLMozLib Version: "); | ||
260 | support.append(media_source->getVersion()); | ||
261 | support.append("\n"); | ||
262 | mgr->destroySource(media_source); | ||
263 | } | ||
264 | } | ||
265 | 248 | ||
266 | if (gPacketsIn > 0) | 249 | if (gPacketsIn > 0) |
267 | { | 250 | { |