aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/newview/lldrawpoolsky.h
diff options
context:
space:
mode:
authorRobin Cornelius2010-10-10 21:53:54 +0100
committerRobin Cornelius2010-10-10 21:53:54 +0100
commitc0034c520c6e61b64822e276316651ec6912bd98 (patch)
tree910442027b6a2c1406d80ca93949755b54badf5c /linden/indra/newview/lldrawpoolsky.h
parentUse all those cores for compile (diff)
parentThickbrick Sleaford, Soft Linden: STORM-164 make gcc-4.4 happy about llvosky.h (diff)
downloadmeta-impy-c0034c520c6e61b64822e276316651ec6912bd98.zip
meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.gz
meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.bz2
meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.xz
Merge branch 'mccabe-plugins' into plugins_merge
Conflicts: linden/doc/contributions.txt linden/indra/cmake/GStreamer.cmake linden/indra/cmake/LLMedia.cmake linden/indra/cmake/OPENAL.cmake linden/indra/llmedia/CMakeLists.txt linden/indra/llprimitive/material_codes.h linden/indra/newview/chatbar_as_cmdline.cpp linden/indra/newview/llappviewer.cpp linden/indra/newview/llfloatertos.cpp linden/indra/newview/llstartup.cpp linden/indra/newview/llviewerwindow.cpp linden/indra/newview/llvoavatar.cpp linden/indra/newview/pipeline.cpp linden/indra/newview/pipeline.h linden/indra/newview/viewer_manifest.py linden/install.xml
Diffstat (limited to 'linden/indra/newview/lldrawpoolsky.h')
-rw-r--r--linden/indra/newview/lldrawpoolsky.h4
1 files changed, 4 insertions, 0 deletions
diff --git a/linden/indra/newview/lldrawpoolsky.h b/linden/indra/newview/lldrawpoolsky.h
index 8595d73..f35b114 100644
--- a/linden/indra/newview/lldrawpoolsky.h
+++ b/linden/indra/newview/lldrawpoolsky.h
@@ -36,12 +36,14 @@
36#include "lldrawpool.h" 36#include "lldrawpool.h"
37 37
38class LLSkyTex; 38class LLSkyTex;
39class LLHeavenBody;
39class LLGLSLShader; 40class LLGLSLShader;
40 41
41class LLDrawPoolSky : public LLFacePool 42class LLDrawPoolSky : public LLFacePool
42{ 43{
43private: 44private:
44 LLSkyTex *mSkyTex; 45 LLSkyTex *mSkyTex;
46 LLHeavenBody *mHB[2]; // Sun and Moon
45 LLGLSLShader *mShader; 47 LLGLSLShader *mShader;
46 48
47public: 49public:
@@ -67,6 +69,8 @@ public:
67 /*virtual*/ void renderForSelect(); 69 /*virtual*/ void renderForSelect();
68 /*virtual*/ void endRenderPass(S32 pass); 70 /*virtual*/ void endRenderPass(S32 pass);
69 void setSkyTex(LLSkyTex* const st) { mSkyTex = st; } 71 void setSkyTex(LLSkyTex* const st) { mSkyTex = st; }
72 void setSun(LLHeavenBody* sun_flag) { mHB[0] = sun_flag; }
73 void setMoon(LLHeavenBody* moon) { mHB[1] = moon; }
70 74
71 void renderSkyCubeFace(U8 side); 75 void renderSkyCubeFace(U8 side);
72 void renderHeavenlyBody(U8 hb, LLFace* face); 76 void renderHeavenlyBody(U8 hb, LLFace* face);