diff options
author | Robin Cornelius | 2010-10-10 21:53:54 +0100 |
---|---|---|
committer | Robin Cornelius | 2010-10-10 21:53:54 +0100 |
commit | c0034c520c6e61b64822e276316651ec6912bd98 (patch) | |
tree | 910442027b6a2c1406d80ca93949755b54badf5c /linden/indra/newview/lldrawpoolbump.cpp | |
parent | Use all those cores for compile (diff) | |
parent | Thickbrick Sleaford, Soft Linden: STORM-164 make gcc-4.4 happy about llvosky.h (diff) | |
download | meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.zip meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.gz meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.bz2 meta-impy-c0034c520c6e61b64822e276316651ec6912bd98.tar.xz |
Merge branch 'mccabe-plugins' into plugins_merge
Conflicts:
linden/doc/contributions.txt
linden/indra/cmake/GStreamer.cmake
linden/indra/cmake/LLMedia.cmake
linden/indra/cmake/OPENAL.cmake
linden/indra/llmedia/CMakeLists.txt
linden/indra/llprimitive/material_codes.h
linden/indra/newview/chatbar_as_cmdline.cpp
linden/indra/newview/llappviewer.cpp
linden/indra/newview/llfloatertos.cpp
linden/indra/newview/llstartup.cpp
linden/indra/newview/llviewerwindow.cpp
linden/indra/newview/llvoavatar.cpp
linden/indra/newview/pipeline.cpp
linden/indra/newview/pipeline.h
linden/indra/newview/viewer_manifest.py
linden/install.xml
Diffstat (limited to 'linden/indra/newview/lldrawpoolbump.cpp')
-rw-r--r-- | linden/indra/newview/lldrawpoolbump.cpp | 25 |
1 files changed, 16 insertions, 9 deletions
diff --git a/linden/indra/newview/lldrawpoolbump.cpp b/linden/indra/newview/lldrawpoolbump.cpp index 93fadca..e14b34d 100644 --- a/linden/indra/newview/lldrawpoolbump.cpp +++ b/linden/indra/newview/lldrawpoolbump.cpp | |||
@@ -140,7 +140,7 @@ void LLStandardBumpmap::restoreGL() | |||
140 | return; | 140 | return; |
141 | } | 141 | } |
142 | 142 | ||
143 | llinfos << "Loading bumpmap: " << bump_file << " from viewerart" << llendl; | 143 | // llinfos << "Loading bumpmap: " << bump_file << " from viewerart" << llendl; |
144 | gStandardBumpmapList[LLStandardBumpmap::sStandardBumpmapCount].mLabel = label; | 144 | gStandardBumpmapList[LLStandardBumpmap::sStandardBumpmapCount].mLabel = label; |
145 | gStandardBumpmapList[LLStandardBumpmap::sStandardBumpmapCount].mImage = | 145 | gStandardBumpmapList[LLStandardBumpmap::sStandardBumpmapCount].mImage = |
146 | gImageList.getImageFromFile(bump_file, | 146 | gImageList.getImageFromFile(bump_file, |
@@ -310,8 +310,8 @@ void LLDrawPoolBump::endRenderPass(S32 pass) | |||
310 | void LLDrawPoolBump::beginShiny(bool invisible) | 310 | void LLDrawPoolBump::beginShiny(bool invisible) |
311 | { | 311 | { |
312 | LLFastTimer t(LLFastTimer::FTM_RENDER_SHINY); | 312 | LLFastTimer t(LLFastTimer::FTM_RENDER_SHINY); |
313 | if ((!invisible && !gPipeline.hasRenderBatches(LLRenderPass::PASS_SHINY))|| | 313 | if (!invisible && !gPipeline.hasRenderBatches(LLRenderPass::PASS_SHINY)|| |
314 | (invisible && !gPipeline.hasRenderBatches(LLRenderPass::PASS_INVISI_SHINY))) | 314 | invisible && !gPipeline.hasRenderBatches(LLRenderPass::PASS_INVISI_SHINY)) |
315 | { | 315 | { |
316 | return; | 316 | return; |
317 | } | 317 | } |
@@ -385,8 +385,8 @@ void LLDrawPoolBump::beginShiny(bool invisible) | |||
385 | void LLDrawPoolBump::renderShiny(bool invisible) | 385 | void LLDrawPoolBump::renderShiny(bool invisible) |
386 | { | 386 | { |
387 | LLFastTimer t(LLFastTimer::FTM_RENDER_SHINY); | 387 | LLFastTimer t(LLFastTimer::FTM_RENDER_SHINY); |
388 | if ((!invisible && !gPipeline.hasRenderBatches(LLRenderPass::PASS_SHINY))|| | 388 | if (!invisible && !gPipeline.hasRenderBatches(LLRenderPass::PASS_SHINY)|| |
389 | (invisible && !gPipeline.hasRenderBatches(LLRenderPass::PASS_INVISI_SHINY))) | 389 | invisible && !gPipeline.hasRenderBatches(LLRenderPass::PASS_INVISI_SHINY)) |
390 | { | 390 | { |
391 | return; | 391 | return; |
392 | } | 392 | } |
@@ -412,8 +412,8 @@ void LLDrawPoolBump::renderShiny(bool invisible) | |||
412 | void LLDrawPoolBump::endShiny(bool invisible) | 412 | void LLDrawPoolBump::endShiny(bool invisible) |
413 | { | 413 | { |
414 | LLFastTimer t(LLFastTimer::FTM_RENDER_SHINY); | 414 | LLFastTimer t(LLFastTimer::FTM_RENDER_SHINY); |
415 | if ((!invisible && !gPipeline.hasRenderBatches(LLRenderPass::PASS_SHINY))|| | 415 | if (!invisible && !gPipeline.hasRenderBatches(LLRenderPass::PASS_SHINY)|| |
416 | (invisible && !gPipeline.hasRenderBatches(LLRenderPass::PASS_INVISI_SHINY))) | 416 | invisible && !gPipeline.hasRenderBatches(LLRenderPass::PASS_INVISI_SHINY)) |
417 | { | 417 | { |
418 | return; | 418 | return; |
419 | } | 419 | } |
@@ -573,7 +573,11 @@ BOOL LLDrawPoolBump::bindBumpMap(LLDrawInfo& params, S32 channel) | |||
573 | LLImageGL* bump = NULL; | 573 | LLImageGL* bump = NULL; |
574 | 574 | ||
575 | U8 bump_code = params.mBump; | 575 | U8 bump_code = params.mBump; |
576 | LLViewerImage* tex = params.mTexture; | 576 | LLViewerImage* tex = params.mViewerTexture; |
577 | if(!tex) | ||
578 | { | ||
579 | return FALSE ; | ||
580 | } | ||
577 | 581 | ||
578 | switch( bump_code ) | 582 | switch( bump_code ) |
579 | { | 583 | { |
@@ -1227,7 +1231,10 @@ void LLDrawPoolBump::pushBatch(LLDrawInfo& params, U32 mask, BOOL texture) | |||
1227 | if (params.mTexture.notNull()) | 1231 | if (params.mTexture.notNull()) |
1228 | { | 1232 | { |
1229 | gGL.getTexUnit(diffuse_channel)->bind(params.mTexture.get()); | 1233 | gGL.getTexUnit(diffuse_channel)->bind(params.mTexture.get()); |
1230 | //params.mTexture->addTextureStats(params.mVSize); | 1234 | if(params.mViewerTexture.notNull()) |
1235 | { | ||
1236 | params.mViewerTexture->addTextureStats(params.mVSize); | ||
1237 | } | ||
1231 | } | 1238 | } |
1232 | else | 1239 | else |
1233 | { | 1240 | { |