diff options
author | David Seikel | 2011-06-04 00:17:28 +1000 |
---|---|---|
committer | David Seikel | 2011-06-04 00:17:28 +1000 |
commit | 492eaaf4eec82327116f2605e3d8becf94bec1b3 (patch) | |
tree | dcddd674cb4861445c3ec5aaa59325b99a437614 /linden/indra/newview/llappviewer.cpp | |
parent | Set the real bare minimum prim size to 0.00001, as 0 sized objects cause bugs. (diff) | |
parent | Fixing the menu to actually use its color options reveals how broken the whol... (diff) | |
download | meta-impy-492eaaf4eec82327116f2605e3d8becf94bec1b3.zip meta-impy-492eaaf4eec82327116f2605e3d8becf94bec1b3.tar.gz meta-impy-492eaaf4eec82327116f2605e3d8becf94bec1b3.tar.bz2 meta-impy-492eaaf4eec82327116f2605e3d8becf94bec1b3.tar.xz |
Merge branch 'next' of git://github.com/jacek/imprudence into next
Conflicts (manually merged):
linden/indra/llcommon/llversionviewer.h
linden/indra/llvfs/lldir.cpp
linden/indra/llvfs/lldir_mac.cpp
linden/indra/newview/CMakeLists.txt
linden/indra/newview/English.lproj/InfoPlist.strings
linden/indra/newview/Info-Imprudence.plist
linden/indra/newview/Info-meta-impy.plist
linden/indra/newview/llappviewer.cpp
linden/indra/newview/llpanellogin.cpp
linden/indra/newview/packaging/mac/Info.plist.in
linden/indra/newview/res/viewerRes.rc
linden/indra/newview/skins/default/xui/en-us/floater_about.xml
linden/indra/newview/skins/default/xui/en-us/panel_preferences_advanced.xml
linden/indra/newview/skins/default/xui/en-us/panel_preferences_graphics1.xml
linden/indra/newview/skins/default/xui/en-us/panel_preferences_im.xml
linden/indra/newview/skins/default/xui/en-us/panel_preferences_skins.xml
linden/indra/newview/skins/default/xui/en-us/panel_preferences_web.xml
linden/indra/newview/skins/default/xui/zh/menu_viewer.xml
linden/indra/newview/skins/default/xui/zh/panel_group_general.xml
linden/indra/newview/viewer_manifest.py
linden/indra/newview/viewerversion.cpp
linden/indra/newview/viewerversion.h
linden/install.xml
Also some post merge tweaks.
Diffstat (limited to 'linden/indra/newview/llappviewer.cpp')
-rw-r--r-- | linden/indra/newview/llappviewer.cpp | 57 |
1 files changed, 25 insertions, 32 deletions
diff --git a/linden/indra/newview/llappviewer.cpp b/linden/indra/newview/llappviewer.cpp index 09b4eda..a026391 100644 --- a/linden/indra/newview/llappviewer.cpp +++ b/linden/indra/newview/llappviewer.cpp | |||
@@ -154,7 +154,7 @@ | |||
154 | #include "llflexibleobject.h" | 154 | #include "llflexibleobject.h" |
155 | #include "llvosurfacepatch.h" | 155 | #include "llvosurfacepatch.h" |
156 | #include "llslider.h" | 156 | #include "llslider.h" |
157 | #include "viewerversion.h" | 157 | #include "viewerinfo.h" |
158 | 158 | ||
159 | // includes for idle() idleShutdown() | 159 | // includes for idle() idleShutdown() |
160 | #include "floaterao.h" | 160 | #include "floaterao.h" |
@@ -602,7 +602,7 @@ bool LLAppViewer::init() | |||
602 | 602 | ||
603 | // Need to do this initialization before we do anything else, since anything | 603 | // Need to do this initialization before we do anything else, since anything |
604 | // that touches files should really go through the lldir API | 604 | // that touches files should really go through the lldir API |
605 | gDirUtilp->initAppDirs(ViewerVersion::getImpViewerName()); | 605 | gDirUtilp->initAppDirs(ViewerInfo::viewerName()); |
606 | // set skin search path to default, will be overridden later | 606 | // set skin search path to default, will be overridden later |
607 | // this allows simple skinned file lookups to work | 607 | // this allows simple skinned file lookups to work |
608 | gDirUtilp->setSkinFolder("default"); | 608 | gDirUtilp->setSkinFolder("default"); |
@@ -624,15 +624,8 @@ bool LLAppViewer::init() | |||
624 | writeSystemInfo(); | 624 | writeSystemInfo(); |
625 | 625 | ||
626 | 626 | ||
627 | // Build a string representing the current version number. | 627 | // String representing the current version name/number. |
628 | gCurrentVersion = llformat( | 628 | gCurrentVersion = ViewerInfo::terseInfo(); |
629 | "%s %d.%d.%d.%d", | ||
630 | gSavedSettings.getString("VersionChannelName").c_str(), | ||
631 | ViewerVersion::getImpMajorVersion(), | ||
632 | ViewerVersion::getImpMinorVersion(), | ||
633 | ViewerVersion::getImpPatchVersion(), | ||
634 | 0 // our 'build number' | ||
635 | ); | ||
636 | 629 | ||
637 | ////////////////////////////////////////////////////////////////////////////// | 630 | ////////////////////////////////////////////////////////////////////////////// |
638 | ////////////////////////////////////////////////////////////////////////////// | 631 | ////////////////////////////////////////////////////////////////////////////// |
@@ -1800,9 +1793,6 @@ std::string LLAppViewer::getSettingsFilename(const std::string& location_key, | |||
1800 | 1793 | ||
1801 | bool LLAppViewer::initConfiguration() | 1794 | bool LLAppViewer::initConfiguration() |
1802 | { | 1795 | { |
1803 | // init Imprudence version - MC | ||
1804 | ViewerVersion::initViewerVersion(); | ||
1805 | |||
1806 | //Set up internal pointers | 1796 | //Set up internal pointers |
1807 | gSettings[sGlobalSettingsName] = &gSavedSettings; | 1797 | gSettings[sGlobalSettingsName] = &gSavedSettings; |
1808 | gSettings[sPerAccountSettingsName] = &gSavedPerAccountSettings; | 1798 | gSettings[sPerAccountSettingsName] = &gSavedPerAccountSettings; |
@@ -1848,9 +1838,9 @@ bool LLAppViewer::initConfiguration() | |||
1848 | // - set procedural settings | 1838 | // - set procedural settings |
1849 | gSavedSettings.setString("ClientSettingsFile", | 1839 | gSavedSettings.setString("ClientSettingsFile", |
1850 | // gDirUtilp->getExpandedFilename(LL_PATH_USER_SETTINGS, getSettingsFilename("Default", "Global"))); | 1840 | // gDirUtilp->getExpandedFilename(LL_PATH_USER_SETTINGS, getSettingsFilename("Default", "Global"))); |
1851 | gDirUtilp->getExpandedFilename(LL_PATH_USER_SETTINGS, "settings_meta-impy_experimental.xml")); | 1841 | gDirUtilp->getExpandedFilename(LL_PATH_USER_SETTINGS, "settings_meta-impy.xml")); |
1852 | 1842 | ||
1853 | gSavedSettings.setString("VersionChannelName", ViewerVersion::getImpViewerName()); | 1843 | gSavedSettings.setString("VersionChannelName", ViewerInfo::nameWithVariant()); |
1854 | 1844 | ||
1855 | //*FIX:Mani - Set default to disabling watchdog mainloop | 1845 | //*FIX:Mani - Set default to disabling watchdog mainloop |
1856 | // timeout for mac and linux. There is no call stack info | 1846 | // timeout for mac and linux. There is no call stack info |
@@ -2096,7 +2086,7 @@ bool LLAppViewer::initConfiguration() | |||
2096 | mYieldTime = gSavedSettings.getS32("YieldTime"); | 2086 | mYieldTime = gSavedSettings.getS32("YieldTime"); |
2097 | 2087 | ||
2098 | // XUI:translate | 2088 | // XUI:translate |
2099 | gSecondLife = ViewerVersion::getImpViewerName(); | 2089 | gSecondLife = ViewerInfo::viewerName(); |
2100 | 2090 | ||
2101 | // Read skin/branding settings if specified. | 2091 | // Read skin/branding settings if specified. |
2102 | //if (! gDirUtilp->getSkinDir().empty() ) | 2092 | //if (! gDirUtilp->getSkinDir().empty() ) |
@@ -2468,11 +2458,12 @@ void LLAppViewer::writeSystemInfo() | |||
2468 | { | 2458 | { |
2469 | gDebugInfo["SLLog"] = LLError::logFileName(); | 2459 | gDebugInfo["SLLog"] = LLError::logFileName(); |
2470 | 2460 | ||
2471 | gDebugInfo["ClientInfo"]["Name"] = gSavedSettings.getString("VersionChannelName"); | 2461 | gDebugInfo["ClientInfo"]["Name"] = ViewerInfo::viewerName(); |
2472 | gDebugInfo["ClientInfo"]["MajorVersion"] = ViewerVersion::getImpMajorVersion(); | 2462 | gDebugInfo["ClientInfo"]["MajorVersion"] = ViewerInfo::versionMajor(); |
2473 | gDebugInfo["ClientInfo"]["MinorVersion"] = ViewerVersion::getImpMinorVersion(); | 2463 | gDebugInfo["ClientInfo"]["MinorVersion"] = ViewerInfo::versionMinor(); |
2474 | gDebugInfo["ClientInfo"]["PatchVersion"] = ViewerVersion::getImpPatchVersion(); | 2464 | gDebugInfo["ClientInfo"]["PatchVersion"] = ViewerInfo::versionPatch(); |
2475 | gDebugInfo["ClientInfo"]["BuildVersion"] = 0; | 2465 | gDebugInfo["ClientInfo"]["ReleaseVersion"] = ViewerInfo::versionRelease(); |
2466 | gDebugInfo["ClientInfo"]["ExtraVersion"] = ViewerInfo::versionExtra(); | ||
2476 | 2467 | ||
2477 | gDebugInfo["CAFilename"] = gDirUtilp->getCAFile(); | 2468 | gDebugInfo["CAFilename"] = gDirUtilp->getCAFile(); |
2478 | 2469 | ||
@@ -2557,11 +2548,12 @@ void LLAppViewer::handleViewerCrash() | |||
2557 | 2548 | ||
2558 | //We already do this in writeSystemInfo(), but we do it again here to make /sure/ we have a version | 2549 | //We already do this in writeSystemInfo(), but we do it again here to make /sure/ we have a version |
2559 | //to check against no matter what | 2550 | //to check against no matter what |
2560 | gDebugInfo["ClientInfo"]["Name"] = gSavedSettings.getString("VersionChannelName"); | 2551 | gDebugInfo["ClientInfo"]["Name"] = ViewerInfo::viewerName(); |
2561 | gDebugInfo["ClientInfo"]["MajorVersion"] = ViewerVersion::getImpMajorVersion(); | 2552 | gDebugInfo["ClientInfo"]["MajorVersion"] = ViewerInfo::versionMajor(); |
2562 | gDebugInfo["ClientInfo"]["MinorVersion"] = ViewerVersion::getImpMinorVersion(); | 2553 | gDebugInfo["ClientInfo"]["MinorVersion"] = ViewerInfo::versionMinor(); |
2563 | gDebugInfo["ClientInfo"]["PatchVersion"] = ViewerVersion::getImpPatchVersion(); | 2554 | gDebugInfo["ClientInfo"]["PatchVersion"] = ViewerInfo::versionPatch(); |
2564 | gDebugInfo["ClientInfo"]["BuildVersion"] = 0; | 2555 | gDebugInfo["ClientInfo"]["ReleaseVersion"] = ViewerInfo::versionRelease(); |
2556 | gDebugInfo["ClientInfo"]["ExtraVersion"] = ViewerInfo::versionExtra(); | ||
2565 | 2557 | ||
2566 | LLParcel* parcel = LLViewerParcelMgr::getInstance()->getAgentParcel(); | 2558 | LLParcel* parcel = LLViewerParcelMgr::getInstance()->getAgentParcel(); |
2567 | if ( parcel && parcel->getMusicURL()[0]) | 2559 | if ( parcel && parcel->getMusicURL()[0]) |
@@ -4341,11 +4333,12 @@ void LLAppViewer::handleLoginComplete() | |||
4341 | initMainloopTimeout("Mainloop Init"); | 4333 | initMainloopTimeout("Mainloop Init"); |
4342 | 4334 | ||
4343 | // Store some data to DebugInfo in case of a freeze. | 4335 | // Store some data to DebugInfo in case of a freeze. |
4344 | gDebugInfo["ClientInfo"]["Name"] = gSavedSettings.getString("VersionChannelName"); | 4336 | gDebugInfo["ClientInfo"]["Name"] = ViewerInfo::viewerName(); |
4345 | gDebugInfo["ClientInfo"]["MajorVersion"] = ViewerVersion::getImpMajorVersion(); | 4337 | gDebugInfo["ClientInfo"]["MajorVersion"] = ViewerInfo::versionMajor(); |
4346 | gDebugInfo["ClientInfo"]["MinorVersion"] = ViewerVersion::getImpMinorVersion(); | 4338 | gDebugInfo["ClientInfo"]["MinorVersion"] = ViewerInfo::versionMinor(); |
4347 | gDebugInfo["ClientInfo"]["PatchVersion"] = ViewerVersion::getImpPatchVersion(); | 4339 | gDebugInfo["ClientInfo"]["PatchVersion"] = ViewerInfo::versionPatch(); |
4348 | gDebugInfo["ClientInfo"]["BuildVersion"] = 0; | 4340 | gDebugInfo["ClientInfo"]["ReleaseVersion"] = ViewerInfo::versionRelease(); |
4341 | gDebugInfo["ClientInfo"]["ExtraVersion"] = ViewerInfo::versionExtra(); | ||
4349 | 4342 | ||
4350 | gDebugInfo["SettingsFilename"] = gSavedSettings.getString("ClientSettingsFile"); | 4343 | gDebugInfo["SettingsFilename"] = gSavedSettings.getString("ClientSettingsFile"); |
4351 | gDebugInfo["CAFilename"] = gDirUtilp->getCAFile(); | 4344 | gDebugInfo["CAFilename"] = gDirUtilp->getCAFile(); |