aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/newview/controllerpasswords.h
diff options
context:
space:
mode:
authorJacek Antonelli2009-09-09 12:27:11 -0500
committerJacek Antonelli2009-09-10 02:26:28 -0500
commite944c5086e47e92e7952e5a43c68f01108899656 (patch)
treec47ff63c4dcae473cd07a0dbcbc9d52636e6061e /linden/indra/newview/controllerpasswords.h
parentCommented out Linux tarball building. (diff)
parentlooks like working now (diff)
downloadmeta-impy-e944c5086e47e92e7952e5a43c68f01108899656.zip
meta-impy-e944c5086e47e92e7952e5a43c68f01108899656.tar.gz
meta-impy-e944c5086e47e92e7952e5a43c68f01108899656.tar.bz2
meta-impy-e944c5086e47e92e7952e5a43c68f01108899656.tar.xz
Merged 'armin/grid-manager5' into login-manager
Conflicts: linden/indra/newview/CMakeLists.txt linden/indra/newview/llpanellogin.cpp
Diffstat (limited to 'linden/indra/newview/controllerpasswords.h')
-rw-r--r--linden/indra/newview/controllerpasswords.h37
1 files changed, 37 insertions, 0 deletions
diff --git a/linden/indra/newview/controllerpasswords.h b/linden/indra/newview/controllerpasswords.h
new file mode 100644
index 0000000..e656659
--- /dev/null
+++ b/linden/indra/newview/controllerpasswords.h
@@ -0,0 +1,37 @@
1/*
2 * controllerpasswords.h
3 * SecondLife
4 *
5 * Created by RMS on 8/5/08.
6 *
7 */
8
9#include <string>
10#include <list>
11#include "llscrolllistctrl.h"
12#include "llbutton.h"
13#include "authentication_model.h"
14
15#ifndef PL_controllerpasswords_H
16#define PL_controllerpasswords_H
17class PasswordsPrefPanel;
18
19class PasswordsController
20{
21public:
22 PasswordsController(PasswordsPrefPanel *panel);
23 virtual ~PasswordsController();
24 virtual void update();
25protected:
26 LLScrollListCtrl *accounts_list;
27 LLButton *remove_btn;
28private:
29 AuthenticationModel::connection_t mModelConnection;
30
31 PasswordsPrefPanel *mPanel;
32 AuthenticationModel *mModel;
33
34 std::list<std::string> mAccountData;
35};
36
37#endif // PL_controllerpasswords_H