diff options
author | Jacek Antonelli | 2009-04-30 13:04:20 -0500 |
---|---|---|
committer | Jacek Antonelli | 2009-04-30 13:07:16 -0500 |
commit | ca8149ca6d157eb4b5fc8ba0e5ba3a6e56f72e7e (patch) | |
tree | 8348301d0ac44a524f1819b777686bf086907d76 /linden/indra/newview/CMakeLists.txt | |
parent | Second Life viewer sources 1.22.11 (diff) | |
download | meta-impy-ca8149ca6d157eb4b5fc8ba0e5ba3a6e56f72e7e.zip meta-impy-ca8149ca6d157eb4b5fc8ba0e5ba3a6e56f72e7e.tar.gz meta-impy-ca8149ca6d157eb4b5fc8ba0e5ba3a6e56f72e7e.tar.bz2 meta-impy-ca8149ca6d157eb4b5fc8ba0e5ba3a6e56f72e7e.tar.xz |
Second Life viewer sources 1.23.0-RC
Diffstat (limited to 'linden/indra/newview/CMakeLists.txt')
-rw-r--r-- | linden/indra/newview/CMakeLists.txt | 86 |
1 files changed, 68 insertions, 18 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt index b95ba37..a7d6c8f 100644 --- a/linden/indra/newview/CMakeLists.txt +++ b/linden/indra/newview/CMakeLists.txt | |||
@@ -11,6 +11,7 @@ include(ELFIO) | |||
11 | include(FMOD) | 11 | include(FMOD) |
12 | include(OPENAL) | 12 | include(OPENAL) |
13 | include(FindOpenGL) | 13 | include(FindOpenGL) |
14 | include(LLAddBuildTest) | ||
14 | include(LLAudio) | 15 | include(LLAudio) |
15 | include(LLCharacter) | 16 | include(LLCharacter) |
16 | include(LLCommon) | 17 | include(LLCommon) |
@@ -30,6 +31,7 @@ include(LScript) | |||
30 | include(Linking) | 31 | include(Linking) |
31 | include(Mozlib) | 32 | include(Mozlib) |
32 | include(NDOF) | 33 | include(NDOF) |
34 | include(GooglePerfTools) | ||
33 | include(TemplateCheck) | 35 | include(TemplateCheck) |
34 | include(UI) | 36 | include(UI) |
35 | include(UnixInstall) | 37 | include(UnixInstall) |
@@ -41,6 +43,7 @@ if (WINDOWS) | |||
41 | endif (WINDOWS) | 43 | endif (WINDOWS) |
42 | 44 | ||
43 | include_directories( | 45 | include_directories( |
46 | ${DBUSGLIB_INCLUDE_DIRS} | ||
44 | ${ELFIO_INCLUDE_DIR} | 47 | ${ELFIO_INCLUDE_DIR} |
45 | ${LLAUDIO_INCLUDE_DIRS} | 48 | ${LLAUDIO_INCLUDE_DIRS} |
46 | ${LLCHARACTER_INCLUDE_DIRS} | 49 | ${LLCHARACTER_INCLUDE_DIRS} |
@@ -62,6 +65,7 @@ include_directories( | |||
62 | 65 | ||
63 | set(viewer_SOURCE_FILES | 66 | set(viewer_SOURCE_FILES |
64 | llagent.cpp | 67 | llagent.cpp |
68 | llagentaccess.cpp | ||
65 | llagentdata.cpp | 69 | llagentdata.cpp |
66 | llagentlanguage.cpp | 70 | llagentlanguage.cpp |
67 | llagentpilot.cpp | 71 | llagentpilot.cpp |
@@ -127,6 +131,7 @@ set(viewer_SOURCE_FILES | |||
127 | llfloateravatartextures.cpp | 131 | llfloateravatartextures.cpp |
128 | llfloaterbeacons.cpp | 132 | llfloaterbeacons.cpp |
129 | llfloaterbuildoptions.cpp | 133 | llfloaterbuildoptions.cpp |
134 | llfloaterbulkpermission.cpp | ||
130 | llfloaterbump.cpp | 135 | llfloaterbump.cpp |
131 | llfloaterbuycontents.cpp | 136 | llfloaterbuycontents.cpp |
132 | llfloaterbuy.cpp | 137 | llfloaterbuy.cpp |
@@ -136,7 +141,6 @@ set(viewer_SOURCE_FILES | |||
136 | llfloaterchat.cpp | 141 | llfloaterchat.cpp |
137 | llfloaterchatterbox.cpp | 142 | llfloaterchatterbox.cpp |
138 | llfloaterclassified.cpp | 143 | llfloaterclassified.cpp |
139 | llfloaterclothing.cpp | ||
140 | llfloatercolorpicker.cpp | 144 | llfloatercolorpicker.cpp |
141 | llfloatercustomize.cpp | 145 | llfloatercustomize.cpp |
142 | llfloaterdaycycle.cpp | 146 | llfloaterdaycycle.cpp |
@@ -145,14 +149,18 @@ set(viewer_SOURCE_FILES | |||
145 | llfloaterenvsettings.cpp | 149 | llfloaterenvsettings.cpp |
146 | llfloaterevent.cpp | 150 | llfloaterevent.cpp |
147 | llfloaterfriends.cpp | 151 | llfloaterfriends.cpp |
152 | llfloaterfonttest.cpp | ||
148 | llfloatergesture.cpp | 153 | llfloatergesture.cpp |
149 | llfloatergodtools.cpp | 154 | llfloatergodtools.cpp |
150 | llfloatergroupinfo.cpp | 155 | llfloatergroupinfo.cpp |
151 | llfloatergroupinvite.cpp | 156 | llfloatergroupinvite.cpp |
152 | llfloatergroups.cpp | 157 | llfloatergroups.cpp |
158 | llfloaterhandler.cpp | ||
153 | llfloaterhardwaresettings.cpp | 159 | llfloaterhardwaresettings.cpp |
154 | llfloaterhtml.cpp | 160 | llfloaterhtml.cpp |
161 | llfloaterhtmlcurrency.cpp | ||
155 | llfloaterhtmlhelp.cpp | 162 | llfloaterhtmlhelp.cpp |
163 | llfloaterhtmlsimple.cpp | ||
156 | llfloaterhud.cpp | 164 | llfloaterhud.cpp |
157 | llfloaterimagepreview.cpp | 165 | llfloaterimagepreview.cpp |
158 | llfloaterinspect.cpp | 166 | llfloaterinspect.cpp |
@@ -166,9 +174,12 @@ set(viewer_SOURCE_FILES | |||
166 | llfloatermute.cpp | 174 | llfloatermute.cpp |
167 | llfloaternamedesc.cpp | 175 | llfloaternamedesc.cpp |
168 | llfloaternewim.cpp | 176 | llfloaternewim.cpp |
177 | llfloaternotificationsconsole.cpp | ||
178 | llfloaterobjectiminfo.cpp | ||
169 | llfloateropenobject.cpp | 179 | llfloateropenobject.cpp |
170 | llfloaterparcel.cpp | 180 | llfloaterparcel.cpp |
171 | llfloaterpermissionsmgr.cpp | 181 | llfloaterpermissionsmgr.cpp |
182 | llfloaterperms.cpp | ||
172 | llfloaterpostcard.cpp | 183 | llfloaterpostcard.cpp |
173 | llfloaterpostprocess.cpp | 184 | llfloaterpostprocess.cpp |
174 | llfloaterpreference.cpp | 185 | llfloaterpreference.cpp |
@@ -195,7 +206,6 @@ set(viewer_SOURCE_FILES | |||
195 | llfollowcam.cpp | 206 | llfollowcam.cpp |
196 | llframestats.cpp | 207 | llframestats.cpp |
197 | llframestatview.cpp | 208 | llframestatview.cpp |
198 | llgenepool.cpp | ||
199 | llgesturemgr.cpp | 209 | llgesturemgr.cpp |
200 | llgivemoney.cpp | 210 | llgivemoney.cpp |
201 | llglsandbox.cpp | 211 | llglsandbox.cpp |
@@ -224,6 +234,7 @@ set(viewer_SOURCE_FILES | |||
224 | lljoystickbutton.cpp | 234 | lljoystickbutton.cpp |
225 | lllandmarklist.cpp | 235 | lllandmarklist.cpp |
226 | lllogchat.cpp | 236 | lllogchat.cpp |
237 | llloginhandler.cpp | ||
227 | llmanip.cpp | 238 | llmanip.cpp |
228 | llmaniprotate.cpp | 239 | llmaniprotate.cpp |
229 | llmanipscale.cpp | 240 | llmanipscale.cpp |
@@ -300,6 +311,7 @@ set(viewer_SOURCE_FILES | |||
300 | llpreviewscript.cpp | 311 | llpreviewscript.cpp |
301 | llpreviewsound.cpp | 312 | llpreviewsound.cpp |
302 | llpreviewtexture.cpp | 313 | llpreviewtexture.cpp |
314 | llproductinforequest.cpp | ||
303 | llprogressview.cpp | 315 | llprogressview.cpp |
304 | llregionposition.cpp | 316 | llregionposition.cpp |
305 | llremoteparcelrequest.cpp | 317 | llremoteparcelrequest.cpp |
@@ -397,6 +409,7 @@ set(viewer_SOURCE_FILES | |||
397 | llvlcomposition.cpp | 409 | llvlcomposition.cpp |
398 | llvlmanager.cpp | 410 | llvlmanager.cpp |
399 | llvoavatar.cpp | 411 | llvoavatar.cpp |
412 | llvoavatardefines.cpp | ||
400 | llvocache.cpp | 413 | llvocache.cpp |
401 | llvoclouds.cpp | 414 | llvoclouds.cpp |
402 | llvograss.cpp | 415 | llvograss.cpp |
@@ -455,6 +468,7 @@ set(viewer_HEADER_FILES | |||
455 | ViewerInstall.cmake | 468 | ViewerInstall.cmake |
456 | 469 | ||
457 | llagent.h | 470 | llagent.h |
471 | llagentaccess.h | ||
458 | llagentdata.h | 472 | llagentdata.h |
459 | llagentlanguage.h | 473 | llagentlanguage.h |
460 | llagentpilot.h | 474 | llagentpilot.h |
@@ -522,6 +536,7 @@ set(viewer_HEADER_FILES | |||
522 | llfloateravatartextures.h | 536 | llfloateravatartextures.h |
523 | llfloaterbeacons.h | 537 | llfloaterbeacons.h |
524 | llfloaterbuildoptions.h | 538 | llfloaterbuildoptions.h |
539 | llfloaterbulkpermission.h | ||
525 | llfloaterbump.h | 540 | llfloaterbump.h |
526 | llfloaterbuy.h | 541 | llfloaterbuy.h |
527 | llfloaterbuycontents.h | 542 | llfloaterbuycontents.h |
@@ -531,7 +546,6 @@ set(viewer_HEADER_FILES | |||
531 | llfloaterchat.h | 546 | llfloaterchat.h |
532 | llfloaterchatterbox.h | 547 | llfloaterchatterbox.h |
533 | llfloaterclassified.h | 548 | llfloaterclassified.h |
534 | llfloaterclothing.h | ||
535 | llfloatercolorpicker.h | 549 | llfloatercolorpicker.h |
536 | llfloatercustomize.h | 550 | llfloatercustomize.h |
537 | llfloaterdaycycle.h | 551 | llfloaterdaycycle.h |
@@ -539,15 +553,19 @@ set(viewer_HEADER_FILES | |||
539 | llfloatereditui.h | 553 | llfloatereditui.h |
540 | llfloaterenvsettings.h | 554 | llfloaterenvsettings.h |
541 | llfloaterevent.h | 555 | llfloaterevent.h |
556 | llfloaterfonttest.h | ||
542 | llfloaterfriends.h | 557 | llfloaterfriends.h |
543 | llfloatergesture.h | 558 | llfloatergesture.h |
544 | llfloatergodtools.h | 559 | llfloatergodtools.h |
545 | llfloatergroupinfo.h | 560 | llfloatergroupinfo.h |
546 | llfloatergroupinvite.h | 561 | llfloatergroupinvite.h |
547 | llfloatergroups.h | 562 | llfloatergroups.h |
563 | llfloaterhandler.h | ||
548 | llfloaterhardwaresettings.h | 564 | llfloaterhardwaresettings.h |
549 | llfloaterhtml.h | 565 | llfloaterhtml.h |
566 | llfloaterhtmlcurrency.h | ||
550 | llfloaterhtmlhelp.h | 567 | llfloaterhtmlhelp.h |
568 | llfloaterhtmlsimple.h | ||
551 | llfloaterhud.h | 569 | llfloaterhud.h |
552 | llfloaterimagepreview.h | 570 | llfloaterimagepreview.h |
553 | llfloaterinspect.h | 571 | llfloaterinspect.h |
@@ -561,12 +579,15 @@ set(viewer_HEADER_FILES | |||
561 | llfloatermute.h | 579 | llfloatermute.h |
562 | llfloaternamedesc.h | 580 | llfloaternamedesc.h |
563 | llfloaternewim.h | 581 | llfloaternewim.h |
582 | llfloaternotificationsconsole.h | ||
583 | llfloaterobjectiminfo.h | ||
564 | llfloateropenobject.h | 584 | llfloateropenobject.h |
565 | llfloaterparcel.h | 585 | llfloaterparcel.h |
566 | llfloaterpermissionsmgr.h | 586 | llfloaterpermissionsmgr.h |
567 | llfloaterpostcard.h | 587 | llfloaterpostcard.h |
568 | llfloaterpostprocess.h | 588 | llfloaterpostprocess.h |
569 | llfloaterpreference.h | 589 | llfloaterpreference.h |
590 | llfloaterperms.h | ||
570 | llfloaterproperties.h | 591 | llfloaterproperties.h |
571 | llfloaterregioninfo.h | 592 | llfloaterregioninfo.h |
572 | llfloaterreporter.h | 593 | llfloaterreporter.h |
@@ -590,7 +611,6 @@ set(viewer_HEADER_FILES | |||
590 | llfollowcam.h | 611 | llfollowcam.h |
591 | llframestats.h | 612 | llframestats.h |
592 | llframestatview.h | 613 | llframestatview.h |
593 | llgenepool.h | ||
594 | llgesturemgr.h | 614 | llgesturemgr.h |
595 | llgivemoney.h | 615 | llgivemoney.h |
596 | llgroupmgr.h | 616 | llgroupmgr.h |
@@ -618,6 +638,7 @@ set(viewer_HEADER_FILES | |||
618 | lllandmarklist.h | 638 | lllandmarklist.h |
619 | lllightconstants.h | 639 | lllightconstants.h |
620 | lllogchat.h | 640 | lllogchat.h |
641 | llloginhandler.h | ||
621 | llmanip.h | 642 | llmanip.h |
622 | llmaniprotate.h | 643 | llmaniprotate.h |
623 | llmanipscale.h | 644 | llmanipscale.h |
@@ -695,6 +716,7 @@ set(viewer_HEADER_FILES | |||
695 | llpreviewscript.h | 716 | llpreviewscript.h |
696 | llpreviewsound.h | 717 | llpreviewsound.h |
697 | llpreviewtexture.h | 718 | llpreviewtexture.h |
719 | llproductinforequest.h | ||
698 | llprogressview.h | 720 | llprogressview.h |
699 | llregionposition.h | 721 | llregionposition.h |
700 | llremoteparcelrequest.h | 722 | llremoteparcelrequest.h |
@@ -794,6 +816,7 @@ set(viewer_HEADER_FILES | |||
794 | llvlcomposition.h | 816 | llvlcomposition.h |
795 | llvlmanager.h | 817 | llvlmanager.h |
796 | llvoavatar.h | 818 | llvoavatar.h |
819 | llvoavatardefines.h | ||
797 | llvocache.h | 820 | llvocache.h |
798 | llvoclouds.h | 821 | llvoclouds.h |
799 | llvograss.h | 822 | llvograss.h |
@@ -923,11 +946,8 @@ if (WINDOWS) | |||
923 | res/arrowcop.cur | 946 | res/arrowcop.cur |
924 | res/arrowcopmulti.cur | 947 | res/arrowcopmulti.cur |
925 | res/arrowdrag.cur | 948 | res/arrowdrag.cur |
926 | res/bitmap2.bmp | ||
927 | res/circleandline.cur | 949 | res/circleandline.cur |
928 | res/icon1.ico | 950 | res/icon1.ico |
929 | res/install_icon.BMP | ||
930 | res/install_icon.ico | ||
931 | res/llarrow.cur | 951 | res/llarrow.cur |
932 | res/llarrowdrag.cur | 952 | res/llarrowdrag.cur |
933 | res/llarrowdragmulti.cur | 953 | res/llarrowdragmulti.cur |
@@ -949,7 +969,6 @@ if (WINDOWS) | |||
949 | res/lltoolzoomout.cur | 969 | res/lltoolzoomout.cur |
950 | res/ll_icon.BMP | 970 | res/ll_icon.BMP |
951 | res/ll_icon.ico | 971 | res/ll_icon.ico |
952 | res/loginbackground.bmp | ||
953 | res/resource.h | 972 | res/resource.h |
954 | res/toolbuy.cur | 973 | res/toolbuy.cur |
955 | res/toolopen.cur | 974 | res/toolopen.cur |
@@ -959,8 +978,6 @@ if (WINDOWS) | |||
959 | res/toolpickobject3.cur | 978 | res/toolpickobject3.cur |
960 | res/toolpipette.cur | 979 | res/toolpipette.cur |
961 | res/toolsit.cur | 980 | res/toolsit.cur |
962 | res/uninstall_icon.BMP | ||
963 | res/uninstall_icon.ico | ||
964 | ) | 981 | ) |
965 | 982 | ||
966 | set_source_files_properties(${viewer_RESOURCE_FILES} | 983 | set_source_files_properties(${viewer_RESOURCE_FILES} |
@@ -1030,6 +1047,7 @@ set(viewer_XUI_FILES | |||
1030 | skins/default/xui/en-us/floater_avatar_textures.xml | 1047 | skins/default/xui/en-us/floater_avatar_textures.xml |
1031 | skins/default/xui/en-us/floater_beacons.xml | 1048 | skins/default/xui/en-us/floater_beacons.xml |
1032 | skins/default/xui/en-us/floater_build_options.xml | 1049 | skins/default/xui/en-us/floater_build_options.xml |
1050 | skins/default/xui/en-us/floater_bulk_perms.xml | ||
1033 | skins/default/xui/en-us/floater_bumps.xml | 1051 | skins/default/xui/en-us/floater_bumps.xml |
1034 | skins/default/xui/en-us/floater_buy_contents.xml | 1052 | skins/default/xui/en-us/floater_buy_contents.xml |
1035 | skins/default/xui/en-us/floater_buy_currency.xml | 1053 | skins/default/xui/en-us/floater_buy_currency.xml |
@@ -1039,7 +1057,6 @@ set(viewer_XUI_FILES | |||
1039 | skins/default/xui/en-us/floater_chat_history.xml | 1057 | skins/default/xui/en-us/floater_chat_history.xml |
1040 | skins/default/xui/en-us/floater_chatterbox.xml | 1058 | skins/default/xui/en-us/floater_chatterbox.xml |
1041 | skins/default/xui/en-us/floater_choose_group.xml | 1059 | skins/default/xui/en-us/floater_choose_group.xml |
1042 | skins/default/xui/en-us/floater_clothing.xml | ||
1043 | skins/default/xui/en-us/floater_color_picker.xml | 1060 | skins/default/xui/en-us/floater_color_picker.xml |
1044 | skins/default/xui/en-us/floater_critical.xml | 1061 | skins/default/xui/en-us/floater_critical.xml |
1045 | skins/default/xui/en-us/floater_customize.xml | 1062 | skins/default/xui/en-us/floater_customize.xml |
@@ -1047,14 +1064,15 @@ set(viewer_XUI_FILES | |||
1047 | skins/default/xui/en-us/floater_device_settings.xml | 1064 | skins/default/xui/en-us/floater_device_settings.xml |
1048 | skins/default/xui/en-us/floater_directory.xml | 1065 | skins/default/xui/en-us/floater_directory.xml |
1049 | skins/default/xui/en-us/floater_env_settings.xml | 1066 | skins/default/xui/en-us/floater_env_settings.xml |
1067 | skins/default/xui/en-us/floater_font_test.xml | ||
1050 | skins/default/xui/en-us/floater_gesture.xml | 1068 | skins/default/xui/en-us/floater_gesture.xml |
1051 | skins/default/xui/en-us/floater_god_tools.xml | 1069 | skins/default/xui/en-us/floater_god_tools.xml |
1052 | skins/default/xui/en-us/floater_group_info.xml | 1070 | skins/default/xui/en-us/floater_group_info.xml |
1053 | skins/default/xui/en-us/floater_hardware_settings.xml | 1071 | skins/default/xui/en-us/floater_hardware_settings.xml |
1054 | skins/default/xui/en-us/floater_html.xml | 1072 | skins/default/xui/en-us/floater_html.xml |
1073 | skins/default/xui/en-us/floater_html_simple.xml | ||
1055 | skins/default/xui/en-us/floater_hud.xml | 1074 | skins/default/xui/en-us/floater_hud.xml |
1056 | skins/default/xui/en-us/floater_image_preview.xml | 1075 | skins/default/xui/en-us/floater_image_preview.xml |
1057 | skins/default/xui/en-us/floater_import.xml | ||
1058 | skins/default/xui/en-us/floater_im.xml | 1076 | skins/default/xui/en-us/floater_im.xml |
1059 | skins/default/xui/en-us/floater_inspect.xml | 1077 | skins/default/xui/en-us/floater_inspect.xml |
1060 | skins/default/xui/en-us/floater_instant_message_ad_hoc.xml | 1078 | skins/default/xui/en-us/floater_instant_message_ad_hoc.xml |
@@ -1070,6 +1088,7 @@ set(viewer_XUI_FILES | |||
1070 | skins/default/xui/en-us/floater_live_lsleditor.xml | 1088 | skins/default/xui/en-us/floater_live_lsleditor.xml |
1071 | skins/default/xui/en-us/floater_lsl_guide.xml | 1089 | skins/default/xui/en-us/floater_lsl_guide.xml |
1072 | skins/default/xui/en-us/floater_media_browser.xml | 1090 | skins/default/xui/en-us/floater_media_browser.xml |
1091 | skins/default/xui/en-us/floater_mini_map.xml | ||
1073 | skins/default/xui/en-us/floater_moveview.xml | 1092 | skins/default/xui/en-us/floater_moveview.xml |
1074 | skins/default/xui/en-us/floater_mute_object.xml | 1093 | skins/default/xui/en-us/floater_mute_object.xml |
1075 | skins/default/xui/en-us/floater_mute.xml | 1094 | skins/default/xui/en-us/floater_mute.xml |
@@ -1077,11 +1096,15 @@ set(viewer_XUI_FILES | |||
1077 | skins/default/xui/en-us/floater_name_description.xml | 1096 | skins/default/xui/en-us/floater_name_description.xml |
1078 | skins/default/xui/en-us/floater_new_im.xml | 1097 | skins/default/xui/en-us/floater_new_im.xml |
1079 | skins/default/xui/en-us/floater_new_outfit_dialog.xml | 1098 | skins/default/xui/en-us/floater_new_outfit_dialog.xml |
1099 | skins/default/xui/en-us/floater_notifications_console.xml | ||
1100 | skins/default/xui/en-us/floater_notification.xml | ||
1101 | skins/default/xui/en-us/floater_object_im_info.xml | ||
1080 | skins/default/xui/en-us/floater_openobject.xml | 1102 | skins/default/xui/en-us/floater_openobject.xml |
1081 | skins/default/xui/en-us/floater_pay_object.xml | 1103 | skins/default/xui/en-us/floater_pay_object.xml |
1082 | skins/default/xui/en-us/floater_pay.xml | 1104 | skins/default/xui/en-us/floater_pay.xml |
1083 | skins/default/xui/en-us/floater_postcard.xml | 1105 | skins/default/xui/en-us/floater_postcard.xml |
1084 | skins/default/xui/en-us/floater_post_process.xml | 1106 | skins/default/xui/en-us/floater_post_process.xml |
1107 | skins/default/xui/en-us/floater_perm_prefs.xml | ||
1085 | skins/default/xui/en-us/floater_preferences.xml | 1108 | skins/default/xui/en-us/floater_preferences.xml |
1086 | skins/default/xui/en-us/floater_preview_animation.xml | 1109 | skins/default/xui/en-us/floater_preview_animation.xml |
1087 | skins/default/xui/en-us/floater_preview_classified.xml | 1110 | skins/default/xui/en-us/floater_preview_classified.xml |
@@ -1111,6 +1134,7 @@ set(viewer_XUI_FILES | |||
1111 | skins/default/xui/en-us/floater_sim_release_message.xml | 1134 | skins/default/xui/en-us/floater_sim_release_message.xml |
1112 | skins/default/xui/en-us/floater_snapshot.xml | 1135 | skins/default/xui/en-us/floater_snapshot.xml |
1113 | skins/default/xui/en-us/floater_sound_preview.xml | 1136 | skins/default/xui/en-us/floater_sound_preview.xml |
1137 | skins/default/xui/en-us/floater_statistics.xml | ||
1114 | skins/default/xui/en-us/floater_telehub.xml | 1138 | skins/default/xui/en-us/floater_telehub.xml |
1115 | skins/default/xui/en-us/floater_test.xml | 1139 | skins/default/xui/en-us/floater_test.xml |
1116 | skins/default/xui/en-us/floater_texture_ctrl.xml | 1140 | skins/default/xui/en-us/floater_texture_ctrl.xml |
@@ -1123,16 +1147,19 @@ set(viewer_XUI_FILES | |||
1123 | skins/default/xui/en-us/floater_wearable_save_as.xml | 1147 | skins/default/xui/en-us/floater_wearable_save_as.xml |
1124 | skins/default/xui/en-us/floater_windlight_options.xml | 1148 | skins/default/xui/en-us/floater_windlight_options.xml |
1125 | skins/default/xui/en-us/floater_world_map.xml | 1149 | skins/default/xui/en-us/floater_world_map.xml |
1150 | skins/default/xui/en-us/fonts.xml | ||
1126 | skins/default/xui/en-us/menu_inventory.xml | 1151 | skins/default/xui/en-us/menu_inventory.xml |
1127 | skins/default/xui/en-us/menu_login.xml | 1152 | skins/default/xui/en-us/menu_login.xml |
1128 | skins/default/xui/en-us/menu_pie_attachment.xml | 1153 | skins/default/xui/en-us/menu_pie_attachment.xml |
1129 | skins/default/xui/en-us/menu_pie_avatar.xml | 1154 | skins/default/xui/en-us/menu_pie_avatar.xml |
1130 | skins/default/xui/en-us/menu_pie_land.xml | 1155 | skins/default/xui/en-us/menu_pie_land.xml |
1156 | skins/default/xui/en-us/menu_mini_map.xml | ||
1131 | skins/default/xui/en-us/menu_pie_object.xml | 1157 | skins/default/xui/en-us/menu_pie_object.xml |
1132 | skins/default/xui/en-us/menu_pie_self.xml | 1158 | skins/default/xui/en-us/menu_pie_self.xml |
1133 | skins/default/xui/en-us/menu_slurl.xml | 1159 | skins/default/xui/en-us/menu_slurl.xml |
1134 | skins/default/xui/en-us/menu_viewer.xml | 1160 | skins/default/xui/en-us/menu_viewer.xml |
1135 | skins/default/xui/en-us/mime_types.xml | 1161 | skins/default/xui/en-us/mime_types.xml |
1162 | skins/default/xui/en-us/notifications.xml | ||
1136 | skins/default/xui/en-us/notify.xml | 1163 | skins/default/xui/en-us/notify.xml |
1137 | skins/default/xui/en-us/panel_audio_device.xml | 1164 | skins/default/xui/en-us/panel_audio_device.xml |
1138 | skins/default/xui/en-us/panel_audio.xml | 1165 | skins/default/xui/en-us/panel_audio.xml |
@@ -1155,12 +1182,13 @@ set(viewer_XUI_FILES | |||
1155 | skins/default/xui/en-us/panel_groups.xml | 1182 | skins/default/xui/en-us/panel_groups.xml |
1156 | skins/default/xui/en-us/panel_group_voting.xml | 1183 | skins/default/xui/en-us/panel_group_voting.xml |
1157 | skins/default/xui/en-us/panel_group.xml | 1184 | skins/default/xui/en-us/panel_group.xml |
1158 | skins/default/xui/en-us/panel_land_covenant.xml | ||
1159 | skins/default/xui/en-us/panel_login.xml | 1185 | skins/default/xui/en-us/panel_login.xml |
1160 | skins/default/xui/en-us/panel_master_volume.xml | 1186 | skins/default/xui/en-us/panel_master_volume.xml |
1161 | skins/default/xui/en-us/panel_media_controls.xml | 1187 | skins/default/xui/en-us/panel_media_controls.xml |
1162 | skins/default/xui/en-us/panel_media_remote_expanded.xml | 1188 | skins/default/xui/en-us/panel_media_remote_expanded.xml |
1163 | skins/default/xui/en-us/panel_media_remote.xml | 1189 | skins/default/xui/en-us/panel_media_remote.xml |
1190 | skins/default/xui/en-us/panel_mini_map.xml | ||
1191 | skins/default/xui/en-us/panel_notifications_channel.xml | ||
1164 | skins/default/xui/en-us/panel_overlaybar.xml | 1192 | skins/default/xui/en-us/panel_overlaybar.xml |
1165 | skins/default/xui/en-us/panel_place_small.xml | 1193 | skins/default/xui/en-us/panel_place_small.xml |
1166 | skins/default/xui/en-us/panel_place.xml | 1194 | skins/default/xui/en-us/panel_place.xml |
@@ -1174,6 +1202,7 @@ set(viewer_XUI_FILES | |||
1174 | skins/default/xui/en-us/panel_preferences_popups.xml | 1202 | skins/default/xui/en-us/panel_preferences_popups.xml |
1175 | skins/default/xui/en-us/panel_preferences_voice.xml | 1203 | skins/default/xui/en-us/panel_preferences_voice.xml |
1176 | skins/default/xui/en-us/panel_preferences_web.xml | 1204 | skins/default/xui/en-us/panel_preferences_web.xml |
1205 | skins/default/xui/en-us/panel_progress.xml | ||
1177 | skins/default/xui/en-us/panel_region_covenant.xml | 1206 | skins/default/xui/en-us/panel_region_covenant.xml |
1178 | skins/default/xui/en-us/panel_region_debug.xml | 1207 | skins/default/xui/en-us/panel_region_debug.xml |
1179 | skins/default/xui/en-us/panel_region_estate.xml | 1208 | skins/default/xui/en-us/panel_region_estate.xml |
@@ -1276,7 +1305,7 @@ if (FMOD) | |||
1276 | PROPERTIES | 1305 | PROPERTIES |
1277 | BUILD_WITH_INSTALL_RPATH 1 | 1306 | BUILD_WITH_INSTALL_RPATH 1 |
1278 | INSTALL_NAME_DIR "@executable_path/../Resources" | 1307 | INSTALL_NAME_DIR "@executable_path/../Resources" |
1279 | LINK_FLAGS "-unexported_symbols_list ../newview/fmod_hidden_symbols.exp" | 1308 | LINK_FLAGS "-unexported_symbols_list ${CMAKE_CURRENT_SOURCE_DIR}/fmod_hidden_symbols.exp" |
1280 | ) | 1309 | ) |
1281 | endif (DARWIN) | 1310 | endif (DARWIN) |
1282 | set(FMODWRAPPER_LIBRARY fmodwrapper) | 1311 | set(FMODWRAPPER_LIBRARY fmodwrapper) |
@@ -1314,8 +1343,8 @@ if (WINDOWS) | |||
1314 | 1343 | ||
1315 | set_target_properties(${VIEWER_BINARY_NAME} | 1344 | set_target_properties(${VIEWER_BINARY_NAME} |
1316 | PROPERTIES | 1345 | PROPERTIES |
1317 | LINK_FLAGS "/debug /NODEFAULTLIB:MSVCRT /SUBSYSTEM:WINDOWS" | 1346 | LINK_FLAGS "/debug /NODEFAULTLIB:LIBCMT /SUBSYSTEM:WINDOWS" |
1318 | LINK_FLAGS_DEBUG "/NODEFAULTLIB:LIBCMT /NODEFAULTLIB:MSVCRTD" | 1347 | LINK_FLAGS_DEBUG "/NODEFAULTLIB:\"LIBCMT;LIBCMTD;MSVCRT\"" |
1319 | LINK_FLAGS_RELEASE ${release_flags} | 1348 | LINK_FLAGS_RELEASE ${release_flags} |
1320 | ) | 1349 | ) |
1321 | 1350 | ||
@@ -1402,6 +1431,7 @@ target_link_libraries(${VIEWER_BINARY_NAME} | |||
1402 | ${LSCRIPT_LIBRARIES} | 1431 | ${LSCRIPT_LIBRARIES} |
1403 | ${LLMATH_LIBRARIES} | 1432 | ${LLMATH_LIBRARIES} |
1404 | ${LLCOMMON_LIBRARIES} | 1433 | ${LLCOMMON_LIBRARIES} |
1434 | ${NDOF_LIBRARY} | ||
1405 | ${viewer_LIBRARIES} | 1435 | ${viewer_LIBRARIES} |
1406 | ${BOOST_PROGRAM_OPTIONS_LIBRARY} | 1436 | ${BOOST_PROGRAM_OPTIONS_LIBRARY} |
1407 | ${BOOST_REGEX_LIBRARY} | 1437 | ${BOOST_REGEX_LIBRARY} |
@@ -1413,7 +1443,6 @@ target_link_libraries(${VIEWER_BINARY_NAME} | |||
1413 | ${SDL_LIBRARY} | 1443 | ${SDL_LIBRARY} |
1414 | ${SMARTHEAP_LIBRARY} | 1444 | ${SMARTHEAP_LIBRARY} |
1415 | ${UI_LIBRARIES} | 1445 | ${UI_LIBRARIES} |
1416 | ${NDOF_LIBRARY} | ||
1417 | ${QUICKTIME_LIBRARY} | 1446 | ${QUICKTIME_LIBRARY} |
1418 | ${WINDOWS_LIBRARIES} | 1447 | ${WINDOWS_LIBRARIES} |
1419 | ${XMLRPCEPI_LIBRARIES} | 1448 | ${XMLRPCEPI_LIBRARIES} |
@@ -1456,7 +1485,7 @@ if (LINUX) | |||
1456 | 1485 | ||
1457 | if (NOT INSTALL) | 1486 | if (NOT INSTALL) |
1458 | add_custom_target(package ALL DEPENDS ${product}.tar.bz2) | 1487 | add_custom_target(package ALL DEPENDS ${product}.tar.bz2) |
1459 | add_dependencies(package linux-crash-logger-stripped) | 1488 | add_dependencies(package linux-crash-logger-strip-target) |
1460 | endif (NOT INSTALL) | 1489 | endif (NOT INSTALL) |
1461 | endif (LINUX) | 1490 | endif (LINUX) |
1462 | 1491 | ||
@@ -1513,9 +1542,30 @@ if (DARWIN) | |||
1513 | ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py | 1542 | ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py |
1514 | ) | 1543 | ) |
1515 | 1544 | ||
1545 | |||
1546 | add_custom_command( | ||
1547 | TARGET package POST_BUILD | ||
1548 | COMMAND ${PYTHON_EXECUTABLE} | ||
1549 | ARGS | ||
1550 | ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py | ||
1551 | --grid=${GRID} | ||
1552 | --configuration=${CMAKE_CFG_INTDIR} | ||
1553 | --channel=${VIEWER_CHANNEL} | ||
1554 | --login_channel=${VIEWER_LOGIN_CHANNEL} | ||
1555 | --source=${CMAKE_CURRENT_SOURCE_DIR} | ||
1556 | --artwork=${ARTWORK_DIR} | ||
1557 | --build=${CMAKE_CURRENT_BINARY_DIR} | ||
1558 | --dest=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/${product}.app | ||
1559 | --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/.${product}.touched | ||
1560 | DEPENDS | ||
1561 | ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py | ||
1562 | ) | ||
1563 | |||
1516 | endif (PACKAGE) | 1564 | endif (PACKAGE) |
1517 | endif (DARWIN) | 1565 | endif (DARWIN) |
1518 | 1566 | ||
1519 | if (INSTALL) | 1567 | if (INSTALL) |
1520 | include(${CMAKE_CURRENT_SOURCE_DIR}/ViewerInstall.cmake) | 1568 | include(${CMAKE_CURRENT_SOURCE_DIR}/ViewerInstall.cmake) |
1521 | endif (INSTALL) | 1569 | endif (INSTALL) |
1570 | |||
1571 | ADD_VIEWER_BUILD_TEST(llagentaccess viewer) | ||