aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/newview/CMakeLists.txt
diff options
context:
space:
mode:
authorunknown2008-12-30 11:34:13 -0700
committerunknown2008-12-30 11:34:13 -0700
commit5e0090c8daa5ae53f7907bbd2b6145f252f278cd (patch)
treec561ebc755dc77e99a58017a76e722d3259ea078 /linden/indra/newview/CMakeLists.txt
parentRemoved llkdu from cmake (diff)
downloadmeta-impy-5e0090c8daa5ae53f7907bbd2b6145f252f278cd.zip
meta-impy-5e0090c8daa5ae53f7907bbd2b6145f252f278cd.tar.gz
meta-impy-5e0090c8daa5ae53f7907bbd2b6145f252f278cd.tar.bz2
meta-impy-5e0090c8daa5ae53f7907bbd2b6145f252f278cd.tar.xz
Added fix for VWR-10392 as well as other fixes
Diffstat (limited to 'linden/indra/newview/CMakeLists.txt')
-rw-r--r--linden/indra/newview/CMakeLists.txt58
1 files changed, 36 insertions, 22 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt
index 9b7a647..53054aa 100644
--- a/linden/indra/newview/CMakeLists.txt
+++ b/linden/indra/newview/CMakeLists.txt
@@ -5,9 +5,9 @@ project(viewer)
5include(00-Common) 5include(00-Common)
6include(Boost) 6include(Boost)
7include(BuildVersion) 7include(BuildVersion)
8include(DBusGlib)
8include(DirectX) 9include(DirectX)
9include(ELFIO) 10include(ELFIO)
10include(FMOD)
11include(FindOpenGL) 11include(FindOpenGL)
12include(LLAudio) 12include(LLAudio)
13include(LLCharacter) 13include(LLCharacter)
@@ -429,6 +429,9 @@ set(viewer_SOURCE_FILES
429 pipeline.cpp 429 pipeline.cpp
430 ) 430 )
431 431
432set(VIEWER_BINARY_NAME "imprudence-bin" CACHE STRING
433 "The name of the viewer executable to create.")
434
432if (LINUX) 435if (LINUX)
433 # We can't set these flags for Darwin, because they get passed to 436 # We can't set these flags for Darwin, because they get passed to
434 # the PPC compiler. Ugh. 437 # the PPC compiler. Ugh.
@@ -849,8 +852,8 @@ if (DARWIN)
849 secondlife.icns 852 secondlife.icns
850 macview.r 853 macview.r
851 gpu_table.txt 854 gpu_table.txt
852 Info-SecondLife.plist 855 Info-Imprudence.plist
853 SecondLife.nib/ 856 Imprudence.nib/
854 # CMake doesn't seem to support Xcode language variants well just yet 857 # CMake doesn't seem to support Xcode language variants well just yet
855 English.lproj/InfoPlist.strings 858 English.lproj/InfoPlist.strings
856 English.lproj/language.txt 859 English.lproj/language.txt
@@ -870,6 +873,7 @@ endif (DARWIN)
870 873
871if (LINUX) 874if (LINUX)
872 LIST(APPEND viewer_SOURCE_FILES llappviewerlinux.cpp) 875 LIST(APPEND viewer_SOURCE_FILES llappviewerlinux.cpp)
876 LIST(APPEND viewer_SOURCE_FILES llappviewerlinux_api_dbus.cpp)
873 LIST(APPEND CMAKE_EXE_LINKER_FLAGS -Wl,--as-needed) 877 LIST(APPEND CMAKE_EXE_LINKER_FLAGS -Wl,--as-needed)
874 878
875 set(viewer_LIBRARIES 879 set(viewer_LIBRARIES
@@ -1238,8 +1242,13 @@ set_source_files_properties(${viewer_CHARACTER_FILES}
1238 1242
1239list(APPEND viewer_SOURCE_FILES ${viewer_CHARACTER_FILES}) 1243list(APPEND viewer_SOURCE_FILES ${viewer_CHARACTER_FILES})
1240 1244
1245
1246if (OPENAL)
1247 set(LLSTARTUP_COMPILE_FLAGS "${LLSTARTUP_COMPILE_FLAGS} -DLL_OPENAL")
1248endif (OPENAL)
1249
1241if (FMOD) 1250if (FMOD)
1242 set_source_files_properties(llstartup.cpp PROPERTIES COMPILE_FLAGS -DLL_FMOD) 1251 set(LLSTARTUP_COMPILE_FLAGS "${LLSTARTUP_COMPILE_FLAGS} -DLL_FMOD")
1243 1252
1244 if (NOT WINDOWS) 1253 if (NOT WINDOWS)
1245 set(fmodwrapper_SOURCE_FILES fmodwrapper.cpp) 1254 set(fmodwrapper_SOURCE_FILES fmodwrapper.cpp)
@@ -1259,6 +1268,8 @@ if (FMOD)
1259 endif (NOT WINDOWS) 1268 endif (NOT WINDOWS)
1260endif (FMOD) 1269endif (FMOD)
1261 1270
1271set_source_files_properties(llstartup.cpp PROPERTIES COMPILE_FLAGS "${LLSTARTUP_COMPILE_FLAGS}")
1272
1262list(APPEND viewer_SOURCE_FILES ${viewer_HEADER_FILES}) 1273list(APPEND viewer_SOURCE_FILES ${viewer_HEADER_FILES})
1263 1274
1264set_source_files_properties(${viewer_HEADER_FILES} 1275set_source_files_properties(${viewer_HEADER_FILES}
@@ -1374,7 +1385,7 @@ target_link_libraries(imprudence-bin
1374 ${viewer_LIBRARIES} 1385 ${viewer_LIBRARIES}
1375 ${BOOST_PROGRAM_OPTIONS_LIBRARY} 1386 ${BOOST_PROGRAM_OPTIONS_LIBRARY}
1376 ${BOOST_REGEX_LIBRARY} 1387 ${BOOST_REGEX_LIBRARY}
1377 ${BOOST_SIGNALS_LIBRARY} 1388 ${DBUSGLIB_LIBRARIES}
1378 ${OPENGL_LIBRARIES} 1389 ${OPENGL_LIBRARIES}
1379 ${FMODWRAPPER_LIBRARY} 1390 ${FMODWRAPPER_LIBRARY}
1380 ${OPENGL_LIBRARIES} 1391 ${OPENGL_LIBRARIES}
@@ -1462,24 +1473,27 @@ if (DARWIN)
1462 ) 1473 )
1463 1474
1464 if (PACKAGE) 1475 if (PACKAGE)
1465 add_custom_target(package 1476 add_custom_target(package ALL DEPENDS imprudence-bin)
1466 COMMAND
1467 ${PYTHON_EXECUTABLE}
1468 ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py
1469 --grid=${GRID}
1470 --configuration=${CMAKE_CFG_INTDIR}
1471 --channel=${VIEWER_CHANNEL}
1472 --login_channel=${VIEWER_CHANNEL}
1473 --source=${CMAKE_CURRENT_SOURCE_DIR}
1474 --artwork=${ARTWORK_DIR}
1475 --build=${CMAKE_CURRENT_BINARY_DIR}
1476 --dest=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/${product}.app
1477 --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/.${product}.touched
1478 DEPENDS
1479 imprudence-bin
1480 ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py
1481 )
1482 add_dependencies(package mac-updater mac-crash-logger) 1477 add_dependencies(package mac-updater mac-crash-logger)
1478
1479 add_custom_command(
1480 TARGET package POST_BUILD
1481 COMMAND ${PYTHON_EXECUTABLE}
1482 ARGS
1483 ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py
1484 --grid=${GRID}
1485 --configuration=${CMAKE_CFG_INTDIR}
1486 --channel=${VIEWER_CHANNEL}
1487 --login_channel=${VIEWER_LOGIN_CHANNEL}
1488 --source=${CMAKE_CURRENT_SOURCE_DIR}
1489 --artwork=${ARTWORK_DIR}
1490 --build=${CMAKE_CURRENT_BINARY_DIR}
1491 --dest=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/${product}.app
1492 --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/.${product}.touched
1493 DEPENDS
1494 ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py
1495 )
1496
1483 endif (PACKAGE) 1497 endif (PACKAGE)
1484endif (DARWIN) 1498endif (DARWIN)
1485 1499