aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/media_plugins
diff options
context:
space:
mode:
authorMcCabe Maxsted2011-02-10 12:34:53 -0700
committerMcCabe Maxsted2011-02-10 12:34:53 -0700
commitfc7b11841ac62d723b8544866d18a3de018896d4 (patch)
tree76e53a16eea3672c870e749c09d89cb4810ff88a /linden/indra/media_plugins
parentGive a little information in the log when we fail to init the audio plugin on... (diff)
downloadmeta-impy-fc7b11841ac62d723b8544866d18a3de018896d4.zip
meta-impy-fc7b11841ac62d723b8544866d18a3de018896d4.tar.gz
meta-impy-fc7b11841ac62d723b8544866d18a3de018896d4.tar.bz2
meta-impy-fc7b11841ac62d723b8544866d18a3de018896d4.tar.xz
Fixed gstreamer plugin headers missing from cmake
Diffstat (limited to 'linden/indra/media_plugins')
-rw-r--r--linden/indra/media_plugins/gstreamer010/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/linden/indra/media_plugins/gstreamer010/CMakeLists.txt b/linden/indra/media_plugins/gstreamer010/CMakeLists.txt
index 4401e64..e405dc6 100644
--- a/linden/indra/media_plugins/gstreamer010/CMakeLists.txt
+++ b/linden/indra/media_plugins/gstreamer010/CMakeLists.txt
@@ -36,9 +36,15 @@ set(media_plugin_gstreamer010_SOURCE_FILES
36 ) 36 )
37 37
38set(media_plugin_gstreamer010_HEADER_FILES 38set(media_plugin_gstreamer010_HEADER_FILES
39 llmediaimplgstreamer.h
39 llmediaimplgstreamervidplug.h 40 llmediaimplgstreamervidplug.h
40 llmediaimplgstreamertriviallogging.h 41 llmediaimplgstreamertriviallogging.h
41 ) 42 )
43
44set_source_files_properties(${media_plugin_gstreamer010_HEADER_FILES}
45 PROPERTIES HEADER_FILE_ONLY TRUE)
46
47list(APPEND media_plugin_gstreamer010_SOURCE_FILES ${media_plugin_gstreamer010_HEADER_FILES})
42 48
43add_library(media_plugin_gstreamer010 49add_library(media_plugin_gstreamer010
44 SHARED 50 SHARED