diff options
author | Aleric Inglewood | 2010-11-07 16:55:50 +0100 |
---|---|---|
committer | Aleric Inglewood | 2010-11-07 18:27:48 +0100 |
commit | 5b4356cefbaa7dbdc8656e7283c110a893b1a89c (patch) | |
tree | 43fae9945562c3281746370d623877840ed884b2 /linden/indra/media_plugins | |
parent | IMP-688: ERROR: getString: Invalid string control nick01 (diff) | |
download | meta-impy-5b4356cefbaa7dbdc8656e7283c110a893b1a89c.zip meta-impy-5b4356cefbaa7dbdc8656e7283c110a893b1a89c.tar.gz meta-impy-5b4356cefbaa7dbdc8656e7283c110a893b1a89c.tar.bz2 meta-impy-5b4356cefbaa7dbdc8656e7283c110a893b1a89c.tar.xz |
IMP-692: SNOW-713: Global objects in libllcommon duplicated in plugins
See http://jira.secondlife.com/browse/SNOW-713
This patch makes llcommon shared. It contains the following snowglobe
(SVN) changesets: 3478, 3479, 3480, 3481, 3482, 3485, 3496, 3498, 3500,
3519 and 3531, plus the fix for all rejects. Note that changes
to scripts/automated_build_scripts/opensrc-build.sh (changesets 3500
and 3625) were ignored as we don't have scripts/automated_build_scripts.
Diffstat (limited to 'linden/indra/media_plugins')
6 files changed, 10 insertions, 50 deletions
diff --git a/linden/indra/media_plugins/base/CMakeLists.txt b/linden/indra/media_plugins/base/CMakeLists.txt index dd0b0a0..8d62043 100644 --- a/linden/indra/media_plugins/base/CMakeLists.txt +++ b/linden/indra/media_plugins/base/CMakeLists.txt | |||
@@ -2,10 +2,6 @@ | |||
2 | 2 | ||
3 | project(media_plugin_base) | 3 | project(media_plugin_base) |
4 | 4 | ||
5 | if(HAVE_64_BIT) | ||
6 | set(REQUIRE_PIC) | ||
7 | endif(HAVE_64_BIT) | ||
8 | |||
9 | include(00-Common) | 5 | include(00-Common) |
10 | include(LLCommon) | 6 | include(LLCommon) |
11 | include(LLImage) | 7 | include(LLImage) |
diff --git a/linden/indra/media_plugins/example/CMakeLists.txt b/linden/indra/media_plugins/example/CMakeLists.txt index bac5fa2..7822300 100644 --- a/linden/indra/media_plugins/example/CMakeLists.txt +++ b/linden/indra/media_plugins/example/CMakeLists.txt | |||
@@ -2,10 +2,6 @@ | |||
2 | 2 | ||
3 | project(media_plugin_example) | 3 | project(media_plugin_example) |
4 | 4 | ||
5 | if(HAVE_64_BIT) | ||
6 | set(REQUIRE_PIC) | ||
7 | endif(HAVE_64_BIT) | ||
8 | |||
9 | include(00-Common) | 5 | include(00-Common) |
10 | include(LLCommon) | 6 | include(LLCommon) |
11 | include(LLImage) | 7 | include(LLImage) |
diff --git a/linden/indra/media_plugins/gstreamer010/CMakeLists.txt b/linden/indra/media_plugins/gstreamer010/CMakeLists.txt index a031157..4401e64 100644 --- a/linden/indra/media_plugins/gstreamer010/CMakeLists.txt +++ b/linden/indra/media_plugins/gstreamer010/CMakeLists.txt | |||
@@ -2,10 +2,6 @@ | |||
2 | 2 | ||
3 | project(media_plugin_gstreamer010) | 3 | project(media_plugin_gstreamer010) |
4 | 4 | ||
5 | if(HAVE_64_BIT) | ||
6 | set(REQUIRE_PIC) | ||
7 | endif(HAVE_64_BIT) | ||
8 | |||
9 | include(00-Common) | 5 | include(00-Common) |
10 | include(LLCommon) | 6 | include(LLCommon) |
11 | include(LLImage) | 7 | include(LLImage) |
@@ -34,14 +30,6 @@ include_directories( | |||
34 | 30 | ||
35 | ### media_plugin_gstreamer010 | 31 | ### media_plugin_gstreamer010 |
36 | 32 | ||
37 | if(NOT CMAKE_SIZEOF_VOID_P MATCHES 4) | ||
38 | if(WINDOWS) | ||
39 | add_definitions(/FIXED:NO) | ||
40 | else(WINDOWS) # not windows therefore gcc LINUX and DARWIN | ||
41 | add_definitions(-fPIC) | ||
42 | endif(WINDOWS) | ||
43 | endif (NOT CMAKE_SIZEOF_VOID_P MATCHES 4) | ||
44 | |||
45 | set(media_plugin_gstreamer010_SOURCE_FILES | 33 | set(media_plugin_gstreamer010_SOURCE_FILES |
46 | media_plugin_gstreamer010.cpp | 34 | media_plugin_gstreamer010.cpp |
47 | llmediaimplgstreamervidplug.cpp | 35 | llmediaimplgstreamervidplug.cpp |
diff --git a/linden/indra/media_plugins/gstreamer010/llmediaimplgstreamertriviallogging.h b/linden/indra/media_plugins/gstreamer010/llmediaimplgstreamertriviallogging.h index 0ea096a..bb90aa1 100755 --- a/linden/indra/media_plugins/gstreamer010/llmediaimplgstreamertriviallogging.h +++ b/linden/indra/media_plugins/gstreamer010/llmediaimplgstreamertriviallogging.h | |||
@@ -38,31 +38,23 @@ | |||
38 | 38 | ||
39 | #include <cstdio> | 39 | #include <cstdio> |
40 | 40 | ||
41 | extern "C" { | ||
42 | #include <sys/types.h> | ||
43 | //#include <unistd.h> //fiuxme | ||
44 | } | ||
45 | |||
46 | #define MSGMODULEFOO "(media plugin)" | ||
47 | |||
48 | #ifdef LL_LINUX | ||
49 | ///////////////////////////////////////////////////////////////////////// | 41 | ///////////////////////////////////////////////////////////////////////// |
50 | // Debug/Info/Warning macros. | 42 | // Debug/Info/Warning macros. |
51 | 43 | #if LL_WINDOWS | |
52 | #define STDERRMSG(...) do{\ | 44 | #include <process.h> |
53 | fprintf(stderr, " pid:%d: ", (int)getpid());\ | 45 | #define LL_GETPID GetCurrentProcessId |
54 | fprintf(stderr, MSGMODULEFOO " %s:%d: ", __FUNCTION__, __LINE__);\ | ||
55 | fprintf(stderr, __VA_ARGS__);\ | ||
56 | fputc('\n',stderr);\ | ||
57 | }while(0) | ||
58 | #else | 46 | #else |
47 | #include <sys/types.h> | ||
48 | #include <unistd.h> | ||
49 | #define LL_GETPID getpid | ||
50 | #endif | ||
51 | #define MSGMODULEFOO "(media plugin)" | ||
59 | #define STDERRMSG(...) do{\ | 52 | #define STDERRMSG(...) do{\ |
53 | fprintf(stderr, " pid:%d: ", (int)LL_GETPID());\ | ||
60 | fprintf(stderr, MSGMODULEFOO " %s:%d: ", __FUNCTION__, __LINE__);\ | 54 | fprintf(stderr, MSGMODULEFOO " %s:%d: ", __FUNCTION__, __LINE__);\ |
61 | fprintf(stderr, __VA_ARGS__);\ | 55 | fprintf(stderr, __VA_ARGS__);\ |
62 | fputc('\n',stderr);\ | 56 | fputc('\n',stderr);\ |
63 | }while(0) | 57 | }while(0) |
64 | #endif | ||
65 | |||
66 | #define NULLMSG(...) do{}while(0) | 58 | #define NULLMSG(...) do{}while(0) |
67 | 59 | ||
68 | #define DEBUGMSG NULLMSG | 60 | #define DEBUGMSG NULLMSG |
diff --git a/linden/indra/media_plugins/gstreamer010/media_plugin_gstreamer010.cpp b/linden/indra/media_plugins/gstreamer010/media_plugin_gstreamer010.cpp index 44bc32e..78e46ca 100755 --- a/linden/indra/media_plugins/gstreamer010/media_plugin_gstreamer010.cpp +++ b/linden/indra/media_plugins/gstreamer010/media_plugin_gstreamer010.cpp | |||
@@ -175,7 +175,7 @@ MediaPluginGStreamer010::MediaPluginGStreamer010( | |||
175 | mCommand ( COMMAND_NONE ) | 175 | mCommand ( COMMAND_NONE ) |
176 | { | 176 | { |
177 | std::ostringstream str; | 177 | std::ostringstream str; |
178 | INFOMSG("MediaPluginGStreamer010 constructor - my PID=%u", U32(getpid())); | 178 | INFOMSG("MediaPluginGStreamer010 constructor - my PID=%u", U32(LL_GETPID())); |
179 | } | 179 | } |
180 | 180 | ||
181 | /////////////////////////////////////////////////////////////////////////////// | 181 | /////////////////////////////////////////////////////////////////////////////// |
diff --git a/linden/indra/media_plugins/webkit/CMakeLists.txt b/linden/indra/media_plugins/webkit/CMakeLists.txt index 2ab4a95..303a774 100644 --- a/linden/indra/media_plugins/webkit/CMakeLists.txt +++ b/linden/indra/media_plugins/webkit/CMakeLists.txt | |||
@@ -2,10 +2,6 @@ | |||
2 | 2 | ||
3 | project(media_plugin_webkit) | 3 | project(media_plugin_webkit) |
4 | 4 | ||
5 | if(HAVE_64_BIT) | ||
6 | set(REQUIRE_PIC) | ||
7 | endif(HAVE_64_BIT) | ||
8 | |||
9 | include(00-Common) | 5 | include(00-Common) |
10 | include(LLCommon) | 6 | include(LLCommon) |
11 | include(LLImage) | 7 | include(LLImage) |
@@ -34,20 +30,12 @@ include_directories( | |||
34 | ${LLQTWEBKIT_INCLUDE_DIR} | 30 | ${LLQTWEBKIT_INCLUDE_DIR} |
35 | ) | 31 | ) |
36 | 32 | ||
37 | |||
38 | ### media_plugin_webkit | 33 | ### media_plugin_webkit |
39 | 34 | ||
40 | set(media_plugin_webkit_SOURCE_FILES | 35 | set(media_plugin_webkit_SOURCE_FILES |
41 | media_plugin_webkit.cpp | 36 | media_plugin_webkit.cpp |
42 | ) | 37 | ) |
43 | 38 | ||
44 | if(NOT CMAKE_SIZEOF_VOID_P MATCHES 4) | ||
45 | if(WINDOWS) | ||
46 | add_definitions(/FIXED:NO) | ||
47 | else(WINDOWS) # not windows therefore gcc LINUX and DARWIN | ||
48 | add_definitions(-fPIC) | ||
49 | endif(WINDOWS) | ||
50 | endif (NOT CMAKE_SIZEOF_VOID_P MATCHES 4) | ||
51 | set(media_plugin_webkit_HEADER_FILES | 39 | set(media_plugin_webkit_HEADER_FILES |
52 | volume_catcher.h | 40 | volume_catcher.h |
53 | ) | 41 | ) |