diff options
author | David Walter Seikel | 2013-08-30 21:42:45 +1000 |
---|---|---|
committer | David Walter Seikel | 2013-08-30 21:42:45 +1000 |
commit | 56a1de48ee43bfacbd3ef2859f392082a26bc814 (patch) | |
tree | 03bd6092dab42985e536b84d2f311a3a12e4edb4 /linden/indra/media_plugins | |
parent | Added a licensing note about gpg.vs, as used to build OTR on Windows. (diff) | |
parent | Merge remote-tracking branch 'origin/next' into WL-refactor (diff) | |
download | meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.zip meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.tar.gz meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.tar.bz2 meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.tar.xz |
Merge remote-tracking branch 'imprudence/next' into next
Unless otherwise stated, Imprudence changes accepted. The three images seem to be the same.
Conflicts:
.gitignore
linden/indra/develop.py
linden/indra/llcommon/llsdserialize_xml.cpp
linden/indra/newview/CMakeLists.txt
Manually combined MOAP, OTR, and WL changes from both.
linden/indra/newview/app_settings/default_grids.xml
Manually merged the grid collection.
Also updated IG info.
linden/indra/newview/hippoupdate.cpp
linden/indra/newview/llettherebelight.cpp
Just used the Imprudence copy.
linden/indra/newview/llviewermessage.cpp
Keep unbranding.
linden/indra/newview/llvoavatar.cpp
Manually merge client tags.
linden/indra/newview/res/viewerRes.rc
Manually merge version from Impy.
linden/indra/newview/skins/dark/colors_base.xml
Keep unbranding.
linden/indra/newview/skins/default/html/unabletoconnect.png
linden/indra/newview/skins/default/textures/icon_top_pick.tga
linden/indra/newview/skins/default/xui/en-us/floater_about.xml
Manual merging of contributors.
linden/indra/newview/skins/gemini/colors_base.xml
Keep unbranding.
linden/indra/newview/skins/gemini/textures/icon_top_pick.tga
linden/indra/newview/viewer_manifest.py
Manually merged boost, gstreamer, OTR, and name.
linden/indra/newview/viewerinfo.cpp
Manually merge the comment.
Diffstat (limited to 'linden/indra/media_plugins')
-rwxr-xr-x | linden/indra/media_plugins/gstreamer010/llmediaimplgstreamervidplug.cpp | 7 | ||||
-rw-r--r-- | linden/indra/media_plugins/webkit/CMakeLists.txt | 4 |
2 files changed, 4 insertions, 7 deletions
diff --git a/linden/indra/media_plugins/gstreamer010/llmediaimplgstreamervidplug.cpp b/linden/indra/media_plugins/gstreamer010/llmediaimplgstreamervidplug.cpp index e194bf7..49bf6f9 100755 --- a/linden/indra/media_plugins/gstreamer010/llmediaimplgstreamervidplug.cpp +++ b/linden/indra/media_plugins/gstreamer010/llmediaimplgstreamervidplug.cpp | |||
@@ -312,12 +312,9 @@ gst_slvideo_set_caps (GstBaseSink * bsink, GstCaps * caps) | |||
312 | static gboolean | 312 | static gboolean |
313 | gst_slvideo_start (GstBaseSink * bsink) | 313 | gst_slvideo_start (GstBaseSink * bsink) |
314 | { | 314 | { |
315 | GstSLVideo *slvideo; | 315 | GST_SLVIDEO(bsink); |
316 | gboolean ret = TRUE; | ||
317 | |||
318 | slvideo = GST_SLVIDEO(bsink); | ||
319 | 316 | ||
320 | return ret; | 317 | return TRUE; |
321 | } | 318 | } |
322 | 319 | ||
323 | static gboolean | 320 | static gboolean |
diff --git a/linden/indra/media_plugins/webkit/CMakeLists.txt b/linden/indra/media_plugins/webkit/CMakeLists.txt index 303a774..f589c61 100644 --- a/linden/indra/media_plugins/webkit/CMakeLists.txt +++ b/linden/indra/media_plugins/webkit/CMakeLists.txt | |||
@@ -112,8 +112,8 @@ if (DARWIN) | |||
112 | # copy the webkit dylib to the build directory | 112 | # copy the webkit dylib to the build directory |
113 | add_custom_command( | 113 | add_custom_command( |
114 | TARGET media_plugin_webkit POST_BUILD | 114 | TARGET media_plugin_webkit POST_BUILD |
115 | # OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/libllqtwebkit.dylib | 115 | # OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/libllqtwebkit.dylib |
116 | COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/ | 116 | COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/ |
117 | DEPENDS media_plugin_webkit ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib | 117 | DEPENDS media_plugin_webkit ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib |
118 | ) | 118 | ) |
119 | 119 | ||