aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/media_plugins/gstreamer010/CMakeLists.txt
diff options
context:
space:
mode:
authorArmin Weatherwax2010-06-14 16:27:25 +0200
committerArmin Weatherwax2010-09-23 15:42:38 +0200
commit3069d8886241b2d9deaadfbf8823d463b469ec6b (patch)
treee70aeae85d110d66a7c048a0132085e0301ab068 /linden/indra/media_plugins/gstreamer010/CMakeLists.txt
parentmake it compile and run. (diff)
downloadmeta-impy-3069d8886241b2d9deaadfbf8823d463b469ec6b.zip
meta-impy-3069d8886241b2d9deaadfbf8823d463b469ec6b.tar.gz
meta-impy-3069d8886241b2d9deaadfbf8823d463b469ec6b.tar.bz2
meta-impy-3069d8886241b2d9deaadfbf8823d463b469ec6b.tar.xz
update to latest SG2 media_plugins
Diffstat (limited to 'linden/indra/media_plugins/gstreamer010/CMakeLists.txt')
-rwxr-xr-xlinden/indra/media_plugins/gstreamer010/CMakeLists.txt15
1 files changed, 8 insertions, 7 deletions
diff --git a/linden/indra/media_plugins/gstreamer010/CMakeLists.txt b/linden/indra/media_plugins/gstreamer010/CMakeLists.txt
index 3b73e04..ee16849 100755
--- a/linden/indra/media_plugins/gstreamer010/CMakeLists.txt
+++ b/linden/indra/media_plugins/gstreamer010/CMakeLists.txt
@@ -30,6 +30,14 @@ include_directories(
30 30
31### media_plugin_gstreamer010 31### media_plugin_gstreamer010
32 32
33if(NOT CMAKE_SIZEOF_VOID_P MATCHES 4)
34 if(WINDOWS)
35 add_definitions(/FIXED:NO)
36 else(WINDOWS) # not windows therefore gcc LINUX and DARWIN
37 add_definitions(-fPIC)
38 endif(WINDOWS)
39endif (NOT CMAKE_SIZEOF_VOID_P MATCHES 4)
40
33set(media_plugin_gstreamer010_SOURCE_FILES 41set(media_plugin_gstreamer010_SOURCE_FILES
34 media_plugin_gstreamer010.cpp 42 media_plugin_gstreamer010.cpp
35 llmediaimplgstreamer_syms.cpp 43 llmediaimplgstreamer_syms.cpp
@@ -42,13 +50,6 @@ set(media_plugin_gstreamer010_HEADER_FILES
42 llmediaimplgstreamertriviallogging.h 50 llmediaimplgstreamertriviallogging.h
43 ) 51 )
44 52
45if (${CXX_VERSION_NUMBER} MATCHES "4[23].")
46 # Work around a bad interaction between broken gstreamer headers and
47 # g++ 4.3's increased strictness.
48 set_source_files_properties(llmediaimplgstreamervidplug.cpp PROPERTIES
49 COMPILE_FLAGS -Wno-write-strings)
50endif (${CXX_VERSION_NUMBER} MATCHES "4[23].")
51
52add_library(media_plugin_gstreamer010 53add_library(media_plugin_gstreamer010
53 SHARED 54 SHARED
54 ${media_plugin_gstreamer010_SOURCE_FILES} 55 ${media_plugin_gstreamer010_SOURCE_FILES}