aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/media_plugins/example/CMakeLists.txt
diff options
context:
space:
mode:
authorArmin Weatherwax2010-06-14 12:04:49 +0200
committerArmin Weatherwax2010-09-23 15:38:25 +0200
commit35df5441d3e2789663532c948731aff3a1e04728 (patch)
treeac7674289784a5f96106ea507637055a8dada78a /linden/indra/media_plugins/example/CMakeLists.txt
parentChanged version to Experimental 2010.09.18 (diff)
downloadmeta-impy-35df5441d3e2789663532c948731aff3a1e04728.zip
meta-impy-35df5441d3e2789663532c948731aff3a1e04728.tar.gz
meta-impy-35df5441d3e2789663532c948731aff3a1e04728.tar.bz2
meta-impy-35df5441d3e2789663532c948731aff3a1e04728.tar.xz
llmediaplugins first step
Diffstat (limited to 'linden/indra/media_plugins/example/CMakeLists.txt')
-rw-r--r--linden/indra/media_plugins/example/CMakeLists.txt74
1 files changed, 74 insertions, 0 deletions
diff --git a/linden/indra/media_plugins/example/CMakeLists.txt b/linden/indra/media_plugins/example/CMakeLists.txt
new file mode 100644
index 0000000..4d82f27
--- /dev/null
+++ b/linden/indra/media_plugins/example/CMakeLists.txt
@@ -0,0 +1,74 @@
1# -*- cmake -*-
2
3project(media_plugin_example)
4
5include(00-Common)
6include(LLCommon)
7include(LLImage)
8include(LLPlugin)
9include(LLMath)
10include(LLRender)
11include(LLWindow)
12include(Linking)
13include(PluginAPI)
14include(MediaPluginBase)
15include(FindOpenGL)
16
17include(ExamplePlugin)
18
19include_directories(
20 ${LLPLUGIN_INCLUDE_DIRS}
21 ${MEDIA_PLUGIN_BASE_INCLUDE_DIRS}
22 ${LLCOMMON_INCLUDE_DIRS}
23 ${LLMATH_INCLUDE_DIRS}
24 ${LLIMAGE_INCLUDE_DIRS}
25 ${LLRENDER_INCLUDE_DIRS}
26 ${LLWINDOW_INCLUDE_DIRS}
27)
28
29
30### media_plugin_example
31
32set(media_plugin_example_SOURCE_FILES
33 media_plugin_example.cpp
34 )
35
36add_library(media_plugin_example
37 SHARED
38 ${media_plugin_example_SOURCE_FILES}
39)
40
41target_link_libraries(media_plugin_example
42 ${LLPLUGIN_LIBRARIES}
43 ${MEDIA_PLUGIN_BASE_LIBRARIES}
44 ${LLCOMMON_LIBRARIES}
45 ${EXAMPLE_PLUGIN_LIBRARIES}
46 ${PLUGIN_API_WINDOWS_LIBRARIES}
47)
48
49add_dependencies(media_plugin_example
50 ${LLPLUGIN_LIBRARIES}
51 ${MEDIA_PLUGIN_BASE_LIBRARIES}
52 ${LLCOMMON_LIBRARIES}
53)
54
55if (WINDOWS)
56 set_target_properties(
57 media_plugin_example
58 PROPERTIES
59 LINK_FLAGS "/MANIFEST:NO"
60 )
61endif (WINDOWS)
62
63if (DARWIN)
64 # Don't prepend 'lib' to the executable name, and don't embed a full path in the library's install name
65 set_target_properties(
66 media_plugin_example
67 PROPERTIES
68 PREFIX ""
69 BUILD_WITH_INSTALL_RPATH 1
70 INSTALL_NAME_DIR "@executable_path"
71 LINK_FLAGS "-exported_symbols_list ${CMAKE_CURRENT_SOURCE_DIR}/../base/media_plugin_base.exp"
72 )
73
74endif (DARWIN) \ No newline at end of file