diff options
author | Armin Weatherwax | 2010-06-14 12:04:49 +0200 |
---|---|---|
committer | Armin Weatherwax | 2010-09-23 15:38:25 +0200 |
commit | 35df5441d3e2789663532c948731aff3a1e04728 (patch) | |
tree | ac7674289784a5f96106ea507637055a8dada78a /linden/indra/media_plugins/example/CMakeLists.txt | |
parent | Changed version to Experimental 2010.09.18 (diff) | |
download | meta-impy-35df5441d3e2789663532c948731aff3a1e04728.zip meta-impy-35df5441d3e2789663532c948731aff3a1e04728.tar.gz meta-impy-35df5441d3e2789663532c948731aff3a1e04728.tar.bz2 meta-impy-35df5441d3e2789663532c948731aff3a1e04728.tar.xz |
llmediaplugins first step
Diffstat (limited to 'linden/indra/media_plugins/example/CMakeLists.txt')
-rw-r--r-- | linden/indra/media_plugins/example/CMakeLists.txt | 74 |
1 files changed, 74 insertions, 0 deletions
diff --git a/linden/indra/media_plugins/example/CMakeLists.txt b/linden/indra/media_plugins/example/CMakeLists.txt new file mode 100644 index 0000000..4d82f27 --- /dev/null +++ b/linden/indra/media_plugins/example/CMakeLists.txt | |||
@@ -0,0 +1,74 @@ | |||
1 | # -*- cmake -*- | ||
2 | |||
3 | project(media_plugin_example) | ||
4 | |||
5 | include(00-Common) | ||
6 | include(LLCommon) | ||
7 | include(LLImage) | ||
8 | include(LLPlugin) | ||
9 | include(LLMath) | ||
10 | include(LLRender) | ||
11 | include(LLWindow) | ||
12 | include(Linking) | ||
13 | include(PluginAPI) | ||
14 | include(MediaPluginBase) | ||
15 | include(FindOpenGL) | ||
16 | |||
17 | include(ExamplePlugin) | ||
18 | |||
19 | include_directories( | ||
20 | ${LLPLUGIN_INCLUDE_DIRS} | ||
21 | ${MEDIA_PLUGIN_BASE_INCLUDE_DIRS} | ||
22 | ${LLCOMMON_INCLUDE_DIRS} | ||
23 | ${LLMATH_INCLUDE_DIRS} | ||
24 | ${LLIMAGE_INCLUDE_DIRS} | ||
25 | ${LLRENDER_INCLUDE_DIRS} | ||
26 | ${LLWINDOW_INCLUDE_DIRS} | ||
27 | ) | ||
28 | |||
29 | |||
30 | ### media_plugin_example | ||
31 | |||
32 | set(media_plugin_example_SOURCE_FILES | ||
33 | media_plugin_example.cpp | ||
34 | ) | ||
35 | |||
36 | add_library(media_plugin_example | ||
37 | SHARED | ||
38 | ${media_plugin_example_SOURCE_FILES} | ||
39 | ) | ||
40 | |||
41 | target_link_libraries(media_plugin_example | ||
42 | ${LLPLUGIN_LIBRARIES} | ||
43 | ${MEDIA_PLUGIN_BASE_LIBRARIES} | ||
44 | ${LLCOMMON_LIBRARIES} | ||
45 | ${EXAMPLE_PLUGIN_LIBRARIES} | ||
46 | ${PLUGIN_API_WINDOWS_LIBRARIES} | ||
47 | ) | ||
48 | |||
49 | add_dependencies(media_plugin_example | ||
50 | ${LLPLUGIN_LIBRARIES} | ||
51 | ${MEDIA_PLUGIN_BASE_LIBRARIES} | ||
52 | ${LLCOMMON_LIBRARIES} | ||
53 | ) | ||
54 | |||
55 | if (WINDOWS) | ||
56 | set_target_properties( | ||
57 | media_plugin_example | ||
58 | PROPERTIES | ||
59 | LINK_FLAGS "/MANIFEST:NO" | ||
60 | ) | ||
61 | endif (WINDOWS) | ||
62 | |||
63 | if (DARWIN) | ||
64 | # Don't prepend 'lib' to the executable name, and don't embed a full path in the library's install name | ||
65 | set_target_properties( | ||
66 | media_plugin_example | ||
67 | PROPERTIES | ||
68 | PREFIX "" | ||
69 | BUILD_WITH_INSTALL_RPATH 1 | ||
70 | INSTALL_NAME_DIR "@executable_path" | ||
71 | LINK_FLAGS "-exported_symbols_list ${CMAKE_CURRENT_SOURCE_DIR}/../base/media_plugin_base.exp" | ||
72 | ) | ||
73 | |||
74 | endif (DARWIN) \ No newline at end of file | ||