diff options
author | David Walter Seikel | 2014-02-03 15:23:22 +1000 |
---|---|---|
committer | David Walter Seikel | 2014-02-03 15:23:22 +1000 |
commit | d056a17f05a1f90708f554651475e116a2ddbd68 (patch) | |
tree | 07fa4f1cca2a25548b8d2d6b4752b07d8efbd2ff /linden/indra/mac_updater | |
parent | Updating tree and volume LOD. These go to eleven. (diff) | |
parent | Fix up OTR prefs to not crash. (diff) | |
download | meta-impy-next.zip meta-impy-next.tar.gz meta-impy-next.tar.bz2 meta-impy-next.tar.xz |
Diffstat (limited to '')
-rw-r--r-- | linden/indra/mac_updater/CMakeLists.txt | 2 | ||||
-rw-r--r-- | linden/indra/mac_updater/mac_updater.cpp | 6 |
2 files changed, 4 insertions, 4 deletions
diff --git a/linden/indra/mac_updater/CMakeLists.txt b/linden/indra/mac_updater/CMakeLists.txt index 0eac76f..5ae7dd8 100644 --- a/linden/indra/mac_updater/CMakeLists.txt +++ b/linden/indra/mac_updater/CMakeLists.txt | |||
@@ -74,6 +74,6 @@ add_custom_command( | |||
74 | -E | 74 | -E |
75 | copy_directory | 75 | copy_directory |
76 | ${CMAKE_CURRENT_SOURCE_DIR}/AutoUpdater.nib | 76 | ${CMAKE_CURRENT_SOURCE_DIR}/AutoUpdater.nib |
77 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/mac-updater.app/Contents/Resources/AutoUpdater.nib | 77 | ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/mac-updater.app/Contents/Resources/AutoUpdater.nib |
78 | ) | 78 | ) |
79 | 79 | ||
diff --git a/linden/indra/mac_updater/mac_updater.cpp b/linden/indra/mac_updater/mac_updater.cpp index 43d9955..79783d3 100644 --- a/linden/indra/mac_updater/mac_updater.cpp +++ b/linden/indra/mac_updater/mac_updater.cpp | |||
@@ -68,8 +68,8 @@ EventHandlerRef gEventHandler = NULL; | |||
68 | OSStatus gFailure = noErr; | 68 | OSStatus gFailure = noErr; |
69 | Boolean gCancelled = false; | 69 | Boolean gCancelled = false; |
70 | 70 | ||
71 | char *gUpdateURL; | 71 | const char *gUpdateURL; |
72 | char *gProductName; | 72 | const char *gProductName; |
73 | 73 | ||
74 | void *updatethreadproc(void*); | 74 | void *updatethreadproc(void*); |
75 | 75 | ||
@@ -1032,7 +1032,7 @@ void *updatethreadproc(void*) | |||
1032 | if(!mountOutput.empty()) | 1032 | if(!mountOutput.empty()) |
1033 | { | 1033 | { |
1034 | const char *s = mountOutput.c_str(); | 1034 | const char *s = mountOutput.c_str(); |
1035 | char *prefix = "/dev/"; | 1035 | const char *prefix = "/dev/"; |
1036 | char *sub = strstr(s, prefix); | 1036 | char *sub = strstr(s, prefix); |
1037 | 1037 | ||
1038 | if(sub != NULL) | 1038 | if(sub != NULL) |