diff options
author | Jacek Antonelli | 2008-12-01 17:39:58 -0600 |
---|---|---|
committer | Jacek Antonelli | 2008-12-01 17:40:06 -0600 |
commit | 7abecb48babe6a6f09bf6692ba55076546cfced9 (patch) | |
tree | 8d18a88513fb97adf32c10aae78f4be1984942db /linden/indra/mac_crash_logger | |
parent | Second Life viewer sources 1.21.6 (diff) | |
download | meta-impy-7abecb48babe6a6f09bf6692ba55076546cfced9.zip meta-impy-7abecb48babe6a6f09bf6692ba55076546cfced9.tar.gz meta-impy-7abecb48babe6a6f09bf6692ba55076546cfced9.tar.bz2 meta-impy-7abecb48babe6a6f09bf6692ba55076546cfced9.tar.xz |
Second Life viewer sources 1.22.0-RC
Diffstat (limited to 'linden/indra/mac_crash_logger')
-rw-r--r-- | linden/indra/mac_crash_logger/CMakeLists.txt | 13 | ||||
-rw-r--r-- | linden/indra/mac_crash_logger/CrashReporter.nib/info.nib | 8 |
2 files changed, 8 insertions, 13 deletions
diff --git a/linden/indra/mac_crash_logger/CMakeLists.txt b/linden/indra/mac_crash_logger/CMakeLists.txt index 9cddb56..daf3e10 100644 --- a/linden/indra/mac_crash_logger/CMakeLists.txt +++ b/linden/indra/mac_crash_logger/CMakeLists.txt | |||
@@ -3,7 +3,6 @@ | |||
3 | project(mac_crash_logger) | 3 | project(mac_crash_logger) |
4 | 4 | ||
5 | include(00-Common) | 5 | include(00-Common) |
6 | include(Boost) | ||
7 | include(LLCommon) | 6 | include(LLCommon) |
8 | include(LLCrashLogger) | 7 | include(LLCrashLogger) |
9 | include(LLMath) | 8 | include(LLMath) |
@@ -36,7 +35,6 @@ set_source_files_properties(${mac_crash_logger_HEADER_FILES} | |||
36 | list(APPEND mac_crash_logger_SOURCE_FILES ${mac_crash_logger_HEADER_FILES}) | 35 | list(APPEND mac_crash_logger_SOURCE_FILES ${mac_crash_logger_HEADER_FILES}) |
37 | 36 | ||
38 | set(mac_crash_logger_RESOURCE_FILES | 37 | set(mac_crash_logger_RESOURCE_FILES |
39 | Info.plist | ||
40 | CrashReporter.nib/ | 38 | CrashReporter.nib/ |
41 | ) | 39 | ) |
42 | set_source_files_properties( | 40 | set_source_files_properties( |
@@ -44,11 +42,6 @@ set_source_files_properties( | |||
44 | PROPERTIES | 42 | PROPERTIES |
45 | HEADER_FILE_ONLY TRUE | 43 | HEADER_FILE_ONLY TRUE |
46 | ) | 44 | ) |
47 | set_source_files_properties( | ||
48 | Info.plist | ||
49 | PROPERTIES | ||
50 | MACOSX_PACKAGE_LOCATION . # will it blend? + poppy | ||
51 | ) | ||
52 | SOURCE_GROUP("Resources" FILES ${mac_crash_logger_RESOURCE_FILES}) | 45 | SOURCE_GROUP("Resources" FILES ${mac_crash_logger_RESOURCE_FILES}) |
53 | list(APPEND mac_crash_logger_SOURCE_FILES ${mac_crash_logger_RESOURCE_FILES}) | 46 | list(APPEND mac_crash_logger_SOURCE_FILES ${mac_crash_logger_RESOURCE_FILES}) |
54 | 47 | ||
@@ -56,6 +49,11 @@ add_executable(mac-crash-logger | |||
56 | MACOSX_BUNDLE | 49 | MACOSX_BUNDLE |
57 | ${mac_crash_logger_SOURCE_FILES}) | 50 | ${mac_crash_logger_SOURCE_FILES}) |
58 | 51 | ||
52 | set_target_properties(mac-crash-logger | ||
53 | PROPERTIES | ||
54 | MACOSX_BUNDLE_INFO_PLIST ${CMAKE_CURRENT_SOURCE_DIR}/Info.plist | ||
55 | ) | ||
56 | |||
59 | target_link_libraries(mac-crash-logger | 57 | target_link_libraries(mac-crash-logger |
60 | ${LLCRASHLOGGER_LIBRARIES} | 58 | ${LLCRASHLOGGER_LIBRARIES} |
61 | ${LLVFS_LIBRARIES} | 59 | ${LLVFS_LIBRARIES} |
@@ -64,7 +62,6 @@ target_link_libraries(mac-crash-logger | |||
64 | ${LLVFS_LIBRARIES} | 62 | ${LLVFS_LIBRARIES} |
65 | ${LLMATH_LIBRARIES} | 63 | ${LLMATH_LIBRARIES} |
66 | ${LLCOMMON_LIBRARIES} | 64 | ${LLCOMMON_LIBRARIES} |
67 | ${BOOST_SIGNALS_LIBRARY} | ||
68 | ) | 65 | ) |
69 | 66 | ||
70 | add_custom_command( | 67 | add_custom_command( |
diff --git a/linden/indra/mac_crash_logger/CrashReporter.nib/info.nib b/linden/indra/mac_crash_logger/CrashReporter.nib/info.nib index b541744..06805c0 100644 --- a/linden/indra/mac_crash_logger/CrashReporter.nib/info.nib +++ b/linden/indra/mac_crash_logger/CrashReporter.nib/info.nib | |||
@@ -5,15 +5,13 @@ | |||
5 | <key>IBFramework Version</key> | 5 | <key>IBFramework Version</key> |
6 | <string>629</string> | 6 | <string>629</string> |
7 | <key>IBLastKnownRelativeProjectPath</key> | 7 | <key>IBLastKnownRelativeProjectPath</key> |
8 | <string>../macview.xcodeproj</string> | 8 | <string>../../build-darwin-i386/SecondLife.xcodeproj</string> |
9 | <key>IBOldestOS</key> | 9 | <key>IBOldestOS</key> |
10 | <integer>5</integer> | 10 | <integer>5</integer> |
11 | <key>IBOpenObjects</key> | 11 | <key>IBOpenObjects</key> |
12 | <array> | 12 | <array/> |
13 | <integer>193</integer> | ||
14 | </array> | ||
15 | <key>IBSystem Version</key> | 13 | <key>IBSystem Version</key> |
16 | <string>9B18</string> | 14 | <string>9E17</string> |
17 | <key>targetFramework</key> | 15 | <key>targetFramework</key> |
18 | <string>IBCarbonFramework</string> | 16 | <string>IBCarbonFramework</string> |
19 | </dict> | 17 | </dict> |