aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/llwindow/CMakeLists.txt
diff options
context:
space:
mode:
authorMcCabe Maxsted2010-11-12 20:29:33 -0700
committerMcCabe Maxsted2010-11-12 20:29:33 -0700
commit7ada43ada084f347648afa7bd5bec362ee04db54 (patch)
tree7550bb1856b26133251cd0d575de84ef73489351 /linden/indra/llwindow/CMakeLists.txt
parentMerge remote branch 'nickyp/weekly' into weekly (diff)
downloadmeta-impy-7ada43ada084f347648afa7bd5bec362ee04db54.zip
meta-impy-7ada43ada084f347648afa7bd5bec362ee04db54.tar.gz
meta-impy-7ada43ada084f347648afa7bd5bec362ee04db54.tar.bz2
meta-impy-7ada43ada084f347648afa7bd5bec362ee04db54.tar.xz
Fixed fontconfig library not being set for Linux-only
Diffstat (limited to 'linden/indra/llwindow/CMakeLists.txt')
-rw-r--r--linden/indra/llwindow/CMakeLists.txt17
1 files changed, 12 insertions, 5 deletions
diff --git a/linden/indra/llwindow/CMakeLists.txt b/linden/indra/llwindow/CMakeLists.txt
index ea81abf..98da751 100644
--- a/linden/indra/llwindow/CMakeLists.txt
+++ b/linden/indra/llwindow/CMakeLists.txt
@@ -56,11 +56,18 @@ set(viewer_HEADER_FILES
56 56
57# Libraries on which this library depends, needed for Linux builds 57# Libraries on which this library depends, needed for Linux builds
58# Sort by high-level to low-level 58# Sort by high-level to low-level
59set(llwindow_LINK_LIBRARIES 59if (LINUX)
60 ${UI_LIBRARIES} # for GTK 60 set(llwindow_LINK_LIBRARIES
61 ${SDL_LIBRARY} 61 ${UI_LIBRARIES} # for GTK
62 fontconfig # For FCInit and other FC* functions. 62 ${SDL_LIBRARY}
63 ) 63 fontconfig # For FCInit and other FC* functions.
64 )
65else (LINUX)
66 set(llwindow_LINK_LIBRARIES
67 ${UI_LIBRARIES} # for GTK
68 ${SDL_LIBRARY}
69 )
70endif (LINUX)
64 71
65if (DARWIN) 72if (DARWIN)
66 list(APPEND llwindow_SOURCE_FILES 73 list(APPEND llwindow_SOURCE_FILES