diff options
author | McCabe Maxsted | 2010-08-06 03:34:19 -0700 |
---|---|---|
committer | McCabe Maxsted | 2010-08-07 06:26:13 -0700 |
commit | f5cbabf65e1c1b94d2e53e682c2435daec6164e1 (patch) | |
tree | a9b159ca26213727b83ae5a246b1e152f98f69c6 /linden/indra/llui | |
parent | Removed pointless 'About' button from the preferences (diff) | |
download | meta-impy-f5cbabf65e1c1b94d2e53e682c2435daec6164e1.zip meta-impy-f5cbabf65e1c1b94d2e53e682c2435daec6164e1.tar.gz meta-impy-f5cbabf65e1c1b94d2e53e682c2435daec6164e1.tar.bz2 meta-impy-f5cbabf65e1c1b94d2e53e682c2435daec6164e1.tar.xz |
Removed unused LLTabContainerVertical cruft
Diffstat (limited to 'linden/indra/llui')
-rw-r--r-- | linden/indra/llui/CMakeLists.txt | 2 | ||||
-rw-r--r-- | linden/indra/llui/lltabcontainer.cpp | 1 | ||||
-rw-r--r-- | linden/indra/llui/lltabcontainervertical.cpp | 33 | ||||
-rw-r--r-- | linden/indra/llui/lltabcontainervertical.h | 33 | ||||
-rw-r--r-- | linden/indra/llui/lluictrlfactory.cpp | 1 | ||||
-rw-r--r-- | linden/indra/llui/lluifwd.h | 1 |
6 files changed, 0 insertions, 71 deletions
diff --git a/linden/indra/llui/CMakeLists.txt b/linden/indra/llui/CMakeLists.txt index f646e63..a0f80b4 100644 --- a/linden/indra/llui/CMakeLists.txt +++ b/linden/indra/llui/CMakeLists.txt | |||
@@ -63,7 +63,6 @@ set(llui_SOURCE_FILES | |||
63 | llspinctrl.cpp | 63 | llspinctrl.cpp |
64 | llstyle.cpp | 64 | llstyle.cpp |
65 | lltabcontainer.cpp | 65 | lltabcontainer.cpp |
66 | lltabcontainervertical.cpp | ||
67 | lltextbox.cpp | 66 | lltextbox.cpp |
68 | lltexteditor.cpp | 67 | lltexteditor.cpp |
69 | lltextparser.cpp | 68 | lltextparser.cpp |
@@ -119,7 +118,6 @@ set(llui_HEADER_FILES | |||
119 | llspinctrl.h | 118 | llspinctrl.h |
120 | llstyle.h | 119 | llstyle.h |
121 | lltabcontainer.h | 120 | lltabcontainer.h |
122 | lltabcontainervertical.h | ||
123 | lltextbox.h | 121 | lltextbox.h |
124 | lltexteditor.h | 122 | lltexteditor.h |
125 | lltextparser.h | 123 | lltextparser.h |
diff --git a/linden/indra/llui/lltabcontainer.cpp b/linden/indra/llui/lltabcontainer.cpp index 1f94191..4be779c 100644 --- a/linden/indra/llui/lltabcontainer.cpp +++ b/linden/indra/llui/lltabcontainer.cpp | |||
@@ -40,7 +40,6 @@ | |||
40 | #include "lltextbox.h" | 40 | #include "lltextbox.h" |
41 | #include "llcriticaldamp.h" | 41 | #include "llcriticaldamp.h" |
42 | #include "lluictrlfactory.h" | 42 | #include "lluictrlfactory.h" |
43 | #include "lltabcontainervertical.h" | ||
44 | #include "llrender.h" | 43 | #include "llrender.h" |
45 | 44 | ||
46 | const F32 SCROLL_STEP_TIME = 0.4f; | 45 | const F32 SCROLL_STEP_TIME = 0.4f; |
diff --git a/linden/indra/llui/lltabcontainervertical.cpp b/linden/indra/llui/lltabcontainervertical.cpp deleted file mode 100644 index a729c95..0000000 --- a/linden/indra/llui/lltabcontainervertical.cpp +++ /dev/null | |||
@@ -1,33 +0,0 @@ | |||
1 | /** | ||
2 | * @file lltabcontainervertical.cpp | ||
3 | * @brief LLTabContainerVertical base class | ||
4 | * | ||
5 | * $LicenseInfo:firstyear=2001&license=viewergpl$ | ||
6 | * | ||
7 | * Copyright (c) 2001-2009, Linden Research, Inc. | ||
8 | * | ||
9 | * Second Life Viewer Source Code | ||
10 | * The source code in this file ("Source Code") is provided by Linden Lab | ||
11 | * to you under the terms of the GNU General Public License, version 2.0 | ||
12 | * ("GPL"), unless you have obtained a separate licensing agreement | ||
13 | * ("Other License"), formally executed by you and Linden Lab. Terms of | ||
14 | * the GPL can be found in doc/GPL-license.txt in this distribution, or | ||
15 | * online at http://secondlifegrid.net/programs/open_source/licensing/gplv2 | ||
16 | * | ||
17 | * There are special exceptions to the terms and conditions of the GPL as | ||
18 | * it is applied to this Source Code. View the full text of the exception | ||
19 | * in the file doc/FLOSS-exception.txt in this software distribution, or | ||
20 | * online at | ||
21 | * http://secondlifegrid.net/programs/open_source/licensing/flossexception | ||
22 | * | ||
23 | * By copying, modifying or distributing this software, you acknowledge | ||
24 | * that you have read and understood your obligations described above, | ||
25 | * and agree to abide by those obligations. | ||
26 | * | ||
27 | * ALL LINDEN LAB SOURCE CODE IS PROVIDED "AS IS." LINDEN LAB MAKES NO | ||
28 | * WARRANTIES, EXPRESS, IMPLIED OR OTHERWISE, REGARDING ITS ACCURACY, | ||
29 | * COMPLETENESS OR PERFORMANCE. | ||
30 | * $/LicenseInfo$ | ||
31 | */ | ||
32 | |||
33 | // deprecated: see LLTabContainer | ||
diff --git a/linden/indra/llui/lltabcontainervertical.h b/linden/indra/llui/lltabcontainervertical.h deleted file mode 100644 index ce42367..0000000 --- a/linden/indra/llui/lltabcontainervertical.h +++ /dev/null | |||
@@ -1,33 +0,0 @@ | |||
1 | /** | ||
2 | * @file lltabcontainervertical.h | ||
3 | * @brief LLTabContainerVertical base class | ||
4 | * | ||
5 | * $LicenseInfo:firstyear=2001&license=viewergpl$ | ||
6 | * | ||
7 | * Copyright (c) 2001-2009, Linden Research, Inc. | ||
8 | * | ||
9 | * Second Life Viewer Source Code | ||
10 | * The source code in this file ("Source Code") is provided by Linden Lab | ||
11 | * to you under the terms of the GNU General Public License, version 2.0 | ||
12 | * ("GPL"), unless you have obtained a separate licensing agreement | ||
13 | * ("Other License"), formally executed by you and Linden Lab. Terms of | ||
14 | * the GPL can be found in doc/GPL-license.txt in this distribution, or | ||
15 | * online at http://secondlifegrid.net/programs/open_source/licensing/gplv2 | ||
16 | * | ||
17 | * There are special exceptions to the terms and conditions of the GPL as | ||
18 | * it is applied to this Source Code. View the full text of the exception | ||
19 | * in the file doc/FLOSS-exception.txt in this software distribution, or | ||
20 | * online at | ||
21 | * http://secondlifegrid.net/programs/open_source/licensing/flossexception | ||
22 | * | ||
23 | * By copying, modifying or distributing this software, you acknowledge | ||
24 | * that you have read and understood your obligations described above, | ||
25 | * and agree to abide by those obligations. | ||
26 | * | ||
27 | * ALL LINDEN LAB SOURCE CODE IS PROVIDED "AS IS." LINDEN LAB MAKES NO | ||
28 | * WARRANTIES, EXPRESS, IMPLIED OR OTHERWISE, REGARDING ITS ACCURACY, | ||
29 | * COMPLETENESS OR PERFORMANCE. | ||
30 | * $/LicenseInfo$ | ||
31 | */ | ||
32 | |||
33 | // deprecated: see LLTabContainer | ||
diff --git a/linden/indra/llui/lluictrlfactory.cpp b/linden/indra/llui/lluictrlfactory.cpp index 07eb39b..5cfc3ee 100644 --- a/linden/indra/llui/lluictrlfactory.cpp +++ b/linden/indra/llui/lluictrlfactory.cpp | |||
@@ -64,7 +64,6 @@ | |||
64 | #include "llmultisliderctrl.h" | 64 | #include "llmultisliderctrl.h" |
65 | #include "llspinctrl.h" | 65 | #include "llspinctrl.h" |
66 | #include "lltabcontainer.h" | 66 | #include "lltabcontainer.h" |
67 | #include "lltabcontainervertical.h" | ||
68 | #include "lltextbox.h" | 67 | #include "lltextbox.h" |
69 | #include "lltexteditor.h" | 68 | #include "lltexteditor.h" |
70 | #include "llui.h" | 69 | #include "llui.h" |
diff --git a/linden/indra/llui/lluifwd.h b/linden/indra/llui/lluifwd.h index 32d5c9b..f99bb39 100644 --- a/linden/indra/llui/lluifwd.h +++ b/linden/indra/llui/lluifwd.h | |||
@@ -53,7 +53,6 @@ class LLSlider; | |||
53 | class LLSliderCtrl; | 53 | class LLSliderCtrl; |
54 | class LLSpinCtrl; | 54 | class LLSpinCtrl; |
55 | class LLTabContainer; | 55 | class LLTabContainer; |
56 | class LLTabContainerVertical; | ||
57 | class LLTextBox; | 56 | class LLTextBox; |
58 | class LLTextEditor; | 57 | class LLTextEditor; |
59 | class LLTextureCtrl; | 58 | class LLTextureCtrl; |