aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/llui/llfunctorregistry.h
diff options
context:
space:
mode:
authorDavid Walter Seikel2013-08-30 21:42:45 +1000
committerDavid Walter Seikel2013-08-30 21:42:45 +1000
commit56a1de48ee43bfacbd3ef2859f392082a26bc814 (patch)
tree03bd6092dab42985e536b84d2f311a3a12e4edb4 /linden/indra/llui/llfunctorregistry.h
parentAdded a licensing note about gpg.vs, as used to build OTR on Windows. (diff)
parentMerge remote-tracking branch 'origin/next' into WL-refactor (diff)
downloadmeta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.zip
meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.tar.gz
meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.tar.bz2
meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.tar.xz
Merge remote-tracking branch 'imprudence/next' into next
Unless otherwise stated, Imprudence changes accepted. The three images seem to be the same. Conflicts: .gitignore linden/indra/develop.py linden/indra/llcommon/llsdserialize_xml.cpp linden/indra/newview/CMakeLists.txt Manually combined MOAP, OTR, and WL changes from both. linden/indra/newview/app_settings/default_grids.xml Manually merged the grid collection. Also updated IG info. linden/indra/newview/hippoupdate.cpp linden/indra/newview/llettherebelight.cpp Just used the Imprudence copy. linden/indra/newview/llviewermessage.cpp Keep unbranding. linden/indra/newview/llvoavatar.cpp Manually merge client tags. linden/indra/newview/res/viewerRes.rc Manually merge version from Impy. linden/indra/newview/skins/dark/colors_base.xml Keep unbranding. linden/indra/newview/skins/default/html/unabletoconnect.png linden/indra/newview/skins/default/textures/icon_top_pick.tga linden/indra/newview/skins/default/xui/en-us/floater_about.xml Manual merging of contributors. linden/indra/newview/skins/gemini/colors_base.xml Keep unbranding. linden/indra/newview/skins/gemini/textures/icon_top_pick.tga linden/indra/newview/viewer_manifest.py Manually merged boost, gstreamer, OTR, and name. linden/indra/newview/viewerinfo.cpp Manually merge the comment.
Diffstat (limited to 'linden/indra/llui/llfunctorregistry.h')
-rw-r--r--linden/indra/llui/llfunctorregistry.h2
1 files changed, 0 insertions, 2 deletions
diff --git a/linden/indra/llui/llfunctorregistry.h b/linden/indra/llui/llfunctorregistry.h
index 8864f7a..7c03f2f 100644
--- a/linden/indra/llui/llfunctorregistry.h
+++ b/linden/indra/llui/llfunctorregistry.h
@@ -75,7 +75,6 @@ public:
75 bool registerFunctor(const std::string& name, ResponseFunctor f) 75 bool registerFunctor(const std::string& name, ResponseFunctor f)
76 { 76 {
77 bool retval = true; 77 bool retval = true;
78 typename FunctorMap::iterator it = mMap.find(name);
79 if (mMap.count(name) == 0) 78 if (mMap.count(name) == 0)
80 { 79 {
81 mMap[name] = f; 80 mMap[name] = f;
@@ -102,7 +101,6 @@ public:
102 101
103 FUNCTOR_TYPE getFunctor(const std::string& name) 102 FUNCTOR_TYPE getFunctor(const std::string& name)
104 { 103 {
105 typename FunctorMap::iterator it = mMap.find(name);
106 if (mMap.count(name) != 0) 104 if (mMap.count(name) != 0)
107 { 105 {
108 return mMap[name]; 106 return mMap[name];