diff options
author | David Walter Seikel | 2013-08-30 21:42:45 +1000 |
---|---|---|
committer | David Walter Seikel | 2013-08-30 21:42:45 +1000 |
commit | 56a1de48ee43bfacbd3ef2859f392082a26bc814 (patch) | |
tree | 03bd6092dab42985e536b84d2f311a3a12e4edb4 /linden/indra/llui/llcombobox.cpp | |
parent | Added a licensing note about gpg.vs, as used to build OTR on Windows. (diff) | |
parent | Merge remote-tracking branch 'origin/next' into WL-refactor (diff) | |
download | meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.zip meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.tar.gz meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.tar.bz2 meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.tar.xz |
Merge remote-tracking branch 'imprudence/next' into next
Unless otherwise stated, Imprudence changes accepted. The three images seem to be the same.
Conflicts:
.gitignore
linden/indra/develop.py
linden/indra/llcommon/llsdserialize_xml.cpp
linden/indra/newview/CMakeLists.txt
Manually combined MOAP, OTR, and WL changes from both.
linden/indra/newview/app_settings/default_grids.xml
Manually merged the grid collection.
Also updated IG info.
linden/indra/newview/hippoupdate.cpp
linden/indra/newview/llettherebelight.cpp
Just used the Imprudence copy.
linden/indra/newview/llviewermessage.cpp
Keep unbranding.
linden/indra/newview/llvoavatar.cpp
Manually merge client tags.
linden/indra/newview/res/viewerRes.rc
Manually merge version from Impy.
linden/indra/newview/skins/dark/colors_base.xml
Keep unbranding.
linden/indra/newview/skins/default/html/unabletoconnect.png
linden/indra/newview/skins/default/textures/icon_top_pick.tga
linden/indra/newview/skins/default/xui/en-us/floater_about.xml
Manual merging of contributors.
linden/indra/newview/skins/gemini/colors_base.xml
Keep unbranding.
linden/indra/newview/skins/gemini/textures/icon_top_pick.tga
linden/indra/newview/viewer_manifest.py
Manually merged boost, gstreamer, OTR, and name.
linden/indra/newview/viewerinfo.cpp
Manually merge the comment.
Diffstat (limited to 'linden/indra/llui/llcombobox.cpp')
-rw-r--r-- | linden/indra/llui/llcombobox.cpp | 5 |
1 files changed, 3 insertions, 2 deletions
diff --git a/linden/indra/llui/llcombobox.cpp b/linden/indra/llui/llcombobox.cpp index 2546c4e..e79f7b2 100644 --- a/linden/indra/llui/llcombobox.cpp +++ b/linden/indra/llui/llcombobox.cpp | |||
@@ -75,7 +75,8 @@ LLComboBox::LLComboBox( const std::string& name, const LLRect &rect, const std:: | |||
75 | mListPosition(BELOW), | 75 | mListPosition(BELOW), |
76 | mPrearrangeCallback( NULL ), | 76 | mPrearrangeCallback( NULL ), |
77 | mTextEntryCallback( NULL ), | 77 | mTextEntryCallback( NULL ), |
78 | mLabel(label) | 78 | mLabel(label), |
79 | mListColor(LLUI::sColorsGroup->getColor("ComboBoxBg")) | ||
79 | { | 80 | { |
80 | if (font) | 81 | if (font) |
81 | { | 82 | { |
@@ -109,7 +110,7 @@ LLComboBox::LLComboBox( const std::string& name, const LLRect &rect, const std:: | |||
109 | mList = new LLScrollListCtrl(std::string("ComboBox"), LLRect(), mGLFont, | 110 | mList = new LLScrollListCtrl(std::string("ComboBox"), LLRect(), mGLFont, |
110 | &LLComboBox::onItemSelected, this, FALSE); | 111 | &LLComboBox::onItemSelected, this, FALSE); |
111 | mList->setVisible(FALSE); | 112 | mList->setVisible(FALSE); |
112 | mList->setBgWriteableColor( LLColor4(1,1,1,1) ); | 113 | mList->setBgWriteableColor(mListColor); |
113 | mList->setCommitOnKeyboardMovement(FALSE); | 114 | mList->setCommitOnKeyboardMovement(FALSE); |
114 | addChild(mList); | 115 | addChild(mList); |
115 | 116 | ||