diff options
author | Jacek Antonelli | 2008-09-06 18:24:57 -0500 |
---|---|---|
committer | Jacek Antonelli | 2008-09-06 18:25:07 -0500 |
commit | 798d367d54a6c6379ad355bd8345fa40e31e7fe9 (patch) | |
tree | 1921f1708cd0240648c97bc02df2c2ab5f2fc41e /linden/indra/llprimitive/CMakeLists.txt | |
parent | Second Life viewer sources 1.20.15 (diff) | |
download | meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.zip meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.gz meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.bz2 meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.xz |
Second Life viewer sources 1.21.0-RC
Diffstat (limited to 'linden/indra/llprimitive/CMakeLists.txt')
-rw-r--r-- | linden/indra/llprimitive/CMakeLists.txt | 49 |
1 files changed, 49 insertions, 0 deletions
diff --git a/linden/indra/llprimitive/CMakeLists.txt b/linden/indra/llprimitive/CMakeLists.txt new file mode 100644 index 0000000..5dc4c70 --- /dev/null +++ b/linden/indra/llprimitive/CMakeLists.txt | |||
@@ -0,0 +1,49 @@ | |||
1 | # -*- cmake -*- | ||
2 | |||
3 | project(llprimitive) | ||
4 | |||
5 | include(00-Common) | ||
6 | include(LLCommon) | ||
7 | include(LLMath) | ||
8 | include(LLMessage) | ||
9 | include(LLXML) | ||
10 | |||
11 | include_directories( | ||
12 | ${LLCOMMON_INCLUDE_DIRS} | ||
13 | ${LLMATH_INCLUDE_DIRS} | ||
14 | ${LLMESSAGE_INCLUDE_DIRS} | ||
15 | ${LLXML_INCLUDE_DIRS} | ||
16 | ) | ||
17 | |||
18 | set(llprimitive_SOURCE_FILES | ||
19 | llmaterialtable.cpp | ||
20 | llprimitive.cpp | ||
21 | lltextureanim.cpp | ||
22 | lltextureentry.cpp | ||
23 | lltreeparams.cpp | ||
24 | llvolumemessage.cpp | ||
25 | llvolumexml.cpp | ||
26 | ) | ||
27 | |||
28 | set(llprimitive_HEADER_FILES | ||
29 | CMakeLists.txt | ||
30 | |||
31 | legacy_object_types.h | ||
32 | llmaterialtable.h | ||
33 | llprimitive.h | ||
34 | lltextureanim.h | ||
35 | lltextureentry.h | ||
36 | lltreeparams.h | ||
37 | lltree_common.h | ||
38 | llvolumemessage.h | ||
39 | llvolumexml.h | ||
40 | material_codes.h | ||
41 | object_flags.h | ||
42 | ) | ||
43 | |||
44 | set_source_files_properties(${llprimitive_HEADER_FILES} | ||
45 | PROPERTIES HEADER_FILE_ONLY TRUE) | ||
46 | |||
47 | list(APPEND llprimitive_SOURCE_FILES ${llprimitive_HEADER_FILES}) | ||
48 | |||
49 | add_library (llprimitive ${llprimitive_SOURCE_FILES}) | ||