diff options
author | David Seikel | 2011-06-04 00:17:28 +1000 |
---|---|---|
committer | David Seikel | 2011-06-04 00:17:28 +1000 |
commit | 492eaaf4eec82327116f2605e3d8becf94bec1b3 (patch) | |
tree | dcddd674cb4861445c3ec5aaa59325b99a437614 /linden/indra/llplugin/llpluginmessage.cpp | |
parent | Set the real bare minimum prim size to 0.00001, as 0 sized objects cause bugs. (diff) | |
parent | Fixing the menu to actually use its color options reveals how broken the whol... (diff) | |
download | meta-impy-492eaaf4eec82327116f2605e3d8becf94bec1b3.zip meta-impy-492eaaf4eec82327116f2605e3d8becf94bec1b3.tar.gz meta-impy-492eaaf4eec82327116f2605e3d8becf94bec1b3.tar.bz2 meta-impy-492eaaf4eec82327116f2605e3d8becf94bec1b3.tar.xz |
Merge branch 'next' of git://github.com/jacek/imprudence into next
Conflicts (manually merged):
linden/indra/llcommon/llversionviewer.h
linden/indra/llvfs/lldir.cpp
linden/indra/llvfs/lldir_mac.cpp
linden/indra/newview/CMakeLists.txt
linden/indra/newview/English.lproj/InfoPlist.strings
linden/indra/newview/Info-Imprudence.plist
linden/indra/newview/Info-meta-impy.plist
linden/indra/newview/llappviewer.cpp
linden/indra/newview/llpanellogin.cpp
linden/indra/newview/packaging/mac/Info.plist.in
linden/indra/newview/res/viewerRes.rc
linden/indra/newview/skins/default/xui/en-us/floater_about.xml
linden/indra/newview/skins/default/xui/en-us/panel_preferences_advanced.xml
linden/indra/newview/skins/default/xui/en-us/panel_preferences_graphics1.xml
linden/indra/newview/skins/default/xui/en-us/panel_preferences_im.xml
linden/indra/newview/skins/default/xui/en-us/panel_preferences_skins.xml
linden/indra/newview/skins/default/xui/en-us/panel_preferences_web.xml
linden/indra/newview/skins/default/xui/zh/menu_viewer.xml
linden/indra/newview/skins/default/xui/zh/panel_group_general.xml
linden/indra/newview/viewer_manifest.py
linden/indra/newview/viewerversion.cpp
linden/indra/newview/viewerversion.h
linden/install.xml
Also some post merge tweaks.
Diffstat (limited to 'linden/indra/llplugin/llpluginmessage.cpp')
-rwxr-xr-x | linden/indra/llplugin/llpluginmessage.cpp | 13 |
1 files changed, 8 insertions, 5 deletions
diff --git a/linden/indra/llplugin/llpluginmessage.cpp b/linden/indra/llplugin/llpluginmessage.cpp index 0810a04..9c4940a 100755 --- a/linden/indra/llplugin/llpluginmessage.cpp +++ b/linden/indra/llplugin/llpluginmessage.cpp | |||
@@ -368,7 +368,8 @@ std::string LLPluginMessage::generate(void) const | |||
368 | 368 | ||
369 | // Pretty XML may be slightly easier to deal with while debugging... | 369 | // Pretty XML may be slightly easier to deal with while debugging... |
370 | // LLSDSerialize::toXML(mMessage, result); | 370 | // LLSDSerialize::toXML(mMessage, result); |
371 | LLSDSerialize::toPrettyXML(mMessage, result); | 371 | // LLSDSerialize::toPrettyXML(mMessage, result); |
372 | result << mMessage; | ||
372 | 373 | ||
373 | return result.str(); | 374 | return result.str(); |
374 | } | 375 | } |
@@ -383,10 +384,12 @@ int LLPluginMessage::parse(const std::string &message) | |||
383 | // clear any previous state | 384 | // clear any previous state |
384 | clear(); | 385 | clear(); |
385 | 386 | ||
386 | std::istringstream input(message); | 387 | std::istringstream input(message); |
387 | 388 | ||
388 | S32 parse_result = LLSDSerialize::fromXML(mMessage, input); | 389 | |
389 | 390 | // S32 parse_result = LLSDSerialize::fromXML(test, input); | |
391 | S32 parse_result = LLSDSerialize::fromNotation( mMessage, input, LLSDSerialize::SIZE_UNLIMITED) ; | ||
392 | |||
390 | return (int)parse_result; | 393 | return (int)parse_result; |
391 | } | 394 | } |
392 | 395 | ||