diff options
author | Armin Weatherwax | 2010-08-07 19:17:13 +0200 |
---|---|---|
committer | Armin Weatherwax | 2010-09-23 15:42:40 +0200 |
commit | 70800de39a3d942d2120abd926fbdb24577fb0f6 (patch) | |
tree | efeb12456e1a8ee7182656dc7503dc9b89a07a63 /linden/indra/llplugin/CMakeLists.txt | |
parent | fix some mime type issues (diff) | |
download | meta-impy-70800de39a3d942d2120abd926fbdb24577fb0f6.zip meta-impy-70800de39a3d942d2120abd926fbdb24577fb0f6.tar.gz meta-impy-70800de39a3d942d2120abd926fbdb24577fb0f6.tar.bz2 meta-impy-70800de39a3d942d2120abd926fbdb24577fb0f6.tar.xz |
update to viewer-external SLPlugin + webkit. Fixes (lots of) webpages not loading.
Issue: llqtwebkit needs update for Linux 64bit
Diffstat (limited to 'linden/indra/llplugin/CMakeLists.txt')
-rw-r--r-- | linden/indra/llplugin/CMakeLists.txt | 19 |
1 files changed, 19 insertions, 0 deletions
diff --git a/linden/indra/llplugin/CMakeLists.txt b/linden/indra/llplugin/CMakeLists.txt index 8a2eff8..8eead94 100644 --- a/linden/indra/llplugin/CMakeLists.txt +++ b/linden/indra/llplugin/CMakeLists.txt | |||
@@ -7,6 +7,7 @@ if(HAVE_64_BIT) | |||
7 | endif(HAVE_64_BIT) | 7 | endif(HAVE_64_BIT) |
8 | 8 | ||
9 | include(00-Common) | 9 | include(00-Common) |
10 | include(CURL) | ||
10 | include(LLCommon) | 11 | include(LLCommon) |
11 | include(LLImage) | 12 | include(LLImage) |
12 | include(LLMath) | 13 | include(LLMath) |
@@ -27,6 +28,7 @@ include_directories( | |||
27 | 28 | ||
28 | set(llplugin_SOURCE_FILES | 29 | set(llplugin_SOURCE_FILES |
29 | llpluginclassmedia.cpp | 30 | llpluginclassmedia.cpp |
31 | llplugincookiestore.cpp | ||
30 | llplugininstance.cpp | 32 | llplugininstance.cpp |
31 | llpluginmessage.cpp | 33 | llpluginmessage.cpp |
32 | llpluginmessagepipe.cpp | 34 | llpluginmessagepipe.cpp |
@@ -40,6 +42,7 @@ set(llplugin_HEADER_FILES | |||
40 | 42 | ||
41 | llpluginclassmedia.h | 43 | llpluginclassmedia.h |
42 | llpluginclassmediaowner.h | 44 | llpluginclassmediaowner.h |
45 | llplugincookiestore.h | ||
43 | llplugininstance.h | 46 | llplugininstance.h |
44 | llpluginmessage.h | 47 | llpluginmessage.h |
45 | llpluginmessageclasses.h | 48 | llpluginmessageclasses.h |
@@ -65,3 +68,19 @@ list(APPEND llplugin_SOURCE_FILES ${llplugin_HEADER_FILES}) | |||
65 | add_library (llplugin ${llplugin_SOURCE_FILES}) | 68 | add_library (llplugin ${llplugin_SOURCE_FILES}) |
66 | 69 | ||
67 | add_subdirectory(slplugin) | 70 | add_subdirectory(slplugin) |
71 | |||
72 | # # Add tests | ||
73 | # include(LLAddBuildTest) | ||
74 | # # UNIT TESTS | ||
75 | # SET(llplugin_TEST_SOURCE_FILES | ||
76 | # llplugincookiestore.cpp | ||
77 | # ) | ||
78 | # | ||
79 | # # llplugincookiestore has a dependency on curl, so we need to link the curl library into the test. | ||
80 | # set_source_files_properties( | ||
81 | # llplugincookiestore.cpp | ||
82 | # PROPERTIES | ||
83 | # LL_TEST_ADDITIONAL_LIBRARIES "${CURL_LIBRARIES}" | ||
84 | # ) | ||
85 | # | ||
86 | # LL_ADD_PROJECT_UNIT_TESTS(llplugin "${llplugin_TEST_SOURCE_FILES}") \ No newline at end of file | ||