aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/llmath/llvolume.cpp
diff options
context:
space:
mode:
authorDavid Walter Seikel2013-08-30 21:42:45 +1000
committerDavid Walter Seikel2013-08-30 21:42:45 +1000
commit56a1de48ee43bfacbd3ef2859f392082a26bc814 (patch)
tree03bd6092dab42985e536b84d2f311a3a12e4edb4 /linden/indra/llmath/llvolume.cpp
parentAdded a licensing note about gpg.vs, as used to build OTR on Windows. (diff)
parentMerge remote-tracking branch 'origin/next' into WL-refactor (diff)
downloadmeta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.zip
meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.tar.gz
meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.tar.bz2
meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.tar.xz
Merge remote-tracking branch 'imprudence/next' into next
Unless otherwise stated, Imprudence changes accepted. The three images seem to be the same. Conflicts: .gitignore linden/indra/develop.py linden/indra/llcommon/llsdserialize_xml.cpp linden/indra/newview/CMakeLists.txt Manually combined MOAP, OTR, and WL changes from both. linden/indra/newview/app_settings/default_grids.xml Manually merged the grid collection. Also updated IG info. linden/indra/newview/hippoupdate.cpp linden/indra/newview/llettherebelight.cpp Just used the Imprudence copy. linden/indra/newview/llviewermessage.cpp Keep unbranding. linden/indra/newview/llvoavatar.cpp Manually merge client tags. linden/indra/newview/res/viewerRes.rc Manually merge version from Impy. linden/indra/newview/skins/dark/colors_base.xml Keep unbranding. linden/indra/newview/skins/default/html/unabletoconnect.png linden/indra/newview/skins/default/textures/icon_top_pick.tga linden/indra/newview/skins/default/xui/en-us/floater_about.xml Manual merging of contributors. linden/indra/newview/skins/gemini/colors_base.xml Keep unbranding. linden/indra/newview/skins/gemini/textures/icon_top_pick.tga linden/indra/newview/viewer_manifest.py Manually merged boost, gstreamer, OTR, and name. linden/indra/newview/viewerinfo.cpp Manually merge the comment.
Diffstat (limited to 'linden/indra/llmath/llvolume.cpp')
-rw-r--r--linden/indra/llmath/llvolume.cpp9
1 files changed, 1 insertions, 8 deletions
diff --git a/linden/indra/llmath/llvolume.cpp b/linden/indra/llmath/llvolume.cpp
index 618048c..9dc3746 100644
--- a/linden/indra/llmath/llvolume.cpp
+++ b/linden/indra/llmath/llvolume.cpp
@@ -4437,14 +4437,7 @@ BOOL LLVolumeFace::createUnCutCubeCap(LLVolume* volume, BOOL partial_build)
4437 const std::vector<LLVector3>& profile = volume->getProfile().mProfile; 4437 const std::vector<LLVector3>& profile = volume->getProfile().mProfile;
4438 S32 max_s = volume->getProfile().getTotal(); 4438 S32 max_s = volume->getProfile().getTotal();
4439 S32 max_t = volume->getPath().mPath.size(); 4439 S32 max_t = volume->getPath().mPath.size();
4440 4440 S32 grid_size = (profile.size() - 1) / 4;
4441 // S32 i;
4442 S32 num_vertices = 0, num_indices = 0;
4443 S32 grid_size = (profile.size()-1)/4;
4444 S32 quad_count = (grid_size * grid_size);
4445
4446 num_vertices = (grid_size+1)*(grid_size+1);
4447 num_indices = quad_count * 4;
4448 4441
4449 LLVector3& min = mExtents[0]; 4442 LLVector3& min = mExtents[0];
4450 LLVector3& max = mExtents[1]; 4443 LLVector3& max = mExtents[1];