aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/llcrashlogger/CMakeLists.txt
diff options
context:
space:
mode:
authorJacek Antonelli2008-09-06 18:24:57 -0500
committerJacek Antonelli2008-09-06 18:25:07 -0500
commit798d367d54a6c6379ad355bd8345fa40e31e7fe9 (patch)
tree1921f1708cd0240648c97bc02df2c2ab5f2fc41e /linden/indra/llcrashlogger/CMakeLists.txt
parentSecond Life viewer sources 1.20.15 (diff)
downloadmeta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.zip
meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.gz
meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.bz2
meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.xz
Second Life viewer sources 1.21.0-RC
Diffstat (limited to 'linden/indra/llcrashlogger/CMakeLists.txt')
-rw-r--r--linden/indra/llcrashlogger/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/linden/indra/llcrashlogger/CMakeLists.txt b/linden/indra/llcrashlogger/CMakeLists.txt
new file mode 100644
index 0000000..b2639ae
--- /dev/null
+++ b/linden/indra/llcrashlogger/CMakeLists.txt
@@ -0,0 +1,35 @@
1# -*- cmake -*-
2
3project(llcrashlogger)
4
5include(00-Common)
6include(LLCommon)
7include(LLMath)
8include(LLMessage)
9include(LLVFS)
10include(LLXML)
11
12include_directories(
13 ${LLCOMMON_INCLUDE_DIRS}
14 ${LLMATH_INCLUDE_DIRS}
15 ${LLMESSAGE_INCLUDE_DIRS}
16 ${LLVFS_INCLUDE_DIRS}
17 ${LLXML_INCLUDE_DIRS}
18 )
19
20set(llcrashlogger_SOURCE_FILES
21 llcrashlogger.cpp
22 )
23
24set(llcrashlogger_HEADER_FILES
25 CMakeLists.txt
26
27 llcrashlogger.h
28 )
29
30set_source_files_properties(${llcrashlogger_HEADER_FILES}
31 PROPERTIES HEADER_FILE_ONLY TRUE)
32
33list(APPEND llcrashlogger_SOURCE_FILES ${llcrashlogger_HEADER_FILES})
34
35add_library(llcrashlogger ${llcrashlogger_SOURCE_FILES})