diff options
author | Armin Weatherwax | 2010-06-17 11:15:54 +0200 |
---|---|---|
committer | Armin Weatherwax | 2010-09-23 15:42:39 +0200 |
commit | c4891694b7c8fcc469dfa057ebf397ee28fc44b1 (patch) | |
tree | 75d1ea097989c8f54c89bd0a1b5da9bac0e74db9 /linden/indra/llcommon | |
parent | update llplugin to latest version of SG2, pull latest webkit (diff) | |
download | meta-impy-c4891694b7c8fcc469dfa057ebf397ee28fc44b1.zip meta-impy-c4891694b7c8fcc469dfa057ebf397ee28fc44b1.tar.gz meta-impy-c4891694b7c8fcc469dfa057ebf397ee28fc44b1.tar.bz2 meta-impy-c4891694b7c8fcc469dfa057ebf397ee28fc44b1.tar.xz |
Robin Cornelius: fixes for building plugins on Linux 64bit
Diffstat (limited to 'linden/indra/llcommon')
-rw-r--r-- | linden/indra/llcommon/CMakeLists.txt | 20 |
1 files changed, 20 insertions, 0 deletions
diff --git a/linden/indra/llcommon/CMakeLists.txt b/linden/indra/llcommon/CMakeLists.txt index 1c12e55..ae961a3 100644 --- a/linden/indra/llcommon/CMakeLists.txt +++ b/linden/indra/llcommon/CMakeLists.txt | |||
@@ -198,3 +198,23 @@ target_link_libraries( | |||
198 | ${EXPAT_LIBRARIES} | 198 | ${EXPAT_LIBRARIES} |
199 | ${ZLIB_LIBRARIES} | 199 | ${ZLIB_LIBRARIES} |
200 | ) | 200 | ) |
201 | |||
202 | if(HAVE_64_BIT) | ||
203 | add_library (llcommonPIC ${llcommon_SOURCE_FILES}) | ||
204 | add_dependencies(llcommonPIC prepare) | ||
205 | |||
206 | if(WINDOWS) | ||
207 | add_definitions(/FIXED:NO) | ||
208 | else(WINDOWS) # not windows therefore gcc LINUX and DARWIN | ||
209 | add_definitions(-fPIC) | ||
210 | endif(WINDOWS) | ||
211 | |||
212 | target_link_libraries( | ||
213 | llcommonPIC | ||
214 | ${APRUTIL_LIBRARIES} | ||
215 | ${APR_LIBRARIES} | ||
216 | ${EXPAT_LIBRARIES} | ||
217 | ${ZLIB_LIBRARIES} | ||
218 | ) | ||
219 | endif(HAVE_64_BIT) | ||
220 | |||