aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/llaudio/CMakeLists.txt
diff options
context:
space:
mode:
authorJacek Antonelli2008-09-06 18:24:57 -0500
committerJacek Antonelli2008-09-06 18:25:07 -0500
commit798d367d54a6c6379ad355bd8345fa40e31e7fe9 (patch)
tree1921f1708cd0240648c97bc02df2c2ab5f2fc41e /linden/indra/llaudio/CMakeLists.txt
parentSecond Life viewer sources 1.20.15 (diff)
downloadmeta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.zip
meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.gz
meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.bz2
meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.xz
Second Life viewer sources 1.21.0-RC
Diffstat (limited to 'linden/indra/llaudio/CMakeLists.txt')
-rw-r--r--linden/indra/llaudio/CMakeLists.txt67
1 files changed, 67 insertions, 0 deletions
diff --git a/linden/indra/llaudio/CMakeLists.txt b/linden/indra/llaudio/CMakeLists.txt
new file mode 100644
index 0000000..b662023
--- /dev/null
+++ b/linden/indra/llaudio/CMakeLists.txt
@@ -0,0 +1,67 @@
1# -*- cmake -*-
2
3project(llaudio)
4
5include(00-Common)
6include(Audio)
7include(FMOD)
8include(LLCommon)
9include(LLMath)
10include(LLMessage)
11include(LLVFS)
12
13include_directories(
14 ${FMOD_INCLUDE_DIR}
15 ${LLCOMMON_INCLUDE_DIRS}
16 ${LLMATH_INCLUDE_DIRS}
17 ${LLMESSAGE_INCLUDE_DIRS}
18 ${LLVFS_INCLUDE_DIRS}
19 ${OGG_INCLUDE_DIRS}
20 ${VORBISENC_INCLUDE_DIRS}
21 ${VORBISFILE_INCLUDE_DIRS}
22 ${VORBIS_INCLUDE_DIRS}
23 )
24
25set(llaudio_SOURCE_FILES
26 audioengine.cpp
27 listener.cpp
28 llaudiodecodemgr.cpp
29 vorbisdecode.cpp
30 vorbisencode.cpp
31 )
32
33set(llaudio_HEADER_FILES
34 CMakeLists.txt
35
36 audioengine.h
37 listener.h
38 llaudiodecodemgr.h
39 vorbisdecode.h
40 vorbisencode.h
41 )
42
43if (FMOD)
44 list(APPEND llaudio_SOURCE_FILES
45 audioengine_fmod.cpp
46 listener_fmod.cpp
47 )
48
49 list(APPEND llaudio_HEADER_FILES
50 audioengine_fmod.h
51 listener_fmod.h
52 )
53
54 if (LINUX)
55 if (${CXX_VERSION} MATCHES "4.[23]")
56 set_source_files_properties(audioengine_fmod.cpp
57 COMPILE_FLAGS -Wno-error=write-strings)
58 endif (${CXX_VERSION} MATCHES "4.[23]")
59 endif (LINUX)
60endif (FMOD)
61
62set_source_files_properties(${llaudio_HEADER_FILES}
63 PROPERTIES HEADER_FILE_ONLY TRUE)
64
65list(APPEND llaudio_SOURCE_FILES ${llaudio_HEADER_FILES})
66
67add_library (llaudio ${llaudio_SOURCE_FILES})