aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/linux_crash_logger/CMakeLists.txt
diff options
context:
space:
mode:
authorJacek Antonelli2008-09-06 18:24:57 -0500
committerJacek Antonelli2008-09-06 18:25:07 -0500
commit798d367d54a6c6379ad355bd8345fa40e31e7fe9 (patch)
tree1921f1708cd0240648c97bc02df2c2ab5f2fc41e /linden/indra/linux_crash_logger/CMakeLists.txt
parentSecond Life viewer sources 1.20.15 (diff)
downloadmeta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.zip
meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.gz
meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.bz2
meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.xz
Second Life viewer sources 1.21.0-RC
Diffstat (limited to 'linden/indra/linux_crash_logger/CMakeLists.txt')
-rw-r--r--linden/indra/linux_crash_logger/CMakeLists.txt68
1 files changed, 68 insertions, 0 deletions
diff --git a/linden/indra/linux_crash_logger/CMakeLists.txt b/linden/indra/linux_crash_logger/CMakeLists.txt
new file mode 100644
index 0000000..628d4ac
--- /dev/null
+++ b/linden/indra/linux_crash_logger/CMakeLists.txt
@@ -0,0 +1,68 @@
1# -*- cmake -*-
2
3project(linux_crash_logger)
4
5include(00-Common)
6include(Boost)
7include(LLCommon)
8include(LLCrashLogger)
9include(LLMath)
10include(LLMessage)
11include(LLVFS)
12include(LLXML)
13include(Linking)
14include(UI)
15
16include_directories(
17 ${LLCOMMON_INCLUDE_DIRS}
18 ${LLCRASHLOGGER_INCLUDE_DIRS}
19 ${LLMATH_INCLUDE_DIRS}
20 ${LLVFS_INCLUDE_DIRS}
21 ${LLXML_INCLUDE_DIRS}
22 )
23
24set(linux_crash_logger_SOURCE_FILES
25 linux_crash_logger.cpp
26 llcrashloggerlinux.cpp
27 )
28
29set(linux_crash_logger_HEADER_FILES
30 CMakeLists.txt
31
32 llcrashloggerlinux.h
33 )
34
35set_source_files_properties(${linux_crash_logger_HEADER_FILES}
36 PROPERTIES HEADER_FILE_ONLY TRUE)
37
38list(APPEND linux_crash_logger_SOURCE_FILES
39 ${linux_crash_logger_HEADER_FILES}
40 )
41
42list(APPEND CMAKE_EXE_LINKER_FLAGS -Wl,--as-needed)
43
44add_executable(linux-crash-logger ${linux_crash_logger_SOURCE_FILES})
45
46target_link_libraries(linux-crash-logger
47 ${LLCRASHLOGGER_LIBRARIES}
48 ${LLVFS_LIBRARIES}
49 ${LLXML_LIBRARIES}
50 ${LLMESSAGE_LIBRARIES}
51 ${LLVFS_LIBRARIES}
52 ${LLMATH_LIBRARIES}
53 ${LLCOMMON_LIBRARIES}
54 ${UI_LIBRARIES}
55 ${BOOST_SIGNALS_LIBRARY}
56 ${DB_LIBRARIES}
57 )
58
59add_custom_command(
60 OUTPUT linux-crash-logger-stripped
61 COMMAND strip
62 ARGS --strip-debug -o linux-crash-logger-stripped
63 linux-crash-logger
64 DEPENDS linux-crash-logger
65 )
66
67add_custom_target(linux-crash-logger-stripped ALL
68 DEPENDS linux-crash-logger-stripped)