diff options
author | Jacek Antonelli | 2008-09-06 18:24:57 -0500 |
---|---|---|
committer | Jacek Antonelli | 2008-09-06 18:25:07 -0500 |
commit | 798d367d54a6c6379ad355bd8345fa40e31e7fe9 (patch) | |
tree | 1921f1708cd0240648c97bc02df2c2ab5f2fc41e /linden/indra/linux_crash_logger/CMakeLists.txt | |
parent | Second Life viewer sources 1.20.15 (diff) | |
download | meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.zip meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.gz meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.bz2 meta-impy-798d367d54a6c6379ad355bd8345fa40e31e7fe9.tar.xz |
Second Life viewer sources 1.21.0-RC
Diffstat (limited to 'linden/indra/linux_crash_logger/CMakeLists.txt')
-rw-r--r-- | linden/indra/linux_crash_logger/CMakeLists.txt | 68 |
1 files changed, 68 insertions, 0 deletions
diff --git a/linden/indra/linux_crash_logger/CMakeLists.txt b/linden/indra/linux_crash_logger/CMakeLists.txt new file mode 100644 index 0000000..628d4ac --- /dev/null +++ b/linden/indra/linux_crash_logger/CMakeLists.txt | |||
@@ -0,0 +1,68 @@ | |||
1 | # -*- cmake -*- | ||
2 | |||
3 | project(linux_crash_logger) | ||
4 | |||
5 | include(00-Common) | ||
6 | include(Boost) | ||
7 | include(LLCommon) | ||
8 | include(LLCrashLogger) | ||
9 | include(LLMath) | ||
10 | include(LLMessage) | ||
11 | include(LLVFS) | ||
12 | include(LLXML) | ||
13 | include(Linking) | ||
14 | include(UI) | ||
15 | |||
16 | include_directories( | ||
17 | ${LLCOMMON_INCLUDE_DIRS} | ||
18 | ${LLCRASHLOGGER_INCLUDE_DIRS} | ||
19 | ${LLMATH_INCLUDE_DIRS} | ||
20 | ${LLVFS_INCLUDE_DIRS} | ||
21 | ${LLXML_INCLUDE_DIRS} | ||
22 | ) | ||
23 | |||
24 | set(linux_crash_logger_SOURCE_FILES | ||
25 | linux_crash_logger.cpp | ||
26 | llcrashloggerlinux.cpp | ||
27 | ) | ||
28 | |||
29 | set(linux_crash_logger_HEADER_FILES | ||
30 | CMakeLists.txt | ||
31 | |||
32 | llcrashloggerlinux.h | ||
33 | ) | ||
34 | |||
35 | set_source_files_properties(${linux_crash_logger_HEADER_FILES} | ||
36 | PROPERTIES HEADER_FILE_ONLY TRUE) | ||
37 | |||
38 | list(APPEND linux_crash_logger_SOURCE_FILES | ||
39 | ${linux_crash_logger_HEADER_FILES} | ||
40 | ) | ||
41 | |||
42 | list(APPEND CMAKE_EXE_LINKER_FLAGS -Wl,--as-needed) | ||
43 | |||
44 | add_executable(linux-crash-logger ${linux_crash_logger_SOURCE_FILES}) | ||
45 | |||
46 | target_link_libraries(linux-crash-logger | ||
47 | ${LLCRASHLOGGER_LIBRARIES} | ||
48 | ${LLVFS_LIBRARIES} | ||
49 | ${LLXML_LIBRARIES} | ||
50 | ${LLMESSAGE_LIBRARIES} | ||
51 | ${LLVFS_LIBRARIES} | ||
52 | ${LLMATH_LIBRARIES} | ||
53 | ${LLCOMMON_LIBRARIES} | ||
54 | ${UI_LIBRARIES} | ||
55 | ${BOOST_SIGNALS_LIBRARY} | ||
56 | ${DB_LIBRARIES} | ||
57 | ) | ||
58 | |||
59 | add_custom_command( | ||
60 | OUTPUT linux-crash-logger-stripped | ||
61 | COMMAND strip | ||
62 | ARGS --strip-debug -o linux-crash-logger-stripped | ||
63 | linux-crash-logger | ||
64 | DEPENDS linux-crash-logger | ||
65 | ) | ||
66 | |||
67 | add_custom_target(linux-crash-logger-stripped ALL | ||
68 | DEPENDS linux-crash-logger-stripped) | ||