diff options
author | Jay Threeth | 2011-04-04 11:48:26 -0700 |
---|---|---|
committer | Jay Threeth | 2011-04-04 11:48:26 -0700 |
commit | 3c9cc506f741b980565ff5b3b001cd8b6ee36b12 (patch) | |
tree | cb862c57b3d5f74177cde3bd962a53fc377166f6 /linden/indra/libgcrypt/libgcrypt-1.2.2/src/Makefile.am | |
parent | build fixes, might build on linux now (diff) | |
download | meta-impy-3c9cc506f741b980565ff5b3b001cd8b6ee36b12.zip meta-impy-3c9cc506f741b980565ff5b3b001cd8b6ee36b12.tar.gz meta-impy-3c9cc506f741b980565ff5b3b001cd8b6ee36b12.tar.bz2 meta-impy-3c9cc506f741b980565ff5b3b001cd8b6ee36b12.tar.xz |
add source to libraries, and cruft for building under windows
Diffstat (limited to 'linden/indra/libgcrypt/libgcrypt-1.2.2/src/Makefile.am')
-rwxr-xr-x | linden/indra/libgcrypt/libgcrypt-1.2.2/src/Makefile.am | 47 |
1 files changed, 47 insertions, 0 deletions
diff --git a/linden/indra/libgcrypt/libgcrypt-1.2.2/src/Makefile.am b/linden/indra/libgcrypt/libgcrypt-1.2.2/src/Makefile.am new file mode 100755 index 0000000..2e5612c --- /dev/null +++ b/linden/indra/libgcrypt/libgcrypt-1.2.2/src/Makefile.am | |||
@@ -0,0 +1,47 @@ | |||
1 | # Copyright (C) 1998,1999,2000,2001,2002,2003,2004 Free Software Foundation, Inc. | ||
2 | # | ||
3 | # This file is part of Libgcrypt. | ||
4 | # | ||
5 | # Libgcrypt is free software; you can redistribute it and/or modify | ||
6 | # it under the terms of the GNU Lesser General Public License as | ||
7 | # published by the Free Software Foundation; either version 2.1 of | ||
8 | # the License, or (at your option) any later version. | ||
9 | # | ||
10 | # Libgcrypt is distributed in the hope that it will be useful, | ||
11 | # but WITHOUT ANY WARRANTY; without even the implied warranty of | ||
12 | # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the | ||
13 | # GNU Lesser General Public License for more details. | ||
14 | # | ||
15 | # You should have received a copy of the GNU Lesser General Public | ||
16 | # License along with this program; if not, write to the Free Software | ||
17 | # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA | ||
18 | |||
19 | ## Process this file with automake to produce Makefile.in | ||
20 | |||
21 | EXTRA_DIST = Manifest libgcrypt-config.in libgcrypt.m4 libgcrypt.vers | ||
22 | bin_SCRIPTS = libgcrypt-config | ||
23 | m4datadir = $(datadir)/aclocal | ||
24 | m4data_DATA = libgcrypt.m4 | ||
25 | include_HEADERS = gcrypt.h gcrypt-module.h | ||
26 | |||
27 | lib_LTLIBRARIES = libgcrypt.la | ||
28 | |||
29 | if HAVE_LD_VERSION_SCRIPT | ||
30 | libgcrypt_version_script_cmd = -Wl,--version-script=$(srcdir)/libgcrypt.vers | ||
31 | else | ||
32 | libgcrypt_version_script_cmd = | ||
33 | endif | ||
34 | |||
35 | libgcrypt_la_CFLAGS = @GPG_ERROR_CFLAGS@ | ||
36 | libgcrypt_la_SOURCES = g10lib.h types.h cipher.h \ | ||
37 | misc.c global.c sexp.c \ | ||
38 | stdmem.c stdmem.h secmem.c secmem.h \ | ||
39 | mpi.h missing-string.c module.c \ | ||
40 | ath.h ath.c | ||
41 | |||
42 | libgcrypt_la_LDFLAGS = $(libgcrypt_version_script_cmd) -version-info \ | ||
43 | @LIBGCRYPT_LT_CURRENT@:@LIBGCRYPT_LT_REVISION@:@LIBGCRYPT_LT_AGE@ | ||
44 | libgcrypt_la_DEPENDENCIES = ../cipher/libcipher.la ../mpi/libmpi.la \ | ||
45 | $(srcdir)/libgcrypt.vers | ||
46 | libgcrypt_la_LIBADD = ../cipher/libcipher.la ../mpi/libmpi.la \ | ||
47 | @LTLIBOBJS@ @GPG_ERROR_LIBS@ | ||