aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/libgcrypt/libgcrypt-1.2.2/config.h.in
diff options
context:
space:
mode:
authorJay Threeth2011-04-04 11:48:26 -0700
committerJay Threeth2011-04-04 11:48:26 -0700
commit3c9cc506f741b980565ff5b3b001cd8b6ee36b12 (patch)
treecb862c57b3d5f74177cde3bd962a53fc377166f6 /linden/indra/libgcrypt/libgcrypt-1.2.2/config.h.in
parentbuild fixes, might build on linux now (diff)
downloadmeta-impy-3c9cc506f741b980565ff5b3b001cd8b6ee36b12.zip
meta-impy-3c9cc506f741b980565ff5b3b001cd8b6ee36b12.tar.gz
meta-impy-3c9cc506f741b980565ff5b3b001cd8b6ee36b12.tar.bz2
meta-impy-3c9cc506f741b980565ff5b3b001cd8b6ee36b12.tar.xz
add source to libraries, and cruft for building under windows
Diffstat (limited to 'linden/indra/libgcrypt/libgcrypt-1.2.2/config.h.in')
-rwxr-xr-xlinden/indra/libgcrypt/libgcrypt-1.2.2/config.h.in313
1 files changed, 313 insertions, 0 deletions
diff --git a/linden/indra/libgcrypt/libgcrypt-1.2.2/config.h.in b/linden/indra/libgcrypt/libgcrypt-1.2.2/config.h.in
new file mode 100755
index 0000000..7e35934
--- /dev/null
+++ b/linden/indra/libgcrypt/libgcrypt-1.2.2/config.h.in
@@ -0,0 +1,313 @@
1/* config.h.in. Generated from configure.ac by autoheader. */
2
3
4/* need this, because some autoconf tests rely on this (e.g. stpcpy)
5 * and it should be used for new programs */
6#define _GNU_SOURCE 1
7
8
9/* Define if you don't want the default EGD socket name. For details see
10 cipher/rndegd.c */
11#undef EGD_SOCKET_NAME
12
13/* The default error source for libgcrypt. */
14#undef GPG_ERR_SOURCE_DEFAULT
15
16/* Define to 1 if you have the `atexit' function. */
17#undef HAVE_ATEXIT
18
19/* Defined if the mlock() call does not work */
20#undef HAVE_BROKEN_MLOCK
21
22/* Defined if a `byte' is typedef'd */
23#undef HAVE_BYTE_TYPEDEF
24
25/* Define to 1 if you have the `clock_gettime' function. */
26#undef HAVE_CLOCK_GETTIME
27
28/* Define to 1 if you have the declaration of `sys_siglist', and to 0 if you
29 don't. */
30#undef HAVE_DECL_SYS_SIGLIST
31
32/* defined if the system supports a random device */
33#undef HAVE_DEV_RANDOM
34
35/* Define to 1 if you have the <dlfcn.h> header file. */
36#undef HAVE_DLFCN_H
37
38/* Define to 1 if you don't have `vprintf' but do have `_doprnt.' */
39#undef HAVE_DOPRNT
40
41/* defined if we run on some of the PCDOS like systems (DOS, Windoze. OS/2)
42 with special properties like no file modes */
43#undef HAVE_DOSISH_SYSTEM
44
45/* defined if we must run on a stupid file system */
46#undef HAVE_DRIVE_LETTERS
47
48/* Define to 1 if you have the `gethrtime' function. */
49#undef HAVE_GETHRTIME
50
51/* Define to 1 if you have the `getpagesize' function. */
52#undef HAVE_GETPAGESIZE
53
54/* Define to 1 if you have the `getrusage' function. */
55#undef HAVE_GETRUSAGE
56
57/* Define to 1 if you have the `gettimeofday' function. */
58#undef HAVE_GETTIMEOFDAY
59
60/* Define to 1 if you have the <inttypes.h> header file. */
61#undef HAVE_INTTYPES_H
62
63/* Define to 1 if you have the `nsl' library (-lnsl). */
64#undef HAVE_LIBNSL
65
66/* Define to 1 if you have the `rt' library (-lrt). */
67#undef HAVE_LIBRT
68
69/* Define to 1 if you have the `memmove' function. */
70#undef HAVE_MEMMOVE
71
72/* Define to 1 if you have the <memory.h> header file. */
73#undef HAVE_MEMORY_H
74
75/* Defined if the system supports an mlock() call */
76#undef HAVE_MLOCK
77
78/* Define to 1 if you have the `mmap' function. */
79#undef HAVE_MMAP
80
81/* Define to 1 if you have the `raise' function. */
82#undef HAVE_RAISE
83
84/* Define to 1 if you have the `rand' function. */
85#undef HAVE_RAND
86
87/* Define to 1 if you have the <stdint.h> header file. */
88#undef HAVE_STDINT_H
89
90/* Define to 1 if you have the <stdlib.h> header file. */
91#undef HAVE_STDLIB_H
92
93/* Define to 1 if you have the `stpcpy' function. */
94#undef HAVE_STPCPY
95
96/* Define to 1 if you have the `strcasecmp' function. */
97#undef HAVE_STRCASECMP
98
99/* Define to 1 if you have the `strerror' function. */
100#undef HAVE_STRERROR
101
102/* Define to 1 if you have the `stricmp' function. */
103#undef HAVE_STRICMP
104
105/* Define to 1 if you have the <strings.h> header file. */
106#undef HAVE_STRINGS_H
107
108/* Define to 1 if you have the <string.h> header file. */
109#undef HAVE_STRING_H
110
111/* Define to 1 if you have the `strtoul' function. */
112#undef HAVE_STRTOUL
113
114/* Define to 1 if you have the <sys/capability.h> header file. */
115#undef HAVE_SYS_CAPABILITY_H
116
117/* Define to 1 if you have the <sys/mman.h> header file. */
118#undef HAVE_SYS_MMAN_H
119
120/* Define to 1 if you have the <sys/select.h> header file. */
121#undef HAVE_SYS_SELECT_H
122
123/* Define to 1 if you have the <sys/stat.h> header file. */
124#undef HAVE_SYS_STAT_H
125
126/* Define to 1 if you have the <sys/types.h> header file. */
127#undef HAVE_SYS_TYPES_H
128
129/* Defined if a `u16' is typedef'd */
130#undef HAVE_U16_TYPEDEF
131
132/* Defined if a `u32' is typedef'd */
133#undef HAVE_U32_TYPEDEF
134
135/* Defined if a `ulong' is typedef'd */
136#undef HAVE_ULONG_TYPEDEF
137
138/* Define to 1 if you have the <unistd.h> header file. */
139#undef HAVE_UNISTD_H
140
141/* Defined if a `ushort' is typedef'd */
142#undef HAVE_USHORT_TYPEDEF
143
144/* Define to 1 if you have the `vprintf' function. */
145#undef HAVE_VPRINTF
146
147/* Define to 1 if you have the `wait4' function. */
148#undef HAVE_WAIT4
149
150/* Define to 1 if you have the `waitpid' function. */
151#undef HAVE_WAITPID
152
153/* Defined if this is not a regular release */
154#undef IS_DEVELOPMENT_VERSION
155
156/* Define to use the (obsolete) malloc guarding feature */
157#undef M_GUARD
158
159/* defined to the name of the strong random device */
160#undef NAME_OF_DEV_RANDOM
161
162/* defined to the name of the weaker random device */
163#undef NAME_OF_DEV_URANDOM
164
165/* Name of this package */
166#undef PACKAGE
167
168/* Define to the address where bug reports for this package should be sent. */
169#undef PACKAGE_BUGREPORT
170
171/* Define to the full name of this package. */
172#undef PACKAGE_NAME
173
174/* Define to the full name and version of this package. */
175#undef PACKAGE_STRING
176
177/* Define to the one symbol short name of this package. */
178#undef PACKAGE_TARNAME
179
180/* Define to the version of this package. */
181#undef PACKAGE_VERSION
182
183/* A human readable text with the name of the OS */
184#undef PRINTABLE_OS_NAME
185
186/* Define as the return type of signal handlers (`int' or `void'). */
187#undef RETSIGTYPE
188
189/* The size of a `unsigned int', as computed by sizeof. */
190#undef SIZEOF_UNSIGNED_INT
191
192/* The size of a `unsigned long', as computed by sizeof. */
193#undef SIZEOF_UNSIGNED_LONG
194
195/* The size of a `unsigned long long', as computed by sizeof. */
196#undef SIZEOF_UNSIGNED_LONG_LONG
197
198/* The size of a `unsigned short', as computed by sizeof. */
199#undef SIZEOF_UNSIGNED_SHORT
200
201/* Define to 1 if you have the ANSI C header files. */
202#undef STDC_HEADERS
203
204/* Defined if this module should be included */
205#undef USE_AES
206
207/* Defined if this module should be included */
208#undef USE_ARCFOUR
209
210/* Defined if this module should be included */
211#undef USE_BLOWFISH
212
213/* define if capabilities should be used */
214#undef USE_CAPABILITIES
215
216/* Defined if this module should be included */
217#undef USE_CAST5
218
219/* Defined if this module should be included */
220#undef USE_CRC
221
222/* Defined if this module should be included */
223#undef USE_DES
224
225/* Defined if this module should be included */
226#undef USE_DSA
227
228/* Defined if this module should be included */
229#undef USE_ELGAMAL
230
231/* Defined if this module should be included */
232#undef USE_MD4
233
234/* Defined if this module should be included */
235#undef USE_MD5
236
237/* set this to limit filenames to the 8.3 format */
238#undef USE_ONLY_8DOT3
239
240/* Defined if this module should be included */
241#undef USE_RFC2268
242
243/* Defined if this module should be included */
244#undef USE_RMD160
245
246/* Defined if the EGD based RNG should be used. */
247#undef USE_RNDEGD
248
249/* Defined if the /dev/random based RNG should be used. */
250#undef USE_RNDLINUX
251
252/* Defined if the default Unix RNG should be used. */
253#undef USE_RNDUNIX
254
255/* Defined if the Windows specific RNG should be used. */
256#undef USE_RNDW32
257
258/* Defined if this module should be included */
259#undef USE_RSA
260
261/* Defined if this module should be included */
262#undef USE_SERPENT
263
264/* Defined if this module should be included */
265#undef USE_SHA1
266
267/* Defined if this module should be included */
268#undef USE_SHA256
269
270/* Defined if this module should be included */
271#undef USE_SHA512
272
273/* Defined if this module should be included */
274#undef USE_TIGER
275
276/* Defined if this module should be included */
277#undef USE_TWOFISH
278
279/* Version of this package */
280#undef VERSION
281
282/* Defined if compiled symbols have a leading underscore */
283#undef WITH_SYMBOL_UNDERSCORE
284
285/* Define to 1 if your processor stores words with the most significant byte
286 first (like Motorola and SPARC, unlike Intel and VAX). */
287#undef WORDS_BIGENDIAN
288
289/* To allow the use of Libgcrypt in multithreaded programs we have to use
290 special features from the library. */
291#ifndef _REENTRANT
292# define _REENTRANT 1
293#endif
294
295
296/* Define to empty if `const' does not conform to ANSI C. */
297#undef const
298
299/* Define to `__inline__' or `__inline' if that's what the C compiler
300 calls it, or to nothing if 'inline' is not supported under any name. */
301#ifndef __cplusplus
302#undef inline
303#endif
304
305/* Define to `unsigned' if <sys/types.h> does not define. */
306#undef size_t
307
308/* Define to `int' if unavailable. */
309#undef socklen_t
310
311
312#define _GCRYPT_IN_LIBGCRYPT 1
313