aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/libgcrypt/libgcrypt-1.2.2/autogen.sh
diff options
context:
space:
mode:
authorDavid Walter Seikel2011-06-27 15:59:06 +1000
committerDavid Walter Seikel2011-06-27 15:59:06 +1000
commit92bd9b2503e7dd927f416cb9b17f169ea925fa56 (patch)
treef0f3776cfc0c6e6224db66f5678387c580095f16 /linden/indra/libgcrypt/libgcrypt-1.2.2/autogen.sh
parentMake use of the new packaging stuff from upstream. (diff)
downloadmeta-impy-92bd9b2503e7dd927f416cb9b17f169ea925fa56.zip
meta-impy-92bd9b2503e7dd927f416cb9b17f169ea925fa56.tar.gz
meta-impy-92bd9b2503e7dd927f416cb9b17f169ea925fa56.tar.bz2
meta-impy-92bd9b2503e7dd927f416cb9b17f169ea925fa56.tar.xz
Clean up line endings, execute bits, and other bits of errant nonsense from Windows.
Diffstat (limited to 'linden/indra/libgcrypt/libgcrypt-1.2.2/autogen.sh')
-rwxr-xr-xlinden/indra/libgcrypt/libgcrypt-1.2.2/autogen.sh306
1 files changed, 153 insertions, 153 deletions
diff --git a/linden/indra/libgcrypt/libgcrypt-1.2.2/autogen.sh b/linden/indra/libgcrypt/libgcrypt-1.2.2/autogen.sh
index 96720e7..4b82dfd 100755
--- a/linden/indra/libgcrypt/libgcrypt-1.2.2/autogen.sh
+++ b/linden/indra/libgcrypt/libgcrypt-1.2.2/autogen.sh
@@ -1,153 +1,153 @@
1#! /bin/sh 1#! /bin/sh
2# Run this to generate all the initial makefiles, etc. 2# Run this to generate all the initial makefiles, etc.
3# 3#
4# Copyright (C) 2003, 2004 g10 Code GmbH 4# Copyright (C) 2003, 2004 g10 Code GmbH
5# 5#
6# This file is free software; as a special exception the author gives 6# This file is free software; as a special exception the author gives
7# unlimited permission to copy and/or distribute it, with or without 7# unlimited permission to copy and/or distribute it, with or without
8# modifications, as long as this notice is preserved. 8# modifications, as long as this notice is preserved.
9# 9#
10# This program is distributed in the hope that it will be useful, but 10# This program is distributed in the hope that it will be useful, but
11# WITHOUT ANY WARRANTY, to the extent permitted by law; without even the 11# WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
12# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. 12# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
13 13
14configure_ac="configure.ac" 14configure_ac="configure.ac"
15 15
16cvtver () { 16cvtver () {
17 awk 'NR==1 {split($NF,A,".");X=1000000*A[1]+1000*A[2]+A[3];print X;exit 0}' 17 awk 'NR==1 {split($NF,A,".");X=1000000*A[1]+1000*A[2]+A[3];print X;exit 0}'
18} 18}
19 19
20check_version () { 20check_version () {
21 if [ `("$1" --version || echo "0") | cvtver` -ge "$2" ]; then 21 if [ `("$1" --version || echo "0") | cvtver` -ge "$2" ]; then
22 return 0 22 return 0
23 fi 23 fi
24 echo "**Error**: "\`$1\'" not installed or too old." >&2 24 echo "**Error**: "\`$1\'" not installed or too old." >&2
25 echo ' Version '$3' or newer is required.' >&2 25 echo ' Version '$3' or newer is required.' >&2
26 [ -n "$4" ] && echo ' Note that this is part of '\`$4\''.' >&2 26 [ -n "$4" ] && echo ' Note that this is part of '\`$4\''.' >&2
27 DIE="yes" 27 DIE="yes"
28 return 1 28 return 1
29} 29}
30 30
31DIE=no 31DIE=no
32 32
33 33
34# Used to cross-compile for Windows. 34# Used to cross-compile for Windows.
35if test "$1" = "--build-w32"; then 35if test "$1" = "--build-w32"; then
36 tmp=`dirname $0` 36 tmp=`dirname $0`
37 tsdir=`cd "$tmp"; pwd` 37 tsdir=`cd "$tmp"; pwd`
38 shift 38 shift
39 if [ ! -f $tsdir/config.guess ]; then 39 if [ ! -f $tsdir/config.guess ]; then
40 echo "$tsdir/config.guess not found" >&2 40 echo "$tsdir/config.guess not found" >&2
41 exit 1 41 exit 1
42 fi 42 fi
43 build=`$tsdir/config.guess` 43 build=`$tsdir/config.guess`
44 44
45 [ -z "$w32root" ] && w32root="$HOME/w32root" 45 [ -z "$w32root" ] && w32root="$HOME/w32root"
46 echo "Using $w32root as standard install directory" >&2 46 echo "Using $w32root as standard install directory" >&2
47 47
48 # See whether we have the Debian cross compiler package or the 48 # See whether we have the Debian cross compiler package or the
49 # old mingw32/cpd system 49 # old mingw32/cpd system
50 if i586-mingw32msvc-gcc --version >/dev/null 2>&1 ; then 50 if i586-mingw32msvc-gcc --version >/dev/null 2>&1 ; then
51 host=i586-mingw32msvc 51 host=i586-mingw32msvc
52 crossbindir=/usr/$host/bin 52 crossbindir=/usr/$host/bin
53 else 53 else
54 host=i386--mingw32 54 host=i386--mingw32
55 if ! mingw32 --version >/dev/null; then 55 if ! mingw32 --version >/dev/null; then
56 echo "We need at least version 0.3 of MingW32/CPD" >&2 56 echo "We need at least version 0.3 of MingW32/CPD" >&2
57 exit 1 57 exit 1
58 fi 58 fi
59 crossbindir=`mingw32 --install-dir`/bin 59 crossbindir=`mingw32 --install-dir`/bin
60 # Old autoconf version required us to setup the environment 60 # Old autoconf version required us to setup the environment
61 # with the proper tool names. 61 # with the proper tool names.
62 CC=`mingw32 --get-path gcc` 62 CC=`mingw32 --get-path gcc`
63 CPP=`mingw32 --get-path cpp` 63 CPP=`mingw32 --get-path cpp`
64 AR=`mingw32 --get-path ar` 64 AR=`mingw32 --get-path ar`
65 RANLIB=`mingw32 --get-path ranlib` 65 RANLIB=`mingw32 --get-path ranlib`
66 export CC CPP AR RANLIB 66 export CC CPP AR RANLIB
67 fi 67 fi
68 68
69 if [ -f "$tsdir/config.log" ]; then 69 if [ -f "$tsdir/config.log" ]; then
70 if ! head $tsdir/config.log | grep "$host" >/dev/null; then 70 if ! head $tsdir/config.log | grep "$host" >/dev/null; then
71 echo "Pease run a 'make distclean' first" >&2 71 echo "Pease run a 'make distclean' first" >&2
72 exit 1 72 exit 1
73 fi 73 fi
74 fi 74 fi
75 75
76 ./configure --enable-maintainer-mode --prefix=${w32root} \ 76 ./configure --enable-maintainer-mode --prefix=${w32root} \
77 --host=i586-mingw32msvc --build=${build} \ 77 --host=i586-mingw32msvc --build=${build} \
78 --with-gpg-error-prefix=${w32root} \ 78 --with-gpg-error-prefix=${w32root} \
79 --disable-shared 79 --disable-shared
80 80
81 exit $? 81 exit $?
82fi 82fi
83 83
84 84
85 85
86 86
87# Grep the required versions from configure.ac 87# Grep the required versions from configure.ac
88autoconf_vers=`sed -n '/^AC_PREREQ(/ { 88autoconf_vers=`sed -n '/^AC_PREREQ(/ {
89s/^.*(\(.*\))/\1/p 89s/^.*(\(.*\))/\1/p
90q 90q
91}' ${configure_ac}` 91}' ${configure_ac}`
92autoconf_vers_num=`echo "$autoconf_vers" | cvtver` 92autoconf_vers_num=`echo "$autoconf_vers" | cvtver`
93 93
94automake_vers=`sed -n '/^min_automake_version=/ { 94automake_vers=`sed -n '/^min_automake_version=/ {
95s/^.*="\(.*\)"/\1/p 95s/^.*="\(.*\)"/\1/p
96q 96q
97}' ${configure_ac}` 97}' ${configure_ac}`
98automake_vers_num=`echo "$automake_vers" | cvtver` 98automake_vers_num=`echo "$automake_vers" | cvtver`
99 99
100#gettext_vers=`sed -n '/^AM_GNU_GETTEXT_VERSION(/ { 100#gettext_vers=`sed -n '/^AM_GNU_GETTEXT_VERSION(/ {
101#s/^.*(\(.*\))/\1/p 101#s/^.*(\(.*\))/\1/p
102#q 102#q
103#}' ${configure_ac}` 103#}' ${configure_ac}`
104#gettext_vers_num=`echo "$gettext_vers" | cvtver` 104#gettext_vers_num=`echo "$gettext_vers" | cvtver`
105 105
106 106
107if [ -z "$autoconf_vers" -o -z "$automake_vers" ] 107if [ -z "$autoconf_vers" -o -z "$automake_vers" ]
108then 108then
109 echo "**Error**: version information not found in "\`${configure_ac}\'"." >&2 109 echo "**Error**: version information not found in "\`${configure_ac}\'"." >&2
110 exit 1 110 exit 1
111fi 111fi
112 112
113# Allow to override the default tool names 113# Allow to override the default tool names
114AUTOCONF=${AUTOCONF_PREFIX}${AUTOCONF:-autoconf}${AUTOCONF_SUFFIX} 114AUTOCONF=${AUTOCONF_PREFIX}${AUTOCONF:-autoconf}${AUTOCONF_SUFFIX}
115AUTOHEADER=${AUTOCONF_PREFIX}${AUTOHEADER:-autoheader}${AUTOCONF_SUFFIX} 115AUTOHEADER=${AUTOCONF_PREFIX}${AUTOHEADER:-autoheader}${AUTOCONF_SUFFIX}
116 116
117AUTOMAKE=${AUTOMAKE_PREFIX}${AUTOMAKE:-automake}${AUTOMAKE_SUFFIX} 117AUTOMAKE=${AUTOMAKE_PREFIX}${AUTOMAKE:-automake}${AUTOMAKE_SUFFIX}
118ACLOCAL=${AUTOMAKE_PREFIX}${ACLOCAL:-aclocal}${AUTOMAKE_SUFFIX} 118ACLOCAL=${AUTOMAKE_PREFIX}${ACLOCAL:-aclocal}${AUTOMAKE_SUFFIX}
119 119
120#GETTEXT=${GETTEXT_PREFIX}${GETTEXT:-gettext}${GETTEXT_SUFFIX} 120#GETTEXT=${GETTEXT_PREFIX}${GETTEXT:-gettext}${GETTEXT_SUFFIX}
121#MSGMERGE=${GETTEXT_PREFIX}${MSGMERGE:-msgmerge}${GETTEXT_SUFFIX} 121#MSGMERGE=${GETTEXT_PREFIX}${MSGMERGE:-msgmerge}${GETTEXT_SUFFIX}
122 122
123 123
124if check_version $AUTOCONF $autoconf_vers_num $autoconf_vers ; then 124if check_version $AUTOCONF $autoconf_vers_num $autoconf_vers ; then
125 check_version $AUTOHEADER $autoconf_vers_num $autoconf_vers autoconf 125 check_version $AUTOHEADER $autoconf_vers_num $autoconf_vers autoconf
126fi 126fi
127if check_version $AUTOMAKE $automake_vers_num $automake_vers; then 127if check_version $AUTOMAKE $automake_vers_num $automake_vers; then
128 check_version $ACLOCAL $automake_vers_num $autoconf_vers automake 128 check_version $ACLOCAL $automake_vers_num $autoconf_vers automake
129fi 129fi
130#if check_version $GETTEXT $gettext_vers_num $gettext_vers; then 130#if check_version $GETTEXT $gettext_vers_num $gettext_vers; then
131# check_version $MSGMERGE $gettext_vers_num $gettext_vers gettext 131# check_version $MSGMERGE $gettext_vers_num $gettext_vers gettext
132#fi 132#fi
133 133
134if test "$DIE" = "yes"; then 134if test "$DIE" = "yes"; then
135 cat <<EOF 135 cat <<EOF
136 136
137Note that you may use alternative versions of the tools by setting 137Note that you may use alternative versions of the tools by setting
138the corresponding environment variables; see README.CVS for details. 138the corresponding environment variables; see README.CVS for details.
139 139
140EOF 140EOF
141 exit 1 141 exit 1
142fi 142fi
143 143
144echo "Running aclocal -I m4 ${ACLOCAL_FLAGS:+$ACLOCAL_FLAGS }..." 144echo "Running aclocal -I m4 ${ACLOCAL_FLAGS:+$ACLOCAL_FLAGS }..."
145$ACLOCAL -I m4 $ACLOCAL_FLAGS 145$ACLOCAL -I m4 $ACLOCAL_FLAGS
146echo "Running autoheader..." 146echo "Running autoheader..."
147$AUTOHEADER 147$AUTOHEADER
148echo "Running automake --gnu ..." 148echo "Running automake --gnu ..."
149$AUTOMAKE --gnu; 149$AUTOMAKE --gnu;
150echo "Running autoconf..." 150echo "Running autoconf..."
151$AUTOCONF 151$AUTOCONF
152 152
153echo "You may now run \"./configure --enable-maintainer-mode && make\"." 153echo "You may now run \"./configure --enable-maintainer-mode && make\"."