diff options
author | Jay Threeth | 2011-04-04 11:48:26 -0700 |
---|---|---|
committer | Jay Threeth | 2011-04-04 11:48:26 -0700 |
commit | 3c9cc506f741b980565ff5b3b001cd8b6ee36b12 (patch) | |
tree | cb862c57b3d5f74177cde3bd962a53fc377166f6 /linden/indra/libgcrypt/CMakeLists.txt | |
parent | build fixes, might build on linux now (diff) | |
download | meta-impy-3c9cc506f741b980565ff5b3b001cd8b6ee36b12.zip meta-impy-3c9cc506f741b980565ff5b3b001cd8b6ee36b12.tar.gz meta-impy-3c9cc506f741b980565ff5b3b001cd8b6ee36b12.tar.bz2 meta-impy-3c9cc506f741b980565ff5b3b001cd8b6ee36b12.tar.xz |
add source to libraries, and cruft for building under windows
Diffstat (limited to 'linden/indra/libgcrypt/CMakeLists.txt')
-rwxr-xr-x | linden/indra/libgcrypt/CMakeLists.txt | 121 |
1 files changed, 121 insertions, 0 deletions
diff --git a/linden/indra/libgcrypt/CMakeLists.txt b/linden/indra/libgcrypt/CMakeLists.txt new file mode 100755 index 0000000..14ff871 --- /dev/null +++ b/linden/indra/libgcrypt/CMakeLists.txt | |||
@@ -0,0 +1,121 @@ | |||
1 | # -*- cmake -*- | ||
2 | |||
3 | project(libgcrypt) | ||
4 | |||
5 | if (WINDOWS) | ||
6 | include_directories( | ||
7 | ../gpg.vs/inc.vs | ||
8 | ../gpg.vs/libgcrypt-1.2.2.vs/custom | ||
9 | ../libgpg-error/libgpg-error-1.0/src | ||
10 | libgcrypt-1.2.2/src | ||
11 | libgcrypt-1.2.2/mpi | ||
12 | libgcrypt-1.2.2/mpi/generic | ||
13 | ) | ||
14 | else (WINDOWS) | ||
15 | include_directories( | ||
16 | libgcrypt-1.2.2/src | ||
17 | libgcrypt-1.2.2/mpi | ||
18 | libgcrypt-1.2.2/mpi/generic | ||
19 | ) | ||
20 | endif (WINDOWS) | ||
21 | |||
22 | set(libgcrypt_SOURCE_FILES | ||
23 | libgcrypt-1.2.2/src/ath.c | ||
24 | libgcrypt-1.2.2/src/global.c | ||
25 | libgcrypt-1.2.2/src/misc.c | ||
26 | libgcrypt-1.2.2/src/missing-string.c | ||
27 | libgcrypt-1.2.2/src/module.c | ||
28 | libgcrypt-1.2.2/src/secmem.c | ||
29 | libgcrypt-1.2.2/src/sexp.c | ||
30 | libgcrypt-1.2.2/src/stdmem.c | ||
31 | |||
32 | libgcrypt-1.2.2/cipher/ac.c | ||
33 | libgcrypt-1.2.2/cipher/arcfour.c | ||
34 | libgcrypt-1.2.2/cipher/blowfish.c | ||
35 | libgcrypt-1.2.2/cipher/cast5.c | ||
36 | libgcrypt-1.2.2/cipher/cipher.c | ||
37 | libgcrypt-1.2.2/cipher/crc.c | ||
38 | libgcrypt-1.2.2/cipher/des.c | ||
39 | libgcrypt-1.2.2/cipher/dsa.c | ||
40 | libgcrypt-1.2.2/cipher/elgamal.c | ||
41 | libgcrypt-1.2.2/cipher/md.c | ||
42 | libgcrypt-1.2.2/cipher/md4.c | ||
43 | libgcrypt-1.2.2/cipher/md5.c | ||
44 | libgcrypt-1.2.2/cipher/primegen.c | ||
45 | libgcrypt-1.2.2/cipher/pubkey.c | ||
46 | libgcrypt-1.2.2/cipher/random.c | ||
47 | libgcrypt-1.2.2/cipher/rfc2268.c | ||
48 | libgcrypt-1.2.2/cipher/rijndael.c | ||
49 | libgcrypt-1.2.2/cipher/rmd160.c | ||
50 | # libgcrypt-1.2.2/cipher/rndegd.c | ||
51 | # libgcrypt-1.2.2/cipher/rndlinux.c | ||
52 | # libgcrypt-1.2.2/cipher/rndunix.c | ||
53 | libgcrypt-1.2.2/cipher/rndw32.c | ||
54 | libgcrypt-1.2.2/cipher/rsa.c | ||
55 | libgcrypt-1.2.2/cipher/serpent.c | ||
56 | libgcrypt-1.2.2/cipher/sha1.c | ||
57 | libgcrypt-1.2.2/cipher/sha256.c | ||
58 | libgcrypt-1.2.2/cipher/sha512.c | ||
59 | libgcrypt-1.2.2/cipher/tiger.c | ||
60 | libgcrypt-1.2.2/cipher/twofish.c | ||
61 | |||
62 | libgcrypt-1.2.2/mpi/mpi-add.c | ||
63 | libgcrypt-1.2.2/mpi/mpi-bit.c | ||
64 | libgcrypt-1.2.2/mpi/mpi-cmp.c | ||
65 | libgcrypt-1.2.2/mpi/mpi-div.c | ||
66 | libgcrypt-1.2.2/mpi/mpi-gcd.c | ||
67 | libgcrypt-1.2.2/mpi/mpi-inline.c | ||
68 | libgcrypt-1.2.2/mpi/mpi-inv.c | ||
69 | libgcrypt-1.2.2/mpi/mpi-mpow.c | ||
70 | libgcrypt-1.2.2/mpi/mpi-mul.c | ||
71 | libgcrypt-1.2.2/mpi/mpi-pow.c | ||
72 | libgcrypt-1.2.2/mpi/mpi-scan.c | ||
73 | libgcrypt-1.2.2/mpi/mpicoder.c | ||
74 | libgcrypt-1.2.2/mpi/mpih-div.c | ||
75 | libgcrypt-1.2.2/mpi/mpih-mul.c | ||
76 | libgcrypt-1.2.2/mpi/mpiutil.c | ||
77 | |||
78 | libgcrypt-1.2.2/mpi/generic/mpih-add1.c | ||
79 | libgcrypt-1.2.2/mpi/generic/mpih-lshift.c | ||
80 | libgcrypt-1.2.2/mpi/generic/mpih-mul1.c | ||
81 | libgcrypt-1.2.2/mpi/generic/mpih-mul2.c | ||
82 | libgcrypt-1.2.2/mpi/generic/mpih-mul3.c | ||
83 | libgcrypt-1.2.2/mpi/generic/mpih-rshift.c | ||
84 | libgcrypt-1.2.2/mpi/generic/mpih-sub1.c | ||
85 | libgcrypt-1.2.2/mpi/generic/udiv-w-sdiv.c | ||
86 | ) | ||
87 | |||
88 | set(libgcrypt_HEADER_FILES | ||
89 | CMakeLists.txt | ||
90 | |||
91 | libgcrypt-1.2.2/src/ath.h | ||
92 | libgcrypt-1.2.2/src/cipher.h | ||
93 | libgcrypt-1.2.2/src/g10lib.h | ||
94 | libgcrypt-1.2.2/src/gcrypt-module.h | ||
95 | libgcrypt-1.2.2/src/gcrypt.h | ||
96 | libgcrypt-1.2.2/src/mpi.h | ||
97 | libgcrypt-1.2.2/src/secmem.h | ||
98 | libgcrypt-1.2.2/src/stdmem.h | ||
99 | libgcrypt-1.2.2/src/types.h | ||
100 | |||
101 | libgcrypt-1.2.2/cipher/bithelp.h | ||
102 | libgcrypt-1.2.2/cipher/random.h | ||
103 | libgcrypt-1.2.2/cipher/rand-internal.h | ||
104 | libgcrypt-1.2.2/cipher/rmd.h | ||
105 | |||
106 | libgcrypt-1.2.2/mpi/longlong.h | ||
107 | libgcrypt-1.2.2/mpi/mpi-inline.h | ||
108 | libgcrypt-1.2.2/mpi/mpi-internal.h | ||
109 | |||
110 | libgcrypt-1.2.2/mpi/generic/mpi-asm-defs.h | ||
111 | ) | ||
112 | |||
113 | set_source_files_properties(${libgcrypt_HEADER_FILES} | ||
114 | PROPERTIES HEADER_FILE_ONLY TRUE) | ||
115 | |||
116 | list(APPEND libgcrypt_SOURCE_FILES ${libgcrypt_HEADER_FILES}) | ||
117 | |||
118 | add_library (libgcrypt ${libgcrypt_SOURCE_FILES}) | ||
119 | target_link_libraries( | ||
120 | libgcrypt | ||
121 | ) | ||