diff options
author | Aleric Inglewood | 2010-09-28 03:19:43 +0200 |
---|---|---|
committer | McCabe Maxsted | 2010-10-01 23:28:28 -0700 |
commit | 27d5708ade21ff8ea2bb90d3b4866c269dce6369 (patch) | |
tree | 5678638eeb505d0247c2b886c4ee88906ec44694 /linden/indra/lib/python | |
parent | RED-562: SNOW-422: Imprudence doesn't compile with g++ 4.4.x (diff) | |
download | meta-impy-27d5708ade21ff8ea2bb90d3b4866c269dce6369.zip meta-impy-27d5708ade21ff8ea2bb90d3b4866c269dce6369.tar.gz meta-impy-27d5708ade21ff8ea2bb90d3b4866c269dce6369.tar.bz2 meta-impy-27d5708ade21ff8ea2bb90d3b4866c269dce6369.tar.xz |
RED-565: Building the package/ directory fails for standalone.
See http://redmine.imprudenceviewer.org/issues/565
This patch also reorders the "help" text of llmanifest.py to be
alphabetical, next to adding the option --standalone with help text.
indra/newview/CMakeLists.txt is changed to pass --standalone to
the python script. Finally, viewer_manifest.py, which inherits
from llmanifest.py uses it to skip the sections that don't make
sense when building standalone, and which fail with errors
without this patch.
This patch is not 100% tested: I don't have a Mac or windows.
However, it ONLY touches 'standalone', and before my patches
standalone was broken anyway. So, even if this doesn't fix it
completely for Mac and/or windows, then it can't hurt to commit,
or even release. Even if this fails, the errors are not fatal:
the packaging fails, but the viewer is already compiled at
this point. I'd advise against holding this back until it could
be tested by a Mac or windows developer that can build standalone:
that might never happen to begin with!
When time comes, some other developer will test it and when
there are still problems, fix it, on the other operating systems.
Diffstat (limited to 'linden/indra/lib/python')
-rw-r--r-- | linden/indra/lib/python/indra/util/llmanifest.py | 17 |
1 files changed, 10 insertions, 7 deletions
diff --git a/linden/indra/lib/python/indra/util/llmanifest.py b/linden/indra/lib/python/indra/util/llmanifest.py index 7a2505d..3444a15 100644 --- a/linden/indra/lib/python/indra/util/llmanifest.py +++ b/linden/indra/lib/python/indra/util/llmanifest.py | |||
@@ -119,7 +119,11 @@ ARGUMENTS=[ | |||
119 | Example use: %(name)s --arch=i686 | 119 | Example use: %(name)s --arch=i686 |
120 | On Linux this would try to use Linux_i686Manifest.""", | 120 | On Linux this would try to use Linux_i686Manifest.""", |
121 | default=""), | 121 | default=""), |
122 | dict(name='artwork', description='Artwork directory.', default=DEFAULT_SRCTREE), | ||
122 | dict(name='build', description='Build directory.', default=DEFAULT_SRCTREE), | 123 | dict(name='build', description='Build directory.', default=DEFAULT_SRCTREE), |
124 | dict(name='channel', | ||
125 | description="""The channel to use for updates, packaging, settings name, etc.""", | ||
126 | default=get_channel), | ||
123 | dict(name='configuration', | 127 | dict(name='configuration', |
124 | description="""The build configuration used. Only used on OS X for | 128 | description="""The build configuration used. Only used on OS X for |
125 | now, but it could be used for other platforms as well.""", | 129 | now, but it could be used for other platforms as well.""", |
@@ -130,16 +134,13 @@ ARGUMENTS=[ | |||
130 | though it's not strictly a grid, 'firstlook' is also an acceptable | 134 | though it's not strictly a grid, 'firstlook' is also an acceptable |
131 | value for this parameter.""", | 135 | value for this parameter.""", |
132 | default=""), | 136 | default=""), |
133 | dict(name='channel', | ||
134 | description="""The channel to use for updates, packaging, settings name, etc.""", | ||
135 | default=get_channel), | ||
136 | dict(name='login_channel', | ||
137 | description="""The channel to use for login handshake/updates only.""", | ||
138 | default=None), | ||
139 | dict(name='installer_name', | 137 | dict(name='installer_name', |
140 | description=""" The name of the file that the installer should be | 138 | description=""" The name of the file that the installer should be |
141 | packaged up into. Only used on Linux at the moment.""", | 139 | packaged up into. Only used on Linux at the moment.""", |
142 | default=None), | 140 | default=None), |
141 | dict(name='login_channel', | ||
142 | description="""The channel to use for login handshake/updates only.""", | ||
143 | default=None), | ||
143 | dict(name='login_url', | 144 | dict(name='login_url', |
144 | description="""The url that the login screen displays in the client.""", | 145 | description="""The url that the login screen displays in the client.""", |
145 | default=None), | 146 | default=None), |
@@ -150,7 +151,9 @@ ARGUMENTS=[ | |||
150 | dict(name='source', | 151 | dict(name='source', |
151 | description='Source directory.', | 152 | description='Source directory.', |
152 | default=DEFAULT_SRCTREE), | 153 | default=DEFAULT_SRCTREE), |
153 | dict(name='artwork', description='Artwork directory.', default=DEFAULT_SRCTREE), | 154 | dict(name='standalone', |
155 | description='Set to ON if this is a standalone build.', | ||
156 | default="OFF"), | ||
154 | dict(name='touch', | 157 | dict(name='touch', |
155 | description="""File to touch when action is finished. Touch file will | 158 | description="""File to touch when action is finished. Touch file will |
156 | contain the name of the final package in a form suitable | 159 | contain the name of the final package in a form suitable |