aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/gpg.vs/libgcrypt-1.2.2.vs/custom/config.h
diff options
context:
space:
mode:
authorJay Threeth2011-04-04 11:48:26 -0700
committerJay Threeth2011-04-04 11:48:26 -0700
commit3c9cc506f741b980565ff5b3b001cd8b6ee36b12 (patch)
treecb862c57b3d5f74177cde3bd962a53fc377166f6 /linden/indra/gpg.vs/libgcrypt-1.2.2.vs/custom/config.h
parentbuild fixes, might build on linux now (diff)
downloadmeta-impy-3c9cc506f741b980565ff5b3b001cd8b6ee36b12.zip
meta-impy-3c9cc506f741b980565ff5b3b001cd8b6ee36b12.tar.gz
meta-impy-3c9cc506f741b980565ff5b3b001cd8b6ee36b12.tar.bz2
meta-impy-3c9cc506f741b980565ff5b3b001cd8b6ee36b12.tar.xz
add source to libraries, and cruft for building under windows
Diffstat (limited to 'linden/indra/gpg.vs/libgcrypt-1.2.2.vs/custom/config.h')
-rwxr-xr-xlinden/indra/gpg.vs/libgcrypt-1.2.2.vs/custom/config.h322
1 files changed, 322 insertions, 0 deletions
diff --git a/linden/indra/gpg.vs/libgcrypt-1.2.2.vs/custom/config.h b/linden/indra/gpg.vs/libgcrypt-1.2.2.vs/custom/config.h
new file mode 100755
index 0000000..dcb6a95
--- /dev/null
+++ b/linden/indra/gpg.vs/libgcrypt-1.2.2.vs/custom/config.h
@@ -0,0 +1,322 @@
1/* config.h.in. Generated from configure.ac by autoheader. */
2
3
4/* need this, because some autoconf tests rely on this (e.g. stpcpy)
5 * and it should be used for new programs */
6#define _GNU_SOURCE 1
7
8
9/* Define if you don't want the default EGD socket name. For details see
10 cipher/rndegd.c */
11#undef EGD_SOCKET_NAME
12
13/* The default error source for libgcrypt. */
14#undef GPG_ERR_SOURCE_DEFAULT
15
16/* Define to 1 if you have the `atexit' function. */
17#define HAVE_ATEXIT 1
18
19/* Defined if the mlock() call does not work */
20#undef HAVE_BROKEN_MLOCK
21
22/* Defined if a `byte' is typedef'd */
23#undef HAVE_BYTE_TYPEDEF
24
25/* Define to 1 if you have the `clock_gettime' function. */
26#undef HAVE_CLOCK_GETTIME
27
28/* Define to 1 if you have the declaration of `sys_siglist', and to 0 if you
29 don't. */
30#define HAVE_DECL_SYS_SIGLIST 0
31
32/* defined if the system supports a random device */
33#undef HAVE_DEV_RANDOM
34
35/* Define to 1 if you have the <dlfcn.h> header file. */
36#undef HAVE_DLFCN_H
37
38/* Define to 1 if you don't have `vprintf' but do have `_doprnt.' */
39#undef HAVE_DOPRNT
40
41/* defined if we run on some of the PCDOS like systems (DOS, Windoze. OS/2)
42 with special properties like no file modes */
43#define HAVE_DOSISH_SYSTEM
44
45/* defined if we must run on a stupid file system */
46#define HAVE_DRIVE_LETTERS
47
48/* Define to 1 if you have the `gethrtime' function. */
49#undef HAVE_GETHRTIME
50
51/* Define to 1 if you have the `getpagesize' function. */
52#undef HAVE_GETPAGESIZE
53
54/* Define to 1 if you have the `getrusage' function. */
55#undef HAVE_GETRUSAGE
56
57/* Define to 1 if you have the `gettimeofday' function. */
58#undef HAVE_GETTIMEOFDAY
59
60/* Define to 1 if you have the <inttypes.h> header file. */
61#undef HAVE_INTTYPES_H
62
63/* Define to 1 if you have the `nsl' library (-lnsl). */
64#undef HAVE_LIBNSL
65
66/* Define to 1 if you have the `rt' library (-lrt). */
67#undef HAVE_LIBRT
68
69/* Define to 1 if you have the `memmove' function. */
70#define HAVE_MEMMOVE 1
71
72/* Define to 1 if you have the <memory.h> header file. */
73#define HAVE_MEMORY_H 1
74
75/* Defined if the system supports an mlock() call */
76#undef HAVE_MLOCK
77
78/* Define to 1 if you have the `mmap' function. */
79#undef HAVE_MMAP
80
81/* Define to 1 if you have the `raise' function. */
82#define HAVE_RAISE 1
83
84/* Define to 1 if you have the `rand' function. */
85#define HAVE_RAND 1
86
87/* Define to 1 if you have the <stdint.h> header file. */
88#undef HAVE_STDINT_H
89
90/* Define to 1 if you have the <stdlib.h> header file. */
91#define HAVE_STDLIB_H 1
92
93/* Define to 1 if you have the `stpcpy' function. */
94#undef HAVE_STPCPY
95
96/* Define to 1 if you have the `strcasecmp' function. */
97#undef HAVE_STRCASECMP
98
99/* Define to 1 if you have the `strerror' function. */
100#define HAVE_STRERROR 1
101
102/* Define to 1 if you have the `stricmp' function. */
103#define HAVE_STRICMP 1
104
105/* Define to 1 if you have the <strings.h> header file. */
106#undef HAVE_STRINGS_H
107
108/* Define to 1 if you have the <string.h> header file. */
109#define HAVE_STRING_H 1
110
111/* Define to 1 if you have the `strtoul' function. */
112#define HAVE_STRTOUL 1
113
114/* Define to 1 if you have the <sys/capability.h> header file. */
115#undef HAVE_SYS_CAPABILITY_H
116
117/* Define to 1 if you have the <sys/mman.h> header file. */
118#undef HAVE_SYS_MMAN_H
119
120/* Define to 1 if you have the <sys/select.h> header file. */
121#undef HAVE_SYS_SELECT_H
122
123/* Define to 1 if you have the <sys/stat.h> header file. */
124#undef HAVE_SYS_STAT_H
125
126/* Define to 1 if you have the <sys/types.h> header file. */
127#undef HAVE_SYS_TYPES_H
128
129/* Defined if a `u16' is typedef'd */
130#undef HAVE_U16_TYPEDEF
131
132/* Defined if a `u32' is typedef'd */
133#undef HAVE_U32_TYPEDEF
134
135/* Defined if a `ulong' is typedef'd */
136#undef HAVE_ULONG_TYPEDEF
137
138/* Define to 1 if you have the <unistd.h> header file. */
139#undef HAVE_UNISTD_H
140
141/* Defined if a `ushort' is typedef'd */
142#undef HAVE_USHORT_TYPEDEF
143
144/* Define to 1 if you have the `vprintf' function. */
145#define HAVE_VPRINTF 1
146
147/* Define to 1 if you have the `wait4' function. */
148#undef HAVE_WAIT4
149
150/* Define to 1 if you have the `waitpid' function. */
151#undef HAVE_WAITPID
152
153/* Defined if this is not a regular release */
154#undef IS_DEVELOPMENT_VERSION
155
156/* Define to use the (obsolete) malloc guarding feature */
157#undef M_GUARD
158
159/* defined to the name of the strong random device */
160#undef NAME_OF_DEV_RANDOM
161
162/* defined to the name of the weaker random device */
163#undef NAME_OF_DEV_URANDOM
164
165/* Name of this package */
166#define PACKAGE "libgcrypt-1.2.2.vs"
167
168/* Define to the address where bug reports for this package should be sent. */
169#define PACKAGE_BUGREPORT "s0rr0w@s0rr0w.net"
170
171/* Define to the full name of this package. */
172#define PACKAGE_NAME "libgcrypt-1.2.2 built with Visual Studio"
173
174/* Define to the full name and version of this package. */
175#undef PACKAGE_STRING
176
177/* Define to the one symbol short name of this package. */
178#undef PACKAGE_TARNAME
179
180/* Define to the version of this package. */
181#undef PACKAGE_VERSION
182
183/* A human readable text with the name of the OS */
184#define PRINTABLE_OS_NAME "Win32"
185
186/* Define as the return type of signal handlers (`int' or `void'). */
187#define RETSIGTYPE void
188
189/* The size of a `unsigned int', as computed by sizeof. */
190#define SIZEOF_UNSIGNED_INT 4
191
192/* The size of a `unsigned long', as computed by sizeof. */
193#define SIZEOF_UNSIGNED_LONG 4
194
195/* The size of a `unsigned long long', as computed by sizeof. */
196#undef SIZEOF_UNSIGNED_LONG_LONG
197
198/* The size of a `unsigned short', as computed by sizeof. */
199#define SIZEOF_UNSIGNED_SHORT 2
200
201/* Define to 1 if you have the ANSI C header files. */
202#define STDC_HEADERS 1
203
204/* Defined if this module should be included */
205#define USE_AES 1
206
207/* Defined if this module should be included */
208#define USE_ARCFOUR 1
209
210/* Defined if this module should be included */
211#define USE_BLOWFISH 1
212
213/* define if capabilities should be used */
214#undef USE_CAPABILITIES
215
216/* Defined if this module should be included */
217#define USE_CAST5 1
218
219/* Defined if this module should be included */
220#define USE_CRC 1
221
222/* Defined if this module should be included */
223#define USE_DES 1
224
225/* Defined if this module should be included */
226#define USE_DSA 1
227
228/* Defined if this module should be included */
229#define USE_ELGAMAL 1
230
231/* Defined if this module should be included */
232#define USE_MD4 1
233
234/* Defined if this module should be included */
235#define USE_MD5 1
236
237/* set this to limit filenames to the 8.3 format */
238#undef USE_ONLY_8DOT3
239
240/* Defined if this module should be included */
241#define USE_RFC2268 1
242
243/* Defined if this module should be included */
244#define USE_RMD160 1
245
246/* Defined if the EGD based RNG should be used. */
247#undef USE_RNDEGD
248
249/* Defined if the /dev/random based RNG should be used. */
250#undef USE_RNDLINUX
251
252/* Defined if the default Unix RNG should be used. */
253#undef USE_RNDUNIX
254
255/* Defined if the Windows specific RNG should be used. */
256#define USE_RNDW32 1
257
258/* Defined if this module should be included */
259#define USE_RSA 1
260
261/* Defined if this module should be included */
262#define USE_SERPENT 1
263
264/* Defined if this module should be included */
265#define USE_SHA1 1
266
267/* Defined if this module should be included */
268#define USE_SHA256 1
269
270/* Defined if this module should be included */
271#define USE_SHA512 1
272
273/* Defined if this module should be included */
274#undef USE_TIGER
275
276/* Defined if this module should be included */
277#define USE_TWOFISH 1
278
279/* Version of this package */
280#define VERSION "1.2.2"
281
282/* Defined if compiled symbols have a leading underscore */
283#define WITH_SYMBOL_UNDERSCORE 1
284
285/* Define to 1 if your processor stores words with the most significant byte
286 first (like Motorola and SPARC, unlike Intel and VAX). */
287#undef WORDS_BIGENDIAN
288
289/* To allow the use of Libgcrypt in multithreaded programs we have to use
290 special features from the library. */
291#ifndef _REENTRANT
292# define _REENTRANT 1
293#endif
294
295
296/* Define to empty if `const' does not conform to ANSI C. */
297#define const
298
299/* Define to `__inline__' or `__inline' if that's what the C compiler
300 calls it, or to nothing if 'inline' is not supported under any name. */
301#ifndef __cplusplus
302#undef inline
303#endif
304
305/* Define to `unsigned' if <sys/types.h> does not define. */
306// #undef size_t
307
308/* Define to `int' if unavailable. */
309#ifndef _SOCKLEN_T_DEFINED
310#ifndef socklen_t
311typedef int socklen_t;
312#define _SOCKLEN_T_DEFINED 1
313#endif
314#endif
315
316// !s0rr0w!
317#define SIZEOF_UINT64_T 8
318#define UINT64_C(C) (C)
319typedef unsigned __int64 uint64_t;
320
321#define _GCRYPT_IN_LIBGCRYPT 1
322