aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/linden/indra/cmake
diff options
context:
space:
mode:
authorDavid Walter Seikel2013-08-30 21:42:45 +1000
committerDavid Walter Seikel2013-08-30 21:42:45 +1000
commit56a1de48ee43bfacbd3ef2859f392082a26bc814 (patch)
tree03bd6092dab42985e536b84d2f311a3a12e4edb4 /linden/indra/cmake
parentAdded a licensing note about gpg.vs, as used to build OTR on Windows. (diff)
parentMerge remote-tracking branch 'origin/next' into WL-refactor (diff)
downloadmeta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.zip
meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.tar.gz
meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.tar.bz2
meta-impy-56a1de48ee43bfacbd3ef2859f392082a26bc814.tar.xz
Merge remote-tracking branch 'imprudence/next' into next
Unless otherwise stated, Imprudence changes accepted. The three images seem to be the same. Conflicts: .gitignore linden/indra/develop.py linden/indra/llcommon/llsdserialize_xml.cpp linden/indra/newview/CMakeLists.txt Manually combined MOAP, OTR, and WL changes from both. linden/indra/newview/app_settings/default_grids.xml Manually merged the grid collection. Also updated IG info. linden/indra/newview/hippoupdate.cpp linden/indra/newview/llettherebelight.cpp Just used the Imprudence copy. linden/indra/newview/llviewermessage.cpp Keep unbranding. linden/indra/newview/llvoavatar.cpp Manually merge client tags. linden/indra/newview/res/viewerRes.rc Manually merge version from Impy. linden/indra/newview/skins/dark/colors_base.xml Keep unbranding. linden/indra/newview/skins/default/html/unabletoconnect.png linden/indra/newview/skins/default/textures/icon_top_pick.tga linden/indra/newview/skins/default/xui/en-us/floater_about.xml Manual merging of contributors. linden/indra/newview/skins/gemini/colors_base.xml Keep unbranding. linden/indra/newview/skins/gemini/textures/icon_top_pick.tga linden/indra/newview/viewer_manifest.py Manually merged boost, gstreamer, OTR, and name. linden/indra/newview/viewerinfo.cpp Manually merge the comment.
Diffstat (limited to 'linden/indra/cmake')
-rw-r--r--linden/indra/cmake/00-Common.cmake5
-rw-r--r--linden/indra/cmake/CMakeLists.txt1
-rw-r--r--linden/indra/cmake/Variables.cmake11
-rw-r--r--linden/indra/cmake/ViewerArtwork.cmake16
4 files changed, 15 insertions, 18 deletions
diff --git a/linden/indra/cmake/00-Common.cmake b/linden/indra/cmake/00-Common.cmake
index 1177fc2..06368c0 100644
--- a/linden/indra/cmake/00-Common.cmake
+++ b/linden/indra/cmake/00-Common.cmake
@@ -24,6 +24,11 @@ list(REMOVE_DUPLICATES TYPES)
24set(CMAKE_CONFIGURATION_TYPES ${TYPES} CACHE STRING "Supported build types." FORCE) 24set(CMAKE_CONFIGURATION_TYPES ${TYPES} CACHE STRING "Supported build types." FORCE)
25unset(TYPES) 25unset(TYPES)
26 26
27# Work around nmake / VS difference.
28set(VIEWER_CFG_INTDIR ${CMAKE_CFG_INTDIR})
29if (NMAKE)
30 set(VIEWER_CFG_INTDIR ${CMAKE_BUILD_TYPE})
31endif(NMAKE)
27 32
28# Determine the number of bits of this processor 33# Determine the number of bits of this processor
29 34
diff --git a/linden/indra/cmake/CMakeLists.txt b/linden/indra/cmake/CMakeLists.txt
index 4a7d633..aca7b5a 100644
--- a/linden/indra/cmake/CMakeLists.txt
+++ b/linden/indra/cmake/CMakeLists.txt
@@ -93,7 +93,6 @@ set(cmake_SOURCE_FILES
93 UI.cmake 93 UI.cmake
94 UnixInstall.cmake 94 UnixInstall.cmake
95 Variables.cmake 95 Variables.cmake
96 ViewerArtwork.cmake
97 ViewerMiscLibs.cmake 96 ViewerMiscLibs.cmake
98 WebKitLibPlugin.cmake 97 WebKitLibPlugin.cmake
99 XmlRpcEpi.cmake 98 XmlRpcEpi.cmake
diff --git a/linden/indra/cmake/Variables.cmake b/linden/indra/cmake/Variables.cmake
index 88c0c5c..dfb0e70 100644
--- a/linden/indra/cmake/Variables.cmake
+++ b/linden/indra/cmake/Variables.cmake
@@ -81,10 +81,19 @@ endif (${CMAKE_SYSTEM_NAME} MATCHES "Linux")
81 81
82if (${CMAKE_SYSTEM_NAME} MATCHES "Darwin") 82if (${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
83 set(DARWIN 1) 83 set(DARWIN 1)
84
85 # Incorporated settings from
86 # http://imprudenceviewer.org/w/index.php?title=How_to_compile&oldid=1647#Mac
87 # so that people don't have to set them every time they run develop.py
88 set(CMAKE_XCODE_ATTRIBUTE_GCC_VERSION "4.0")
89 set(CMAKE_XCODE_ATTRIBUTE_ARCHS '$(ARCHS_STANDARD_32_BIT)')
90 set(CMAKE_XCODE_ATTRIBUTE_VALID_ARCHS "i386 ppc")
91 # set(CMAKE_XCODE_ATTRIBUTE_ONLY_ACTIVE_ARCH "NO")
92
84 # set this dynamically from the build system now - 93 # set this dynamically from the build system now -
85 # NOTE: wont have a distributable build unless you add this on the configure line with: 94 # NOTE: wont have a distributable build unless you add this on the configure line with:
86 # -DCMAKE_OSX_ARCHITECTURES:STRING='i386;ppc' 95 # -DCMAKE_OSX_ARCHITECTURES:STRING='i386;ppc'
87 set(CMAKE_OSX_ARCHITECTURES i386) 96 set(CMAKE_OSX_ARCHITECTURES i386;ppc)
88 set(CMAKE_OSX_SYSROOT /Developer/SDKs/MacOSX10.5.sdk) 97 set(CMAKE_OSX_SYSROOT /Developer/SDKs/MacOSX10.5.sdk)
89 if (CMAKE_OSX_ARCHITECTURES MATCHES "i386") 98 if (CMAKE_OSX_ARCHITECTURES MATCHES "i386")
90 set(ARCH i386) 99 set(ARCH i386)
diff --git a/linden/indra/cmake/ViewerArtwork.cmake b/linden/indra/cmake/ViewerArtwork.cmake
deleted file mode 100644
index 20210fc..0000000
--- a/linden/indra/cmake/ViewerArtwork.cmake
+++ /dev/null
@@ -1,16 +0,0 @@
1# -*- cmake -*-
2#
3# Download viewer artwork even when using standalone
4
5include(Variables)
6include(Prebuilt)
7
8if (NOT STANDALONE)
9 use_prebuilt_binary(artwork)
10 use_prebuilt_binary(fonts)
11else (NOT STANDALONE)
12 set(STANDALONE OFF)
13 use_prebuilt_binary(artwork)
14 use_prebuilt_binary(fonts)
15 set(STANDALONE ON)
16endif (NOT STANDALONE)