aboutsummaryrefslogtreecommitdiffstatshomepage
diff options
context:
space:
mode:
authorJacek Antonelli2008-11-04 19:51:51 -0600
committerJacek Antonelli2008-11-04 19:51:51 -0600
commitb391062545651f5ac87c39fc275d6a16944c2ee1 (patch)
tree5844888eadf51043ab575f0d45e022da7a225e55
parentScript finds Imprudence version numbers for packaging. (diff)
downloadmeta-impy-b391062545651f5ac87c39fc275d6a16944c2ee1.zip
meta-impy-b391062545651f5ac87c39fc275d6a16944c2ee1.tar.gz
meta-impy-b391062545651f5ac87c39fc275d6a16944c2ee1.tar.bz2
meta-impy-b391062545651f5ac87c39fc275d6a16944c2ee1.tar.xz
Fix Mac crash logger & updater missing Info.plist.
Suggested by Aimee Trescothick (Aimee Walton).
-rw-r--r--ChangeLog.txt9
-rw-r--r--linden/indra/mac_crash_logger/CMakeLists.txt2
-rw-r--r--linden/indra/mac_updater/CMakeLists.txt2
3 files changed, 11 insertions, 2 deletions
diff --git a/ChangeLog.txt b/ChangeLog.txt
index ad4e55d..3ccca7a 100644
--- a/ChangeLog.txt
+++ b/ChangeLog.txt
@@ -1,3 +1,12 @@
12008-11-04 Jacek Antonelli <jacek.antonelli@gmail.com>
2
3 * linden/indra/mac_crash_logger/CMakeLists.txt:
4 Fix Mac crash logger & updater missing Info.plist.
5 Suggested by Aimee Trescothick (Aimee Walton).
6 * linden/indra/mac_updater/CMakeLists.txt:
7 Ditto.
8
9
12008-11-02 Jacek Antonelli <jacek.antonelli@gmail.com> 102008-11-02 Jacek Antonelli <jacek.antonelli@gmail.com>
2 11
3 * linden/scripts/build_version.py: 12 * linden/scripts/build_version.py:
diff --git a/linden/indra/mac_crash_logger/CMakeLists.txt b/linden/indra/mac_crash_logger/CMakeLists.txt
index 9cddb56..371b6fb 100644
--- a/linden/indra/mac_crash_logger/CMakeLists.txt
+++ b/linden/indra/mac_crash_logger/CMakeLists.txt
@@ -47,7 +47,7 @@ set_source_files_properties(
47set_source_files_properties( 47set_source_files_properties(
48 Info.plist 48 Info.plist
49 PROPERTIES 49 PROPERTIES
50 MACOSX_PACKAGE_LOCATION . # will it blend? + poppy 50 MACOSX_BUNDLE_INFO_PLIST ${CMAKE_CURRENT_SOURCE_DIR}/Info.plist
51 ) 51 )
52SOURCE_GROUP("Resources" FILES ${mac_crash_logger_RESOURCE_FILES}) 52SOURCE_GROUP("Resources" FILES ${mac_crash_logger_RESOURCE_FILES})
53list(APPEND mac_crash_logger_SOURCE_FILES ${mac_crash_logger_RESOURCE_FILES}) 53list(APPEND mac_crash_logger_SOURCE_FILES ${mac_crash_logger_RESOURCE_FILES})
diff --git a/linden/indra/mac_updater/CMakeLists.txt b/linden/indra/mac_updater/CMakeLists.txt
index 3ac5aee..ef87b29 100644
--- a/linden/indra/mac_updater/CMakeLists.txt
+++ b/linden/indra/mac_updater/CMakeLists.txt
@@ -53,7 +53,7 @@ set_source_files_properties(
53set_source_files_properties( 53set_source_files_properties(
54 Info.plist 54 Info.plist
55 PROPERTIES 55 PROPERTIES
56 MACOSX_PACKAGE_LOCATION . # will it blend? + poppy 56 MACOSX_BUNDLE_INFO_PLIST ${CMAKE_CURRENT_SOURCE_DIR}/Info.plist
57 ) 57 )
58SOURCE_GROUP("Resources" FILES ${mac_updater_RESOURCE_FILES}) 58SOURCE_GROUP("Resources" FILES ${mac_updater_RESOURCE_FILES})
59list(APPEND mac_updater_SOURCE_FILES ${mac_updater_RESOURCE_FILES}) 59list(APPEND mac_updater_SOURCE_FILES ${mac_updater_RESOURCE_FILES})