diff options
author | McCabe Maxsted | 2010-10-27 02:17:31 -0700 |
---|---|---|
committer | McCabe Maxsted | 2010-10-27 02:17:31 -0700 |
commit | 74749fc1ed3b6f6eda57739712c3e01ba126c7b6 (patch) | |
tree | 54dfeb70feded0be7a1e63a16a87df84673179a6 | |
parent | Merge remote branch 'origin/webkit_plugins' into webkit_plugins (diff) | |
download | meta-impy-74749fc1ed3b6f6eda57739712c3e01ba126c7b6.zip meta-impy-74749fc1ed3b6f6eda57739712c3e01ba126c7b6.tar.gz meta-impy-74749fc1ed3b6f6eda57739712c3e01ba126c7b6.tar.bz2 meta-impy-74749fc1ed3b6f6eda57739712c3e01ba126c7b6.tar.xz |
Fixed mime_types.xml not being copied on Windows (also fixes plugin dll copying error)
-rw-r--r-- | linden/indra/newview/CMakeLists.txt | 39 |
1 files changed, 26 insertions, 13 deletions
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt index e113d05..bec20d9 100644 --- a/linden/indra/newview/CMakeLists.txt +++ b/linden/indra/newview/CMakeLists.txt | |||
@@ -1525,6 +1525,7 @@ ADD_VIEWER_BUILD_TEST(llagentaccess viewer) | |||
1525 | 1525 | ||
1526 | # Don't do these for DARWIN or LINUX here -- they're taken care of by viewer_manifest.py | 1526 | # Don't do these for DARWIN or LINUX here -- they're taken care of by viewer_manifest.py |
1527 | if (WINDOWS) | 1527 | if (WINDOWS) |
1528 | |||
1528 | get_target_property(BUILT_SLPLUGIN SLPlugin LOCATION) | 1529 | get_target_property(BUILT_SLPLUGIN SLPlugin LOCATION) |
1529 | add_custom_command( | 1530 | add_custom_command( |
1530 | TARGET ${VIEWER_BINARY_NAME} POST_BUILD | 1531 | TARGET ${VIEWER_BINARY_NAME} POST_BUILD |
@@ -1549,17 +1550,17 @@ if (WINDOWS) | |||
1549 | COMMENT "Copying WebKit Plugin to the runtime folder." | 1550 | COMMENT "Copying WebKit Plugin to the runtime folder." |
1550 | ) | 1551 | ) |
1551 | 1552 | ||
1552 | get_target_property(BUILT_GSTREAMER_PLUGIN media_plugin_gstreamer010 LOCATION) | 1553 | #get_target_property(BUILT_GSTREAMER_PLUGIN media_plugin_gstreamer010 LOCATION) |
1553 | add_custom_command( | 1554 | # add_custom_command( |
1554 | TARGET ${VIEWER_BINARY_NAME} POST_BUILD | 1555 | # TARGET ${VIEWER_BINARY_NAME} POST_BUILD |
1555 | COMMAND ${CMAKE_COMMAND} | 1556 | # COMMAND ${CMAKE_COMMAND} |
1556 | ARGS | 1557 | # ARGS |
1557 | -E | 1558 | # -E |
1558 | copy_if_different | 1559 | # copy_if_different |
1559 | ${BUILT_GSTREAMER_PLUGIN} | 1560 | # ${BUILT_GSTREAMER_PLUGIN} |
1560 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin | 1561 | # ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin |
1561 | COMMENT "Copying Gstreamer Plugin to the runtime folder." | 1562 | # COMMENT "Copying Gstreamer Plugin to the runtime folder." |
1562 | ) | 1563 | # ) |
1563 | 1564 | ||
1564 | get_target_property(BUILT_QUICKTIME_PLUGIN media_plugin_quicktime LOCATION) | 1565 | get_target_property(BUILT_QUICKTIME_PLUGIN media_plugin_quicktime LOCATION) |
1565 | add_custom_command( | 1566 | add_custom_command( |
@@ -1573,8 +1574,20 @@ if (WINDOWS) | |||
1573 | COMMENT "Copying Quicktime Plugin to the runtime folder." | 1574 | COMMENT "Copying Quicktime Plugin to the runtime folder." |
1574 | ) | 1575 | ) |
1575 | 1576 | ||
1576 | 1577 | # Copying the mime_types.xml file to app_settings | |
1577 | 1578 | set(mime_types_source "${CMAKE_SOURCE_DIR}/newview/skins/default/xui/en-us") | |
1579 | set(mime_types_dest "${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/app_settings") | ||
1580 | add_custom_command( | ||
1581 | TARGET ${VIEWER_BINARY_NAME} POST_BUILD | ||
1582 | COMMAND ${CMAKE_COMMAND} | ||
1583 | ARGS | ||
1584 | -E | ||
1585 | copy_if_different | ||
1586 | ${mime_types_source}/mime_types_windows.xml | ||
1587 | ${mime_types_dest}/mime_types.xml | ||
1588 | COMMENT "Copying mime_types_windows.xml to mime_types.xml." | ||
1589 | ) | ||
1590 | |||
1578 | endif (WINDOWS) | 1591 | endif (WINDOWS) |
1579 | 1592 | ||
1580 | if (DARWIN) | 1593 | if (DARWIN) |