diff options
author | McCabe Maxsted | 2011-09-08 21:03:06 -0700 |
---|---|---|
committer | McCabe Maxsted | 2011-09-08 21:03:06 -0700 |
commit | 701e76557ae6a6cd7f4b18ee275ee122b91495a8 (patch) | |
tree | 79d7a5e5b7482dec52f71e2b70f07ff436574da3 | |
parent | Revert "Reverted ability to customize the Imprudence client tag color." (diff) | |
download | meta-impy-701e76557ae6a6cd7f4b18ee275ee122b91495a8.zip meta-impy-701e76557ae6a6cd7f4b18ee275ee122b91495a8.tar.gz meta-impy-701e76557ae6a6cd7f4b18ee275ee122b91495a8.tar.bz2 meta-impy-701e76557ae6a6cd7f4b18ee275ee122b91495a8.tar.xz |
Don't run vstool.exe when using an express version of vc++, by CobraElDiablo from the Astra Viewer
-rwxr-xr-x | linden/indra/develop.py | 6 | ||||
-rw-r--r-- | linden/indra/newview/CMakeLists.txt | 24 |
2 files changed, 18 insertions, 12 deletions
diff --git a/linden/indra/develop.py b/linden/indra/develop.py index 6d2ce72..8b23b1d 100755 --- a/linden/indra/develop.py +++ b/linden/indra/develop.py | |||
@@ -80,6 +80,7 @@ class PlatformSetup(object): | |||
80 | project_name = 'Imprudence' | 80 | project_name = 'Imprudence' |
81 | distcc = True | 81 | distcc = True |
82 | cmake_opts = [] | 82 | cmake_opts = [] |
83 | using_express = False | ||
83 | 84 | ||
84 | def __init__(self): | 85 | def __init__(self): |
85 | self.script_dir = os.path.realpath( | 86 | self.script_dir = os.path.realpath( |
@@ -494,6 +495,7 @@ class WindowsSetup(PlatformSetup): | |||
494 | for version in 'vc80 vc90 vc100 vc71'.split(): | 495 | for version in 'vc80 vc90 vc100 vc71'.split(): |
495 | if self.find_visual_studio_express(version): | 496 | if self.find_visual_studio_express(version): |
496 | self._generator = version | 497 | self._generator = version |
498 | self.using_express = True | ||
497 | print 'Building with ', self.gens[version]['gen'] , "Express edition" | 499 | print 'Building with ', self.gens[version]['gen'] , "Express edition" |
498 | break | 500 | break |
499 | else: | 501 | else: |
@@ -570,6 +572,7 @@ class WindowsSetup(PlatformSetup): | |||
570 | key = _winreg.OpenKey(reg, key_str) | 572 | key = _winreg.OpenKey(reg, key_str) |
571 | value = _winreg.QueryValueEx(key, value_str)[0]+"IDE" | 573 | value = _winreg.QueryValueEx(key, value_str)[0]+"IDE" |
572 | print 'Found: %s' % value | 574 | print 'Found: %s' % value |
575 | self.using_express = True | ||
573 | return value | 576 | return value |
574 | except WindowsError, err: | 577 | except WindowsError, err: |
575 | print >> sys.stderr, "Didn't find ", self.gens[gen]['gen'] | 578 | print >> sys.stderr, "Didn't find ", self.gens[gen]['gen'] |
@@ -618,7 +621,8 @@ class WindowsSetup(PlatformSetup): | |||
618 | '''Override to add the vstool.exe call after running cmake.''' | 621 | '''Override to add the vstool.exe call after running cmake.''' |
619 | PlatformSetup.run_cmake(self, args) | 622 | PlatformSetup.run_cmake(self, args) |
620 | if self.unattended == 'OFF': | 623 | if self.unattended == 'OFF': |
621 | self.run_vstool() | 624 | if self.using_express == False: |
625 | self.run_vstool() | ||
622 | 626 | ||
623 | def run_vstool(self): | 627 | def run_vstool(self): |
624 | for build_dir in self.build_dirs(): | 628 | for build_dir in self.build_dirs(): |
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt index 1b9f75a..54c1998 100644 --- a/linden/indra/newview/CMakeLists.txt +++ b/linden/indra/newview/CMakeLists.txt | |||
@@ -1323,17 +1323,19 @@ if (WINDOWS) | |||
1323 | 1323 | ||
1324 | # sets the 'working directory' for debugging from visual studio. | 1324 | # sets the 'working directory' for debugging from visual studio. |
1325 | if (NOT UNATTENDED) | 1325 | if (NOT UNATTENDED) |
1326 | add_custom_command( | 1326 | if (NOT self.using_express) |
1327 | TARGET ${VIEWER_BINARY_NAME} PRE_BUILD | 1327 | add_custom_command( |
1328 | COMMAND ${CMAKE_SOURCE_DIR}/tools/vstool/vstool.exe | 1328 | TARGET ${VIEWER_BINARY_NAME} PRE_BUILD |
1329 | ARGS | 1329 | COMMAND ${CMAKE_SOURCE_DIR}/tools/vstool/vstool.exe |
1330 | --solution | 1330 | ARGS |
1331 | ${CMAKE_BINARY_DIR}/${CMAKE_PROJECT_NAME}.sln | 1331 | --solution |
1332 | --workingdir | 1332 | ${CMAKE_BINARY_DIR}/${CMAKE_PROJECT_NAME}.sln |
1333 | ${VIEWER_BINARY_NAME} | 1333 | --workingdir |
1334 | ${CMAKE_CURRENT_SOURCE_DIR} | 1334 | ${VIEWER_BINARY_NAME} |
1335 | COMMENT "Setting the ${VIEWER_BINARY_NAME} working directory for debugging." | 1335 | ${CMAKE_CURRENT_SOURCE_DIR} |
1336 | ) | 1336 | COMMENT "Setting the ${VIEWER_BINARY_NAME} working directory for debugging." |
1337 | ) | ||
1338 | endif (NOT self.using_express) | ||
1337 | endif (NOT UNATTENDED) | 1339 | endif (NOT UNATTENDED) |
1338 | 1340 | ||
1339 | add_custom_command( | 1341 | add_custom_command( |