diff options
author | Jacek Antonelli | 2009-02-27 23:58:57 -0600 |
---|---|---|
committer | Jacek Antonelli | 2009-02-27 23:58:57 -0600 |
commit | 5a0e76234c4a910cfdc3cba19109de5d94435360 (patch) | |
tree | 30dd86c88e18a54a6bc88ffe8b3ff0e5715629d2 | |
parent | LLUI's CMakeList needs LLMedia cmake stuff. (diff) | |
download | meta-impy-5a0e76234c4a910cfdc3cba19109de5d94435360.zip meta-impy-5a0e76234c4a910cfdc3cba19109de5d94435360.tar.gz meta-impy-5a0e76234c4a910cfdc3cba19109de5d94435360.tar.bz2 meta-impy-5a0e76234c4a910cfdc3cba19109de5d94435360.tar.xz |
Get gstreamer reference from media manager.
Eliminates the need to include llmediaimplgstreamer.h,
which causes problems on Linux due to name clash between
libxml2 and expat's XMLCALLs.
-rw-r--r-- | ChangeLog.txt | 6 | ||||
-rw-r--r-- | linden/indra/newview/llfloaterabout.cpp | 4 |
2 files changed, 7 insertions, 3 deletions
diff --git a/ChangeLog.txt b/ChangeLog.txt index 187fb9d..2b3727a 100644 --- a/ChangeLog.txt +++ b/ChangeLog.txt | |||
@@ -1,5 +1,11 @@ | |||
1 | 2009-02-27 Jacek Antonelli <jacek.antonelli@gmail.com> | 1 | 2009-02-27 Jacek Antonelli <jacek.antonelli@gmail.com> |
2 | 2 | ||
3 | * linden/indra/newview/llfloaterabout.cpp: | ||
4 | Get gstreamer reference from media manager. | ||
5 | Eliminates the need to include llmediaimplgstreamer.h, | ||
6 | which causes problems on Linux due to name clash between | ||
7 | libxml2 and expat's XMLCALLs. | ||
8 | |||
3 | * linden/indra/llui/CMakeLists.txt: | 9 | * linden/indra/llui/CMakeLists.txt: |
4 | LLUI's CMakeList needs LLMedia cmake stuff. | 10 | LLUI's CMakeList needs LLMedia cmake stuff. |
5 | 11 | ||
diff --git a/linden/indra/newview/llfloaterabout.cpp b/linden/indra/newview/llfloaterabout.cpp index aeca4b5..be1c254 100644 --- a/linden/indra/newview/llfloaterabout.cpp +++ b/linden/indra/newview/llfloaterabout.cpp | |||
@@ -42,7 +42,6 @@ | |||
42 | #include "llcurl.h" | 42 | #include "llcurl.h" |
43 | #include "llimagej2c.h" | 43 | #include "llimagej2c.h" |
44 | #include "audioengine.h" | 44 | #include "audioengine.h" |
45 | #include "llmediaimplgstreamer.h" | ||
46 | 45 | ||
47 | #include "llviewertexteditor.h" | 46 | #include "llviewertexteditor.h" |
48 | #include "llviewercontrol.h" | 47 | #include "llviewercontrol.h" |
@@ -209,14 +208,13 @@ LLFloaterAbout::LLFloaterAbout() | |||
209 | LLMediaManager *mgr = LLMediaManager::getInstance(); | 208 | LLMediaManager *mgr = LLMediaManager::getInstance(); |
210 | if (mgr) | 209 | if (mgr) |
211 | { | 210 | { |
212 | LLMediaBase *gstreamer = new LLMediaImplGStreamer(); | 211 | LLMediaBase *gstreamer = mgr->createSourceFromMimeType("http", "audio/mpeg"); |
213 | if (gstreamer) | 212 | if (gstreamer) |
214 | { | 213 | { |
215 | support.append("GStreamer Version: "); | 214 | support.append("GStreamer Version: "); |
216 | support.append( gstreamer->getVersion() ); | 215 | support.append( gstreamer->getVersion() ); |
217 | support.append("\n"); | 216 | support.append("\n"); |
218 | } | 217 | } |
219 | delete gstreamer; | ||
220 | 218 | ||
221 | LLMediaBase *media_source = mgr->createSourceFromMimeType("http", "text/html"); | 219 | LLMediaBase *media_source = mgr->createSourceFromMimeType("http", "text/html"); |
222 | if (media_source) | 220 | if (media_source) |