diff options
author | David Walter Seikel | 2013-04-26 13:09:45 +1000 |
---|---|---|
committer | David Walter Seikel | 2013-04-26 13:09:45 +1000 |
commit | 044d7575eab98ff26ed7d48a461b613db52bed04 (patch) | |
tree | fb01182736d1e1ac8d7063613845b3d17a0917c5 | |
parent | Small clean ups. (diff) | |
download | meta-impy-044d7575eab98ff26ed7d48a461b613db52bed04.zip meta-impy-044d7575eab98ff26ed7d48a461b613db52bed04.tar.gz meta-impy-044d7575eab98ff26ed7d48a461b613db52bed04.tar.bz2 meta-impy-044d7575eab98ff26ed7d48a461b613db52bed04.tar.xz |
Make nmake builds more like VS builds.
Still some tweaking to go, therefore, still some rough bits in this.
-rw-r--r-- | linden/indra/cmake/00-Common.cmake | 5 | ||||
-rwxr-xr-x | linden/indra/develop.py | 5 | ||||
-rwxr-xr-x | linden/indra/llplugin/slplugin/CMakeLists.txt | 2 | ||||
-rw-r--r-- | linden/indra/mac_crash_logger/CMakeLists.txt | 2 | ||||
-rw-r--r-- | linden/indra/mac_updater/CMakeLists.txt | 2 | ||||
-rw-r--r-- | linden/indra/media_plugins/webkit/CMakeLists.txt | 4 | ||||
-rw-r--r-- | linden/indra/newview/CMakeLists.txt | 42 | ||||
-rw-r--r-- | linden/indra/newview/installers/windows/imprudence_installer_template.iss | 14 | ||||
-rwxr-xr-x | linden/indra/newview/viewer_manifest.py | 51 | ||||
-rw-r--r-- | linden/indra/test_apps/llplugintest/CMakeLists.txt | 4 | ||||
-rwxr-xr-x | linden/scripts/linux/4-package-viewer | 2 |
11 files changed, 73 insertions, 60 deletions
diff --git a/linden/indra/cmake/00-Common.cmake b/linden/indra/cmake/00-Common.cmake index 81bfbdf..ea21ba0 100644 --- a/linden/indra/cmake/00-Common.cmake +++ b/linden/indra/cmake/00-Common.cmake | |||
@@ -24,6 +24,11 @@ list(REMOVE_DUPLICATES TYPES) | |||
24 | set(CMAKE_CONFIGURATION_TYPES ${TYPES} CACHE STRING "Supported build types." FORCE) | 24 | set(CMAKE_CONFIGURATION_TYPES ${TYPES} CACHE STRING "Supported build types." FORCE) |
25 | unset(TYPES) | 25 | unset(TYPES) |
26 | 26 | ||
27 | # Work around nmake / VS difference. | ||
28 | set(VIEWER_CFG_INTDIR ${CMAKE_CFG_INTDIR}) | ||
29 | if (NMAKE) | ||
30 | set(VIEWER_CFG_INTDIR ${CMAKE_BUILD_TYPE}) | ||
31 | endif(NMAKE) | ||
27 | 32 | ||
28 | # Determine the number of bits of this processor | 33 | # Determine the number of bits of this processor |
29 | 34 | ||
diff --git a/linden/indra/develop.py b/linden/indra/develop.py index eb071bd..76ba0d9 100755 --- a/linden/indra/develop.py +++ b/linden/indra/develop.py | |||
@@ -580,10 +580,12 @@ class WindowsSetup(PlatformSetup): | |||
580 | unattended=self.unattended, | 580 | unattended=self.unattended, |
581 | project_name=self.project_name, | 581 | project_name=self.project_name, |
582 | type=self.build_type, | 582 | type=self.build_type, |
583 | use_vstool='ON' | 583 | use_vstool='ON', |
584 | nmake='' | ||
584 | ) | 585 | ) |
585 | if self.generator == 'nmake': | 586 | if self.generator == 'nmake': |
586 | args['use_vstool'] = 'OFF' | 587 | args['use_vstool'] = 'OFF' |
588 | args['nmake'] = '-DNMAKE:BOOL=ON' | ||
587 | if self.using_express: | 589 | if self.using_express: |
588 | args['using_express'] = 'ON' | 590 | args['using_express'] = 'ON' |
589 | args['use_vstool'] = 'OFF' | 591 | args['use_vstool'] = 'OFF' |
@@ -599,6 +601,7 @@ class WindowsSetup(PlatformSetup): | |||
599 | '-DROOT_PROJECT_NAME:STRING=%(project_name)s ' | 601 | '-DROOT_PROJECT_NAME:STRING=%(project_name)s ' |
600 | '-DUSING_EXPRESS:BOOL=%(using_express)s ' | 602 | '-DUSING_EXPRESS:BOOL=%(using_express)s ' |
601 | '-DUSE_VSTOOL:BOOL=%(use_vstool)s ' | 603 | '-DUSE_VSTOOL:BOOL=%(use_vstool)s ' |
604 | '%(nmake)s ' | ||
602 | '%(opts)s "%(dir)s"' % args) | 605 | '%(opts)s "%(dir)s"' % args) |
603 | 606 | ||
604 | def get_build_cmd(self): | 607 | def get_build_cmd(self): |
diff --git a/linden/indra/llplugin/slplugin/CMakeLists.txt b/linden/indra/llplugin/slplugin/CMakeLists.txt index 81d9299..f794dae 100755 --- a/linden/indra/llplugin/slplugin/CMakeLists.txt +++ b/linden/indra/llplugin/slplugin/CMakeLists.txt | |||
@@ -75,7 +75,7 @@ if (DARWIN) | |||
75 | COMMAND mkdir | 75 | COMMAND mkdir |
76 | ARGS | 76 | ARGS |
77 | -p | 77 | -p |
78 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/SLPlugin.app/Contents/Resources | 78 | ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/SLPlugin.app/Contents/Resources |
79 | ) | 79 | ) |
80 | endif (DARWIN) | 80 | endif (DARWIN) |
81 | 81 | ||
diff --git a/linden/indra/mac_crash_logger/CMakeLists.txt b/linden/indra/mac_crash_logger/CMakeLists.txt index daf3e10..ee1dc93 100644 --- a/linden/indra/mac_crash_logger/CMakeLists.txt +++ b/linden/indra/mac_crash_logger/CMakeLists.txt | |||
@@ -71,6 +71,6 @@ add_custom_command( | |||
71 | -E | 71 | -E |
72 | copy_directory | 72 | copy_directory |
73 | ${CMAKE_CURRENT_SOURCE_DIR}/CrashReporter.nib | 73 | ${CMAKE_CURRENT_SOURCE_DIR}/CrashReporter.nib |
74 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/mac-crash-logger.app/Contents/Resources/CrashReporter.nib | 74 | ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/mac-crash-logger.app/Contents/Resources/CrashReporter.nib |
75 | ) | 75 | ) |
76 | 76 | ||
diff --git a/linden/indra/mac_updater/CMakeLists.txt b/linden/indra/mac_updater/CMakeLists.txt index 0eac76f..5ae7dd8 100644 --- a/linden/indra/mac_updater/CMakeLists.txt +++ b/linden/indra/mac_updater/CMakeLists.txt | |||
@@ -74,6 +74,6 @@ add_custom_command( | |||
74 | -E | 74 | -E |
75 | copy_directory | 75 | copy_directory |
76 | ${CMAKE_CURRENT_SOURCE_DIR}/AutoUpdater.nib | 76 | ${CMAKE_CURRENT_SOURCE_DIR}/AutoUpdater.nib |
77 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/mac-updater.app/Contents/Resources/AutoUpdater.nib | 77 | ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/mac-updater.app/Contents/Resources/AutoUpdater.nib |
78 | ) | 78 | ) |
79 | 79 | ||
diff --git a/linden/indra/media_plugins/webkit/CMakeLists.txt b/linden/indra/media_plugins/webkit/CMakeLists.txt index 303a774..f589c61 100644 --- a/linden/indra/media_plugins/webkit/CMakeLists.txt +++ b/linden/indra/media_plugins/webkit/CMakeLists.txt | |||
@@ -112,8 +112,8 @@ if (DARWIN) | |||
112 | # copy the webkit dylib to the build directory | 112 | # copy the webkit dylib to the build directory |
113 | add_custom_command( | 113 | add_custom_command( |
114 | TARGET media_plugin_webkit POST_BUILD | 114 | TARGET media_plugin_webkit POST_BUILD |
115 | # OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/libllqtwebkit.dylib | 115 | # OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/libllqtwebkit.dylib |
116 | COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/ | 116 | COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/ |
117 | DEPENDS media_plugin_webkit ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib | 117 | DEPENDS media_plugin_webkit ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib |
118 | ) | 118 | ) |
119 | 119 | ||
diff --git a/linden/indra/newview/CMakeLists.txt b/linden/indra/newview/CMakeLists.txt index 9172aa0..907fa5c 100644 --- a/linden/indra/newview/CMakeLists.txt +++ b/linden/indra/newview/CMakeLists.txt | |||
@@ -1348,7 +1348,7 @@ if (WINDOWS) | |||
1348 | -E | 1348 | -E |
1349 | copy_if_different | 1349 | copy_if_different |
1350 | ${CMAKE_CURRENT_SOURCE_DIR}/../../scripts/messages/message_template.msg | 1350 | ${CMAKE_CURRENT_SOURCE_DIR}/../../scripts/messages/message_template.msg |
1351 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/app_settings/message_template.msg | 1351 | ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/app_settings/message_template.msg |
1352 | COMMENT "Copying message_template.msg to the runtime folder." | 1352 | COMMENT "Copying message_template.msg to the runtime folder." |
1353 | ) | 1353 | ) |
1354 | 1354 | ||
@@ -1359,7 +1359,7 @@ if (WINDOWS) | |||
1359 | -E | 1359 | -E |
1360 | copy_if_different | 1360 | copy_if_different |
1361 | ${CMAKE_CURRENT_SOURCE_DIR}/../../etc/message.xml | 1361 | ${CMAKE_CURRENT_SOURCE_DIR}/../../etc/message.xml |
1362 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/app_settings/message.xml | 1362 | ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/app_settings/message.xml |
1363 | COMMENT "Copying message.xml to the runtime folder." | 1363 | COMMENT "Copying message.xml to the runtime folder." |
1364 | ) | 1364 | ) |
1365 | 1365 | ||
@@ -1370,11 +1370,11 @@ if (WINDOWS) | |||
1370 | endif (EXISTS ${CMAKE_SOURCE_DIR}/copy_win_scripts) | 1370 | endif (EXISTS ${CMAKE_SOURCE_DIR}/copy_win_scripts) |
1371 | 1371 | ||
1372 | add_custom_command( | 1372 | add_custom_command( |
1373 | OUTPUT ${CMAKE_CFG_INTDIR}/touched.bat | 1373 | OUTPUT ${VIEWER_CFG_INTDIR}/touched.bat |
1374 | COMMAND ${PYTHON_EXECUTABLE} | 1374 | COMMAND ${PYTHON_EXECUTABLE} |
1375 | ARGS | 1375 | ARGS |
1376 | ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py | 1376 | ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py |
1377 | --configuration=${CMAKE_CFG_INTDIR} | 1377 | --configuration=${VIEWER_CFG_INTDIR} |
1378 | --channel=${VIEWER_CHANNEL} | 1378 | --channel=${VIEWER_CHANNEL} |
1379 | --login_channel=${VIEWER_LOGIN_CHANNEL} | 1379 | --login_channel=${VIEWER_LOGIN_CHANNEL} |
1380 | --standalone=${STANDALONE} | 1380 | --standalone=${STANDALONE} |
@@ -1383,15 +1383,15 @@ if (WINDOWS) | |||
1383 | --source=${CMAKE_CURRENT_SOURCE_DIR} | 1383 | --source=${CMAKE_CURRENT_SOURCE_DIR} |
1384 | --artwork=${ARTWORK_DIR} | 1384 | --artwork=${ARTWORK_DIR} |
1385 | --build=${CMAKE_CURRENT_BINARY_DIR} | 1385 | --build=${CMAKE_CURRENT_BINARY_DIR} |
1386 | --dest=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/package | 1386 | --dest=${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/package |
1387 | --touch=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/touched.bat | 1387 | --touch=${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/touched.bat |
1388 | DEPENDS ${VIEWER_BINARY_NAME} ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py | 1388 | DEPENDS ${VIEWER_BINARY_NAME} ${CMAKE_CURRENT_SOURCE_DIR}/viewer_manifest.py |
1389 | ) | 1389 | ) |
1390 | 1390 | ||
1391 | add_dependencies(${VIEWER_BINARY_NAME} SLPlugin media_plugin_quicktime media_plugin_webkit media_plugin_gstreamer010) | 1391 | add_dependencies(${VIEWER_BINARY_NAME} SLPlugin media_plugin_quicktime media_plugin_webkit media_plugin_gstreamer010) |
1392 | 1392 | ||
1393 | if (PACKAGE) | 1393 | if (PACKAGE) |
1394 | add_custom_target(package ALL DEPENDS ${CMAKE_CFG_INTDIR}/touched.bat) | 1394 | add_custom_target(package ALL DEPENDS ${VIEWER_CFG_INTDIR}/touched.bat) |
1395 | add_dependencies(package windows-updater windows-crash-logger) | 1395 | add_dependencies(package windows-updater windows-crash-logger) |
1396 | endif (PACKAGE) | 1396 | endif (PACKAGE) |
1397 | endif (WINDOWS) | 1397 | endif (WINDOWS) |
@@ -1526,8 +1526,8 @@ if (DARWIN) | |||
1526 | --artwork=${ARTWORK_DIR} | 1526 | --artwork=${ARTWORK_DIR} |
1527 | --build=${CMAKE_CURRENT_BINARY_DIR} | 1527 | --build=${CMAKE_CURRENT_BINARY_DIR} |
1528 | --buildtype=${CMAKE_BUILD_TYPE} | 1528 | --buildtype=${CMAKE_BUILD_TYPE} |
1529 | --configuration=${CMAKE_CFG_INTDIR} | 1529 | --configuration=${VIEWER_CFG_INTDIR} |
1530 | --dest=${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/${product}.app | 1530 | --dest=${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/${product}.app |
1531 | --grid=${GRID} | 1531 | --grid=${GRID} |
1532 | --source=${CMAKE_CURRENT_SOURCE_DIR} | 1532 | --source=${CMAKE_CURRENT_SOURCE_DIR} |
1533 | --standalone=${STANDALONE} | 1533 | --standalone=${STANDALONE} |
@@ -1558,8 +1558,8 @@ if (WINDOWS) | |||
1558 | -E | 1558 | -E |
1559 | copy_if_different | 1559 | copy_if_different |
1560 | ${BUILT_LLCOMMON} | 1560 | ${BUILT_LLCOMMON} |
1561 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR} | 1561 | ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR} |
1562 | COMMENT "Copying llcommon.dll to the runtime folder." | 1562 | COMMENT "Copying llcommon.dll to the runtime folder ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}." |
1563 | ) | 1563 | ) |
1564 | 1564 | ||
1565 | get_target_property(BUILT_SLPLUGIN SLPlugin LOCATION) | 1565 | get_target_property(BUILT_SLPLUGIN SLPlugin LOCATION) |
@@ -1570,8 +1570,8 @@ if (WINDOWS) | |||
1570 | -E | 1570 | -E |
1571 | copy_if_different | 1571 | copy_if_different |
1572 | ${BUILT_SLPLUGIN} | 1572 | ${BUILT_SLPLUGIN} |
1573 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR} | 1573 | ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR} |
1574 | COMMENT "Copying SLPlugin executable to the runtime folder." | 1574 | COMMENT "Copying SLPlugin executable to the runtime folder ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}." |
1575 | ) | 1575 | ) |
1576 | 1576 | ||
1577 | get_target_property(BUILT_WEBKIT_PLUGIN media_plugin_webkit LOCATION) | 1577 | get_target_property(BUILT_WEBKIT_PLUGIN media_plugin_webkit LOCATION) |
@@ -1582,8 +1582,8 @@ if (WINDOWS) | |||
1582 | -E | 1582 | -E |
1583 | copy_if_different | 1583 | copy_if_different |
1584 | ${BUILT_WEBKIT_PLUGIN} | 1584 | ${BUILT_WEBKIT_PLUGIN} |
1585 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin | 1585 | ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin |
1586 | COMMENT "Copying WebKit Plugin to the runtime folder." | 1586 | COMMENT "Copying WebKit Plugin to the runtime folder ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin." |
1587 | ) | 1587 | ) |
1588 | 1588 | ||
1589 | get_target_property(BUILT_GSTREAMER_PLUGIN media_plugin_gstreamer010 LOCATION) | 1589 | get_target_property(BUILT_GSTREAMER_PLUGIN media_plugin_gstreamer010 LOCATION) |
@@ -1594,8 +1594,8 @@ if (WINDOWS) | |||
1594 | -E | 1594 | -E |
1595 | copy_if_different | 1595 | copy_if_different |
1596 | ${BUILT_GSTREAMER_PLUGIN} | 1596 | ${BUILT_GSTREAMER_PLUGIN} |
1597 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin | 1597 | ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin |
1598 | COMMENT "Copying Gstreamer Plugin to the runtime folder." | 1598 | COMMENT "Copying Gstreamer Plugin to the runtime folder ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin." |
1599 | ) | 1599 | ) |
1600 | 1600 | ||
1601 | get_target_property(BUILT_QUICKTIME_PLUGIN media_plugin_quicktime LOCATION) | 1601 | get_target_property(BUILT_QUICKTIME_PLUGIN media_plugin_quicktime LOCATION) |
@@ -1606,13 +1606,13 @@ if (WINDOWS) | |||
1606 | -E | 1606 | -E |
1607 | copy_if_different | 1607 | copy_if_different |
1608 | ${BUILT_QUICKTIME_PLUGIN} | 1608 | ${BUILT_QUICKTIME_PLUGIN} |
1609 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin | 1609 | ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin |
1610 | COMMENT "Copying Quicktime Plugin to the runtime folder." | 1610 | COMMENT "Copying Quicktime Plugin to the runtime folder ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin." |
1611 | ) | 1611 | ) |
1612 | 1612 | ||
1613 | # Copying the mime_types.xml file to app_settings | 1613 | # Copying the mime_types.xml file to app_settings |
1614 | set(mime_types_source "${CMAKE_SOURCE_DIR}/newview/skins/default/xui/en-us") | 1614 | set(mime_types_source "${CMAKE_SOURCE_DIR}/newview/skins/default/xui/en-us") |
1615 | set(mime_types_dest "${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/app_settings") | 1615 | set(mime_types_dest "${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/app_settings") |
1616 | add_custom_command( | 1616 | add_custom_command( |
1617 | TARGET ${VIEWER_BINARY_NAME} POST_BUILD | 1617 | TARGET ${VIEWER_BINARY_NAME} POST_BUILD |
1618 | COMMAND ${CMAKE_COMMAND} | 1618 | COMMAND ${CMAKE_COMMAND} |
@@ -1629,7 +1629,7 @@ endif (WINDOWS) | |||
1629 | if (DARWIN) | 1629 | if (DARWIN) |
1630 | # Don't do this here -- it's taken care of by viewer_manifest.py | 1630 | # Don't do this here -- it's taken care of by viewer_manifest.py |
1631 | # add_custom_command(TARGET ${VIEWER_BINARY_NAME} POST_BUILD | 1631 | # add_custom_command(TARGET ${VIEWER_BINARY_NAME} POST_BUILD |
1632 | # COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llplugin/ | 1632 | # COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llplugin/ |
1633 | # DEPENDS ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib | 1633 | # DEPENDS ${CMAKE_SOURCE_DIR}/../libraries/universal-darwin/lib_release/libllqtwebkit.dylib |
1634 | # ) | 1634 | # ) |
1635 | endif (DARWIN) | 1635 | endif (DARWIN) |
diff --git a/linden/indra/newview/installers/windows/imprudence_installer_template.iss b/linden/indra/newview/installers/windows/imprudence_installer_template.iss index 7113368..7d02b0c 100644 --- a/linden/indra/newview/installers/windows/imprudence_installer_template.iss +++ b/linden/indra/newview/installers/windows/imprudence_installer_template.iss | |||
@@ -27,16 +27,16 @@ AppPublisher=The Imprudence Project | |||
27 | AppPublisherURL=http://kokuaviewer.org | 27 | AppPublisherURL=http://kokuaviewer.org |
28 | AppSupportURL=http://kokuaviewer.org | 28 | AppSupportURL=http://kokuaviewer.org |
29 | AllowNoIcons=true | 29 | AllowNoIcons=true |
30 | InfoAfterFile=..\..\..\..\..\README.txt | 30 | InfoAfterFile=..\..\..\..\..\..\README.txt |
31 | OutputDir=. | 31 | OutputDir=. |
32 | SetupIconFile=..\..\..\newview\installers\windows\imp_icon.ico | 32 | SetupIconFile=..\..\..\..\newview\installers\windows\imp_icon.ico |
33 | Compression=lzma2/ultra64 | 33 | Compression=lzma2/ultra64 |
34 | InternalCompressLevel=ultra64 | 34 | InternalCompressLevel=ultra64 |
35 | SolidCompression=true | 35 | SolidCompression=true |
36 | PrivilegesRequired=poweruser | 36 | PrivilegesRequired=poweruser |
37 | AllowRootDirectory=true | 37 | AllowRootDirectory=true |
38 | WizardImageFile=..\..\..\newview\installers\windows\imprudence_installer_icon_left.bmp | 38 | WizardImageFile=..\..\..\..\newview\installers\windows\imprudence_installer_icon_left.bmp |
39 | WizardSmallImageFile=..\..\..\newview\installers\windows\imprudence_installer_icon_right.bmp | 39 | WizardSmallImageFile=..\..\..\..\newview\installers\windows\imprudence_installer_icon_right.bmp |
40 | SetupLogging=true | 40 | SetupLogging=true |
41 | RestartIfNeededByRun=false | 41 | RestartIfNeededByRun=false |
42 | AlwaysRestart=false | 42 | AlwaysRestart=false |
@@ -145,9 +145,9 @@ Source: %%PACKAGEFILES%%\vivoxsdk.dll; DestDir: {app}; Flags: ignoreversion | |||
145 | Source: %%PACKAGEFILES%%\wrap_oal.dll; DestDir: {app}; Flags: ignoreversion | 145 | Source: %%PACKAGEFILES%%\wrap_oal.dll; DestDir: {app}; Flags: ignoreversion |
146 | 146 | ||
147 | ; VC++ 2005 SP1 x86, VC++ 2008 SP1 x86, and VC++ 2010 SP1 x86 redist | 147 | ; VC++ 2005 SP1 x86, VC++ 2008 SP1 x86, and VC++ 2010 SP1 x86 redist |
148 | Source: ..\..\..\newview\installers\windows\vcredist_x86_VS2005_SP1_MFC_SEC.exe; DestDir: {app}\redist; DestName: vcredist_x86_VS2005_SP1_MFC_SEC.exe | 148 | Source: ..\..\..\..\newview\installers\windows\vcredist_x86_VS2005_SP1_MFC_SEC.exe; DestDir: {app}\redist; DestName: vcredist_x86_VS2005_SP1_MFC_SEC.exe |
149 | ;Source: ..\..\..\newview\installers\windows\vcredist_x86_VS2008_SP1_ATL_SEC.exe; DestDir: {app}\redist; DestName: vcredist_x86_VS2008_SP1_ATL_SEC.exe | 149 | ;Source: ..\..\..\..\newview\installers\windows\vcredist_x86_VS2008_SP1_ATL_SEC.exe; DestDir: {app}\redist; DestName: vcredist_x86_VS2008_SP1_ATL_SEC.exe |
150 | Source: ..\..\..\newview\installers\windows\vcredist_x86_VS2010_SP1.exe; DestDir: {app}\redist; DestName: vcredist_x86_VS2010_SP1.exe | 150 | Source: ..\..\..\..\newview\installers\windows\vcredist_x86_VS2010_SP1.exe; DestDir: {app}\redist; DestName: vcredist_x86_VS2010_SP1.exe |
151 | 151 | ||
152 | ; Old files we don't use anymore: | 152 | ; Old files we don't use anymore: |
153 | ; Source: %%PACKAGEFILES%%\dronesettings.xml; DestDir: {app}; Flags: ignoreversion | 153 | ; Source: %%PACKAGEFILES%%\dronesettings.xml; DestDir: {app}; Flags: ignoreversion |
diff --git a/linden/indra/newview/viewer_manifest.py b/linden/indra/newview/viewer_manifest.py index 718c3d2..84e75b8 100755 --- a/linden/indra/newview/viewer_manifest.py +++ b/linden/indra/newview/viewer_manifest.py | |||
@@ -232,21 +232,15 @@ class WindowsManifest(ViewerManifest): | |||
232 | 232 | ||
233 | def construct(self): | 233 | def construct(self): |
234 | super(WindowsManifest, self).construct() | 234 | super(WindowsManifest, self).construct() |
235 | # the final exe is complicated because we're not sure where it's coming from, | 235 | # Come out, come out, where ever you are. |
236 | # nor do we have a fixed name for the executable | 236 | executable = self.find_existing_file('release/imprudence-bin.exe', 'releasesse2/imprudence-bin.exe', 'relwithdebinfo/imprudence-bin.exe', 'debug/imprudence-bin.exe', './imprudence-bin.exe') |
237 | # Actually, we know on both counts -- MC | 237 | nmake = False |
238 | if self.configuration().lower() == "release": | 238 | self.path(executable, dst=self.final_exe()) |
239 | self.path(self.find_existing_file('release/imprudence-bin.exe'), dst=self.final_exe()) | ||
240 | elif self.configuration().lower() == "releasesse2": | ||
241 | self.path(self.find_existing_file('releasesse2/imprudence-bin.exe'), dst=self.final_exe()) | ||
242 | elif self.configuration().lower() == "relwithdebinfo": | ||
243 | self.path(self.find_existing_file('relwithdebinfo/imprudence-bin.exe'), dst=self.final_exe()) | ||
244 | elif self.configuration().lower() == "debug": | ||
245 | self.path(self.find_existing_file('debug/imprudence-bin.exe'), dst=self.final_exe()) | ||
246 | else: | ||
247 | self.path(self.find_existing_file('release/imprudence-bin.exe', 'releasesse2/imprudence-bin.exe', 'relwithdebinfo/imprudence-bin.exe', 'debug/imprudence-bin.exe', 'imprudence-bin.exe'), dst=self.final_exe()) | ||
248 | 239 | ||
249 | # copy over the the pdb file for the regular or SSE2 versions if we don't already have one copied | 240 | # copy over the the pdb file for the regular or SSE2 versions if we don't already have one copied |
241 | # Don't think this ever worked, the destination seems bogus. | ||
242 | # It's trying to copy a built file outside of the source tree, a file we have anyway. | ||
243 | # TODO - do we even need this? | ||
250 | symbol_ver = '.'.join(self.args['version']) | 244 | symbol_ver = '.'.join(self.args['version']) |
251 | symbol_file = 'imprudence-%s.%s.pdb' % (symbol_ver, self.args['configuration']) | 245 | symbol_file = 'imprudence-%s.%s.pdb' % (symbol_ver, self.args['configuration']) |
252 | symbol_path = '../../../../../pdb_files/%s' % (symbol_file) | 246 | symbol_path = '../../../../../pdb_files/%s' % (symbol_file) |
@@ -255,7 +249,7 @@ class WindowsManifest(ViewerManifest): | |||
255 | else: | 249 | else: |
256 | #print "%s doesn't exist yet" % (os.getcwd() + symbol_path) | 250 | #print "%s doesn't exist yet" % (os.getcwd() + symbol_path) |
257 | try: | 251 | try: |
258 | self.path(self.find_existing_file('release/imprudence-bin.pdb'), dst="../%s" % (symbol_path)) | 252 | self.path(self.find_existing_file(executable.split('/', 1)[0] % '/imprudence-bin.pdb'), dst="../%s" % (symbol_path)) |
259 | pass | 253 | pass |
260 | except: | 254 | except: |
261 | print "Can't save symbol file %s, skipping" % (symbol_path) | 255 | print "Can't save symbol file %s, skipping" % (symbol_path) |
@@ -270,7 +264,13 @@ class WindowsManifest(ViewerManifest): | |||
270 | self.path("imprudence.url") | 264 | self.path("imprudence.url") |
271 | 265 | ||
272 | # Plugin host application | 266 | # Plugin host application |
273 | self.path(os.path.join(os.pardir, 'llplugin', 'slplugin', self.args['configuration'], "SLPlugin.exe"), "SLPlugin.exe") | 267 | try: |
268 | self.path(os.path.join(os.pardir, 'llplugin', 'slplugin', self.args['configuration'], "SLPlugin.exe"), "SLPlugin.exe") | ||
269 | except: | ||
270 | # Probably an nmake build, which is not putting exe's into the configuration folders. | ||
271 | self.path(os.path.join(os.pardir, 'llplugin', 'slplugin', "SLPlugin.exe"), "SLPlugin.exe") | ||
272 | # Propogate our wild guess. | ||
273 | nmake = True | ||
274 | 274 | ||
275 | self.path("featuretable.txt") | 275 | self.path("featuretable.txt") |
276 | 276 | ||
@@ -281,7 +281,7 @@ class WindowsManifest(ViewerManifest): | |||
281 | #self.path("fmod.dll") | 281 | #self.path("fmod.dll") |
282 | 282 | ||
283 | # For spellchecking | 283 | # For spellchecking |
284 | if self.prefix(src=os.path.join(self.args['configuration'], "Release"), dst=""): | 284 | if self.prefix(self.args['configuration'], dst=""): |
285 | self.path("libhunspell.dll") | 285 | self.path("libhunspell.dll") |
286 | self.end_prefix() | 286 | self.end_prefix() |
287 | 287 | ||
@@ -289,12 +289,12 @@ class WindowsManifest(ViewerManifest): | |||
289 | self.path("llkdu.dll.2.config") | 289 | self.path("llkdu.dll.2.config") |
290 | 290 | ||
291 | # Get llcommon and deps. | 291 | # Get llcommon and deps. |
292 | if self.prefix(src=os.path.join(self.args['configuration'], "Release"), dst=""): | 292 | if self.prefix(self.args['configuration'], dst=""): |
293 | self.path('libapr-1.dll') | 293 | self.path('libapr-1.dll') |
294 | self.path('libaprutil-1.dll') | 294 | self.path('libaprutil-1.dll') |
295 | self.path('libapriconv-1.dll') | 295 | self.path('libapriconv-1.dll') |
296 | self.end_prefix() | ||
297 | self.path('llcommon.dll') | 296 | self.path('llcommon.dll') |
297 | self.end_prefix() | ||
298 | 298 | ||
299 | # For textures | 299 | # For textures |
300 | if self.prefix(src="../../libraries/i686-win32/lib/release", dst=""): | 300 | if self.prefix(src="../../libraries/i686-win32/lib/release", dst=""): |
@@ -307,21 +307,26 @@ class WindowsManifest(ViewerManifest): | |||
307 | self.path("alut.dll") | 307 | self.path("alut.dll") |
308 | self.end_prefix() | 308 | self.end_prefix() |
309 | 309 | ||
310 | # TODO - Yes, I know, would be better if nmake builds put stuff in the right place, track that down and fix it later. | ||
311 | if nmake: | ||
312 | config = '' | ||
313 | else: | ||
314 | config = self.args['configuration'] | ||
310 | # Media plugins - QuickTime | 315 | # Media plugins - QuickTime |
311 | if self.prefix(src='../media_plugins/quicktime/%s' % self.args['configuration'], dst="llplugin"): | 316 | if self.prefix(src='../media_plugins/quicktime/%s' % config, dst="llplugin"): |
312 | self.path("media_plugin_quicktime.dll") | 317 | self.path("media_plugin_quicktime.dll") |
313 | self.end_prefix() | 318 | self.end_prefix() |
314 | 319 | ||
315 | # Media plugins - WebKit/Qt | 320 | # Media plugins - WebKit/Qt |
316 | if self.prefix(src='../media_plugins/webkit/%s' % self.args['configuration'], dst="llplugin"): | 321 | if self.prefix(src='../media_plugins/webkit/%s' % config, dst="llplugin"): |
317 | self.path("media_plugin_webkit.dll") | 322 | self.path("media_plugin_webkit.dll") |
318 | self.end_prefix() | 323 | self.end_prefix() |
319 | 324 | ||
320 | # Media plugins - GStreamer | 325 | # Media plugins - GStreamer |
321 | if self.prefix(src='../media_plugins/gstreamer010/%s' % self.args['configuration'], dst="llplugin"): | 326 | if self.prefix(src='../media_plugins/gstreamer010/%s' % config, dst="llplugin"): |
322 | self.path("media_plugin_gstreamer010.dll") | 327 | self.path("media_plugin_gstreamer010.dll") |
323 | self.end_prefix() | 328 | self.end_prefix() |
324 | 329 | ||
325 | # For WebKit/Qt plugin runtimes | 330 | # For WebKit/Qt plugin runtimes |
326 | if self.prefix(src="../../libraries/i686-win32/lib/release", dst="llplugin"): | 331 | if self.prefix(src="../../libraries/i686-win32/lib/release", dst="llplugin"): |
327 | self.path("libeay32.dll") | 332 | self.path("libeay32.dll") |
diff --git a/linden/indra/test_apps/llplugintest/CMakeLists.txt b/linden/indra/test_apps/llplugintest/CMakeLists.txt index a6cb740..91ba2db 100644 --- a/linden/indra/test_apps/llplugintest/CMakeLists.txt +++ b/linden/indra/test_apps/llplugintest/CMakeLists.txt | |||
@@ -311,7 +311,7 @@ endif (DARWIN OR LINUX) | |||
311 | if (DARWIN) | 311 | if (DARWIN) |
312 | # path inside the app bundle where we'll need to copy plugins and other related files | 312 | # path inside the app bundle where we'll need to copy plugins and other related files |
313 | set(PLUGINS_DESTINATION_DIR | 313 | set(PLUGINS_DESTINATION_DIR |
314 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/llmediaplugintest.app/Contents/Resources | 314 | ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/llmediaplugintest.app/Contents/Resources |
315 | ) | 315 | ) |
316 | 316 | ||
317 | # create the Contents/Resources directory | 317 | # create the Contents/Resources directory |
@@ -326,7 +326,7 @@ if (DARWIN) | |||
326 | ) | 326 | ) |
327 | else (DARWIN) | 327 | else (DARWIN) |
328 | set(PLUGINS_DESTINATION_DIR | 328 | set(PLUGINS_DESTINATION_DIR |
329 | ${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_CFG_INTDIR}/ | 329 | ${CMAKE_CURRENT_BINARY_DIR}/${VIEWER_CFG_INTDIR}/ |
330 | ) | 330 | ) |
331 | endif (DARWIN) | 331 | endif (DARWIN) |
332 | 332 | ||
diff --git a/linden/scripts/linux/4-package-viewer b/linden/scripts/linux/4-package-viewer index 19d2456..d954f02 100755 --- a/linden/scripts/linux/4-package-viewer +++ b/linden/scripts/linux/4-package-viewer | |||
@@ -3,7 +3,7 @@ | |||
3 | if [ "$OSTYPE" == "cygwin" ] ; then | 3 | if [ "$OSTYPE" == "cygwin" ] ; then |
4 | # Assumes version has been passed in from outside, coz Windows insists on adding crap to python output. | 4 | # Assumes version has been passed in from outside, coz Windows insists on adding crap to python output. |
5 | cd ../../indra/build-nmake/ | 5 | cd ../../indra/build-nmake/ |
6 | iscc newview/package/${version}-Windows-x86.iss | 6 | iscc newview/$TYPE/package/${version}-Windows-x86.iss |
7 | else | 7 | else |
8 | cd ../../indra/viewer-linux-* | 8 | cd ../../indra/viewer-linux-* |
9 | make package | 9 | make package |