aboutsummaryrefslogtreecommitdiffstatshomepage
diff options
context:
space:
mode:
authorunknown2008-12-30 14:50:08 -0700
committerunknown2008-12-30 14:50:08 -0700
commit9ad66298fded7500c884c0a32e576dd56ae60e44 (patch)
tree63265013176b80695b163e30f38473eb8a577597
parentMerged in balp's openal branch (diff)
downloadmeta-impy-9ad66298fded7500c884c0a32e576dd56ae60e44.zip
meta-impy-9ad66298fded7500c884c0a32e576dd56ae60e44.tar.gz
meta-impy-9ad66298fded7500c884c0a32e576dd56ae60e44.tar.bz2
meta-impy-9ad66298fded7500c884c0a32e576dd56ae60e44.tar.xz
Fixed a compile problem in VS2005
-rw-r--r--ChangeLog.txt9
-rw-r--r--linden/indra/llaudio/audioengine_openal.cpp2
-rw-r--r--linden/indra/llaudio/audioengine_openal.h1
3 files changed, 8 insertions, 4 deletions
diff --git a/ChangeLog.txt b/ChangeLog.txt
index 094fb1e..4ebc477 100644
--- a/ChangeLog.txt
+++ b/ChangeLog.txt
@@ -1,9 +1,14 @@
12008-12-30 McCabe Maxsted <hakushakukun@gmail.com> 12008-12-30 McCabe Maxsted <hakushakukun@gmail.com>
2 2
3 * Merged in balp's openal branch. 3
4 * linden/indra/llaudio/audioengine_openal.cpp:
5 Fixed a compile problem in VS2005.
6 * linden/indra/llaudio/audioengine_openal.h:
7 Ditto.
4 8
5 9
62008-12-30 McCabe Maxsted <hakushakukun@gmail.com> 10 * Merged in balp's openal branch.
11
7 12
8 * linden/indra/CMakeLists.txt: 13 * linden/indra/CMakeLists.txt:
9 "Added fix for VWR-10392 as well as other fixes. 14 "Added fix for VWR-10392 as well as other fixes.
diff --git a/linden/indra/llaudio/audioengine_openal.cpp b/linden/indra/llaudio/audioengine_openal.cpp
index f13a5fa..de87c2a 100644
--- a/linden/indra/llaudio/audioengine_openal.cpp
+++ b/linden/indra/llaudio/audioengine_openal.cpp
@@ -36,7 +36,6 @@
36#include "audioengine_openal.h" 36#include "audioengine_openal.h"
37#include "listener_openal.h" 37#include "listener_openal.h"
38 38
39
40LLAudioEngine_OpenAL::LLAudioEngine_OpenAL() 39LLAudioEngine_OpenAL::LLAudioEngine_OpenAL()
41 : 40 :
42 mWindGen(NULL), 41 mWindGen(NULL),
@@ -390,6 +389,7 @@ void LLAudioEngine_OpenAL::initWind()
390 } 389 }
391 390
392 mWindGen = new LLWindGen<WIND_SAMPLE_T>; 391 mWindGen = new LLWindGen<WIND_SAMPLE_T>;
392 static const float WIND_BUFFER_SIZE_SEC = 0.05f; // 1/20th sec
393 393
394 mWindBufFreq = mWindGen->getInputSamplingRate(); 394 mWindBufFreq = mWindGen->getInputSamplingRate();
395 mWindBufSamples = llceil(mWindBufFreq * WIND_BUFFER_SIZE_SEC); 395 mWindBufSamples = llceil(mWindBufFreq * WIND_BUFFER_SIZE_SEC);
diff --git a/linden/indra/llaudio/audioengine_openal.h b/linden/indra/llaudio/audioengine_openal.h
index b03153a..1f6dee4 100644
--- a/linden/indra/llaudio/audioengine_openal.h
+++ b/linden/indra/llaudio/audioengine_openal.h
@@ -72,7 +72,6 @@ class LLAudioEngine_OpenAL : public LLAudioEngine
72 int mNumEmptyWindALBuffers; 72 int mNumEmptyWindALBuffers;
73 73
74 static const int MAX_NUM_WIND_BUFFERS = 80; 74 static const int MAX_NUM_WIND_BUFFERS = 80;
75 static const float WIND_BUFFER_SIZE_SEC = 0.05f; // 1/20th sec
76}; 75};
77 76
78class LLAudioChannelOpenAL : public LLAudioChannel 77class LLAudioChannelOpenAL : public LLAudioChannel