From 9ad66298fded7500c884c0a32e576dd56ae60e44 Mon Sep 17 00:00:00 2001
From: unknown
Date: Tue, 30 Dec 2008 14:50:08 -0700
Subject: Fixed a compile problem in VS2005

---
 ChangeLog.txt                               | 9 +++++++--
 linden/indra/llaudio/audioengine_openal.cpp | 2 +-
 linden/indra/llaudio/audioengine_openal.h   | 1 -
 3 files changed, 8 insertions(+), 4 deletions(-)

diff --git a/ChangeLog.txt b/ChangeLog.txt
index 094fb1e..4ebc477 100644
--- a/ChangeLog.txt
+++ b/ChangeLog.txt
@@ -1,9 +1,14 @@
 2008-12-30  McCabe Maxsted  <hakushakukun@gmail.com>
 
-	* Merged in balp's openal branch.
+
+	* linden/indra/llaudio/audioengine_openal.cpp:
+	Fixed a compile problem in VS2005.
+	* linden/indra/llaudio/audioengine_openal.h:
+	Ditto.
 
 
-2008-12-30  McCabe Maxsted  <hakushakukun@gmail.com>
+	* Merged in balp's openal branch.
+
 
 	* linden/indra/CMakeLists.txt:
 	"Added fix for VWR-10392 as well as other fixes.
diff --git a/linden/indra/llaudio/audioengine_openal.cpp b/linden/indra/llaudio/audioengine_openal.cpp
index f13a5fa..de87c2a 100644
--- a/linden/indra/llaudio/audioengine_openal.cpp
+++ b/linden/indra/llaudio/audioengine_openal.cpp
@@ -36,7 +36,6 @@
 #include "audioengine_openal.h"
 #include "listener_openal.h"
 
-
 LLAudioEngine_OpenAL::LLAudioEngine_OpenAL()
 	:
 	mWindGen(NULL),
@@ -390,6 +389,7 @@ void LLAudioEngine_OpenAL::initWind()
 	}
 
 	mWindGen = new LLWindGen<WIND_SAMPLE_T>;
+	static const float WIND_BUFFER_SIZE_SEC = 0.05f; // 1/20th sec
 
 	mWindBufFreq = mWindGen->getInputSamplingRate();
 	mWindBufSamples = llceil(mWindBufFreq * WIND_BUFFER_SIZE_SEC);
diff --git a/linden/indra/llaudio/audioengine_openal.h b/linden/indra/llaudio/audioengine_openal.h
index b03153a..1f6dee4 100644
--- a/linden/indra/llaudio/audioengine_openal.h
+++ b/linden/indra/llaudio/audioengine_openal.h
@@ -72,7 +72,6 @@ class LLAudioEngine_OpenAL : public LLAudioEngine
 	        int mNumEmptyWindALBuffers;
 
         	static const int MAX_NUM_WIND_BUFFERS = 80;
-        	static const float WIND_BUFFER_SIZE_SEC = 0.05f; // 1/20th sec
 };
 
 class LLAudioChannelOpenAL : public LLAudioChannel
-- 
cgit v1.1