aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/embryo/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/embryo/doc/Makefile.am')
-rw-r--r--libraries/embryo/doc/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/libraries/embryo/doc/Makefile.am b/libraries/embryo/doc/Makefile.am
new file mode 100644
index 0000000..91c79f3
--- /dev/null
+++ b/libraries/embryo/doc/Makefile.am
@@ -0,0 +1,33 @@
1
2MAINTAINERCLEANFILES = Makefile.in embryo.dox
3
4.PHONY: doc
5
6PACKAGE_DOCNAME = $(PACKAGE_TARNAME)-$(PACKAGE_VERSION)-doc
7
8if EFL_BUILD_DOC
9
10doc-clean:
11 rm -rf html/ latex/ man/ xml/ $(top_builddir)/$(PACKAGE_DOCNAME).tar*
12
13doc: all doc-clean
14 $(efl_doxygen)
15 cp $(srcdir)/img/* html/
16 rm -rf $(PACKAGE_DOCNAME).tar*
17 mkdir -p $(PACKAGE_DOCNAME)/doc
18 cp -R html/ latex/ man/ $(PACKAGE_DOCNAME)/doc
19 tar cf $(PACKAGE_DOCNAME).tar $(PACKAGE_DOCNAME)/
20 bzip2 -9 $(PACKAGE_DOCNAME).tar
21 rm -rf $(PACKAGE_DOCNAME)/
22 mv $(PACKAGE_DOCNAME).tar.bz2 $(top_builddir)
23
24clean-local: doc-clean
25
26else
27
28doc:
29 @echo "Documentation not built. Run ./configure --help"
30
31endif
32
33EXTRA_DIST = Doxyfile e.css foot.html head.html $(wildcard img/*.*) embryo.dox.in