aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/edje/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/edje/doc/Makefile.am')
-rw-r--r--libraries/edje/doc/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/libraries/edje/doc/Makefile.am b/libraries/edje/doc/Makefile.am
new file mode 100644
index 0000000..97c2a68
--- /dev/null
+++ b/libraries/edje/doc/Makefile.am
@@ -0,0 +1,35 @@
1
2MAINTAINERCLEANFILES = Makefile.in
3
4.PHONY: doc
5
6PACKAGE_DOCNAME = $(PACKAGE_TARNAME)-$(PACKAGE_VERSION)-doc
7
8if EFL_BUILD_DOC
9
10doc-clean:
11 rm -rf html/ latex/ man/ xml/ $(top_builddir)/$(PACKAGE_DOCNAME).tar*
12
13doc: all doc-clean
14 $(efl_doxygen)
15 cp $(srcdir)/img/* html/
16 cp $(srcdir)/img/* latex/
17 rm -rf $(PACKAGE_DOCNAME).tar*
18 mkdir -p $(PACKAGE_DOCNAME)/doc
19 cp -R html/ latex/ man/ $(PACKAGE_DOCNAME)/doc
20 tar cf $(PACKAGE_DOCNAME).tar $(PACKAGE_DOCNAME)/
21 bzip2 -9 $(PACKAGE_DOCNAME).tar
22 rm -rf $(PACKAGE_DOCNAME)/
23 mv $(PACKAGE_DOCNAME).tar.bz2 $(top_builddir)
24
25clean-local: doc-clean
26
27else
28
29doc:
30 @echo "Documentation not built. Run ./configure --help"
31
32endif
33
34EXTRA_DIST = Doxyfile e.css foot.html head.html $(wildcard img/*.*) \
35 $(wildcard examples/*.*)