aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/libraries/edje/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/edje/configure.ac')
-rw-r--r--libraries/edje/configure.ac643
1 files changed, 643 insertions, 0 deletions
diff --git a/libraries/edje/configure.ac b/libraries/edje/configure.ac
new file mode 100644
index 0000000..36bf32c
--- /dev/null
+++ b/libraries/edje/configure.ac
@@ -0,0 +1,643 @@
1##--##--##--##--##--##--##--##--##--##--##--##--##--##--##--##--##
2##--##--##--##--##--##--##--##--##--##--##--##--##--##--##--##--##
3m4_define([v_maj], [1])
4m4_define([v_min], [1])
5m4_define([v_mic], [0])
6m4_define([v_rev], m4_esyscmd([(svnversion "${SVN_REPO_PATH:-.}" | grep -v export || echo 0) | awk -F : '{printf("%s\n", $1);}' | tr -d ' :MSP\n']))
7m4_if(v_rev, [0], [m4_define([v_rev], m4_esyscmd([git log 2> /dev/null | (grep -m1 git-svn-id || echo 0) | sed -e 's/.*@\([0-9]*\).*/\1/' | tr -d '\n']))])
8##-- When released, remove the dnl on the below line
9m4_undefine([v_rev])
10##-- When doing snapshots - change soname. remove dnl on below line
11dnl m4_define([relname], [ver-pre-svn-07])
12dnl m4_define([v_rel], [-release relname])
13##--##--##--##--##--##--##--##--##--##--##--##--##--##--##--##--##
14m4_ifdef([v_rev], [m4_define([v_ver], [v_maj.v_min.v_mic.v_rev])], [m4_define([v_ver], [v_maj.v_min.v_mic])])
15m4_define([lt_cur], m4_eval(v_maj + v_min))
16m4_define([lt_rev], v_mic)
17m4_define([lt_age], v_min)
18##--##--##--##--##--##--##--##--##--##--##--##--##--##--##--##--##
19##--##--##--##--##--##--##--##--##--##--##--##--##--##--##--##--##
20
21AC_INIT([edje], [v_ver], [enlightenment-devel@lists.sourceforge.net])
22AC_PREREQ([2.52])
23AC_CONFIG_SRCDIR([configure.ac])
24AC_CONFIG_MACRO_DIR([m4])
25
26AC_CONFIG_HEADERS([config.h])
27AH_TOP([
28#ifndef EFL_CONFIG_H__
29#define EFL_CONFIG_H__
30])
31AH_BOTTOM([
32#endif /* EFL_CONFIG_H__ */
33])
34
35AM_INIT_AUTOMAKE([1.6 dist-bzip2])
36m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
37
38AC_LIBTOOL_WIN32_DLL
39define([AC_LIBTOOL_LANG_CXX_CONFIG], [:])dnl
40define([AC_LIBTOOL_LANG_F77_CONFIG], [:])dnl
41AC_PROG_LIBTOOL
42
43##--##--##--##--##--##--##--##--##--##--##--##--##--##--##--##--##
44##--##--##--##--##--##--##--##--##--##--##--##--##--##--##--##--##
45m4_ifdef([v_rev], , [m4_define([v_rev], [0])])
46m4_ifdef([v_rel], , [m4_define([v_rel], [])])
47AC_DEFINE_UNQUOTED(VMAJ, [v_maj], [Major version])
48AC_DEFINE_UNQUOTED(VMIN, [v_min], [Minor version])
49AC_DEFINE_UNQUOTED(VMIC, [v_mic], [Micro version])
50AC_DEFINE_UNQUOTED(VREV, [v_rev], [Revison])
51version_info="lt_cur:lt_rev:lt_age"
52release_info="v_rel"
53AC_SUBST(version_info)
54AC_SUBST(release_info)
55##--##--##--##--##--##--##--##--##--##--##--##--##--##--##--##--##
56##--##--##--##--##--##--##--##--##--##--##--##--##--##--##--##--##
57VMAJ=v_maj
58AC_SUBST(VMAJ)
59
60AC_DEFINE_UNQUOTED([SHARED_LIB_SUFFIX], ["$shrext_cmds"], [Suffix for shared objects])
61
62### Default options with respect to host
63AC_CANONICAL_BUILD
64AC_CANONICAL_HOST
65
66
67case "$host_os" in
68 mingw32ce* | cegcc*)
69 MODULE_ARCH="$host_os-$host_cpu"
70 install_vim="no"
71 have_edje_cc="no"
72 ;;
73 *)
74 MODULE_ARCH="$host_os-$host_cpu-v_maj.0.0"
75 install_vim="yes"
76 have_edje_cc="yes"
77 ;;
78esac
79
80requirement_edje=""
81
82AC_SUBST(MODULE_ARCH)
83AC_DEFINE_UNQUOTED(MODULE_ARCH, "${MODULE_ARCH}", "Module architecture")
84
85### Additional options to configure
86
87AC_ARG_ENABLE([amalgamation],
88 [AC_HELP_STRING([--enable-amalgamation], [enable generation of one single file with all source code in it, helps compiler optimizations.])],
89 [if test "x${enableval}" = "xyes"; then
90 do_amalgamation="yes"
91 else
92 do_amalgamation="no"
93 fi
94 ],
95 [do_amalgamation="no"]
96)
97AM_CONDITIONAL([EDJE_AMALGAMATION], [test "x${do_amalgamation}" = "xyes"])
98
99EFL_ENABLE_BIN([edje-cc])
100EFL_ENABLE_BIN([edje-decc])
101EFL_ENABLE_BIN([edje-recc])
102EFL_ENABLE_BIN([edje-player])
103EFL_ENABLE_BIN([edje-inspector])
104EFL_ENABLE_BIN([edje-external-inspector])
105
106# Optional EDJE_PROGRAM_CACHE (use much more ram, but increase speed in some cases)
107want_edje_program_cache="no"
108
109AC_ARG_ENABLE([edje-program-cache],
110 [AC_HELP_STRING(
111 [--enable-edje-program-cache],
112 [enable EDJE_PROGRAM_CACHE support. [[default=disabled]]]
113 )],
114 [want_edje_program_cache=$enableval]
115)
116AM_CONDITIONAL([EDJE_PROGRAM_CACHE], [test "x${want_edje_program_cache}" = "xyes"])
117
118if test "x${want_edje_program_cache}" = "xyes" ; then
119 AC_DEFINE([EDJE_PROGRAM_CACHE], [1], [Cache result of program glob matches - this uses up extra ram with the gain of faster program matching])
120fi
121
122# Optional EDJE_CALC_CACHE (use more ram, but increase speed by reducing the need to recalculate static stuff)
123want_edje_calc_cache="yes"
124
125AC_ARG_ENABLE([edje-calc-cache],
126 [AC_HELP_STRING(
127 [--enable-edje-calc-cache],
128 [enable EDJE_CALC_CACHE support. [[default=disabled]]]
129 )],
130 [want_edje_calc_cache=$enableval]
131)
132AM_CONDITIONAL([EDJE_CALC_CACHE], [test "x${want_edje_calc_cache}" = "xyes"])
133
134if test "x${want_edje_calc_cache}" = "xyes" ; then
135 AC_DEFINE([EDJE_CALC_CACHE], [1], [Cache result of edje_part_recalc - this uses up extra ram with the gain of reducing CPU usage when edje object are not resized])
136fi
137
138# Enable Fixed Point use
139want_fixed_point="no"
140
141AC_ARG_ENABLE([fixed-point],
142 [AC_HELP_STRING(
143 [--enable-fixed-point],
144 [reduce use of FPU by using Fixed Point provided by Eina and Eet, [[default=disabled]]]
145 )],
146 [want_fixed_point=$enableval]
147)
148AM_CONDITIONAL([BUILD_EDJE_FP], [test "x${want_fixed_point}" = "xyes"])
149
150if test "x${want_fixed_point}" = "xyes" ; then
151 AC_DEFINE([BUILD_EDJE_FP], [1], [Use Fixed Point instead of FPU])
152fi
153
154install_vim="yes"
155AC_ARG_WITH([vim],
156 [AC_HELP_STRING([--with-vim=DIR], [Location of Vim data files [[autodetect]]])],
157 [
158 if test -d "${withval}"; then
159 vimdir="${withval}"
160 fi
161 ]
162)
163
164if test "x${vimdir}" = "x" ; then
165 if test -d "${prefix}/share/vim"; then
166 vimdir="${prefix}/share/vim"
167 elif test -d "/usr/share/vim"; then
168 vimdir="/usr/share/vim"
169 elif test -d "/usr/local/share/vim"; then
170 vimdir="/usr/local/share/vim"
171 elif test -d "/opt/share/vim"; then
172 vimdir="/opt/share/vim"
173 else
174 install_vim="no"
175 fi
176fi
177
178AC_MSG_CHECKING([for location of Vim data files])
179
180if test "${install_vim}" = "yes"; then
181 AC_MSG_RESULT([$vimdir])
182else
183 AC_MSG_RESULT([Not found, EDC syntax file will not be installed])
184fi
185
186AC_SUBST(vimdir)
187
188### Checks for programs
189AC_PROG_CC
190
191# doxygen program for documentation building
192
193EFL_CHECK_DOXYGEN([build_doc="yes"], [build_doc="no"])
194
195# python
196
197AM_PATH_PYTHON([2.5], , [:])
198AM_CONDITIONAL([HAVE_PYTHON], [test "$PYTHON" != : ])
199
200# pkg-config
201
202PKG_PROG_PKG_CONFIG
203
204# Check whether pkg-config supports Requires.private
205
206if $PKG_CONFIG --atleast-pkgconfig-version 0.22; then
207 pkgconfig_requires_private="Requires.private"
208else
209 pkgconfig_requires_private="Requires"
210fi
211AC_SUBST(pkgconfig_requires_private)
212
213
214### Checks for libraries
215
216# Evil library for compilation on Windows
217
218EFL_EDJE_BUILD=""
219case "$host_os" in
220 mingw*)
221 PKG_CHECK_MODULES([EVIL], [evil >= 1.0.0])
222 AC_DEFINE([HAVE_EVIL], [1], [Set to 1 if Evil library is installed])
223 requirement_edje="evil ${requirement_edje}"
224 EFL_EDJE_BUILD="-DEFL_EDJE_BUILD"
225 ;;
226esac
227AC_SUBST(EFL_EDJE_BUILD)
228
229# Dependencies for the library
230
231# Lua pkg-config hack for different naming conventions
232have_lua="yes"
233requirement_lua=""
234lua_libs=""
235PKG_CHECK_MODULES([LUA], [lua >= 5.1.0], requirement_lua="lua",
236 [PKG_CHECK_MODULES([LUA], [lua5.1 >= 5.1.0], requirement_lua="lua5.1",
237 [PKG_CHECK_MODULES([LUA], [lua-5.1 >= 5.1.0], requirement_lua="lua-5.1",
238 [PKG_CHECK_MODULES([LUA], [lua51 >= 5.1.0], requirement_lua="lua51",
239 [have_lua="no"])])])])
240
241if test "x${have_lua}" = "xno" ; then
242 AC_MSG_CHECKING([whether lua_newstate() is in liblua])
243 AC_CHECK_LIB([lua], [lua_newstate],
244 [
245 have_lua="yes"
246 lua_libs="-llua"
247 ],
248 [have_lua="no"])
249 AC_MSG_RESULT([${have_lua}])
250fi
251AC_SUBST(lua_libs)
252
253if test "x${have_lua}" = "xno" ; then
254 AC_MSG_ERROR([Cannot find lua library. Be sure that you have installed it and set CFLAGS and LDFLAGS correctly])
255fi
256
257PKG_CHECK_MODULES([MINIMAL],
258 [
259 eina >= 1.1.0
260 eet >= 1.5.0
261 ])
262
263PKG_CHECK_MODULES([EDJE],
264 [
265 eina >= 1.1.0
266 eet >= 1.5.0
267 evas >= 1.1.0
268 ecore >= 1.1.0
269 ecore-evas >= 1.1.0
270 ecore-file >= 1.1.0
271 embryo >= 1.1.0
272 ])
273
274EDJE_LIBS="${EDJE_LIBS} ${LUA_LIBS} ${lua_libs}"
275EDJE_CFLAGS="${EDJE_CFLAGS} ${LUA_CFLAGS}"
276
277requirement_edje="embryo >= 1.1.0 ecore-evas >= 1.1.0 ecore >= 1.1.0 evas >= 1.1.0 eet >= 1.5.0 eina >= 1.1.0 ${requirement_edje}"
278requirement_edje="${requirement_lua} ${requirement_edje}"
279
280have_ecore_imf="no"
281PKG_CHECK_MODULES([ECORE_IMF],
282 [
283 ecore-imf >= 1.1.0
284 ecore-imf-evas >= 1.1.0
285 ],
286 [
287 AC_DEFINE([HAVE_ECORE_IMF], [1], [Input Method Support for Edje Entry])
288 have_ecore_imf="yes"
289 requirement_edje="ecore-imf-evas >= 1.1.0 ecore-imf >= 1.1.0 ${requirement_edje}"
290 ],
291 [have_ecore_imf="no"])
292
293# Enable Multisense use
294want_multisense="no"
295dnl AC_ARG_ENABLE([multisense],
296dnl [AC_HELP_STRING(
297dnl [--enable-multisense],
298dnl [multisense provides sound. tone and haptic effects support, [[default=disabled]]]
299dnl )],
300dnl [want_multisense=$enableval]
301dnl )
302AM_CONDITIONAL([ENABLE_MULTISENSE], [test "x${want_multisense}" = "xyes"])
303
304##sndfile library
305have_sndfile="no"
306want_sndfile="auto"
307AC_ARG_ENABLE([sndfile],
308 [AC_HELP_STRING([--disable-sndfile], [disable sndfile support. @<:@default=detect@:>@])],
309 [want_sndfile=$enableval], [])
310
311if test "x${want_multisense}" = "xyes" -a "x$want_sndfile" != "xno"; then
312
313 PKG_CHECK_MODULES([SNDFILE],
314 [sndfile >= 1.0.21],
315 [
316 AC_DEFINE(HAVE_LIBSNDFILE, 1, [sndfile support for Edje])
317 have_sndfile="yes"
318 requirement_edje="sndfile >= 1.0.21 ${requirement_edje}"
319 ],
320 [have_sndfile="no"; want_multisense="no"]
321 )
322
323 if test "x$want_sndfile" = "xyes" -a "x$have_sndfile" = "xno"; then
324 AC_MSG_ERROR([sndfile support requested, but not found by pkg-config.])
325 fi
326fi
327AM_CONDITIONAL([HAVE_LIBSNDFILE], [test "x${have_sndfile}" = "xyes"])
328
329##libremix library
330have_libremix="no"
331want_libremix="auto"
332AC_ARG_ENABLE([remix],
333 [AC_HELP_STRING([--disable-remix], [disable remix support. @<:@default=detect@:>@])],
334 [want_libremix=$enableval], [])
335
336if test "x${want_multisense}" = "xyes" -a "x$want_libremix" != "xno"; then
337 PKG_CHECK_MODULES([REMIX],
338 [remix >= 0.2.4],
339 [
340 AC_DEFINE(HAVE_LIBREMIX, 1, [remix support for Edje])
341 have_libremix="yes"
342 requirement_edje="remix >= 0.2.4 ${requirement_edje}"
343 AC_DEFINE(__REMIX_PLUGIN__, 1, "Set to REMIX Plugin type")
344 REMIX_PLUGIN_DIR=`pkg-config --variable=libdir remix`"/remix"
345 AC_SUBST(REMIX_PLUGIN_DIR)
346 AC_DEFINE_UNQUOTED(REMIX_PLUGIN_DIR, "$REMIX_PLUGIN_DIR", [Set the remix plugin directory])
347 ],
348 [have_libremix="no"; want_multisense="no"]
349 )
350
351 if test "x$want_libremix" = "xyes" -a "x$have_libremix" = "xno"; then
352 AC_MSG_ERROR([remix support requested, but not found by pkg-config.])
353 fi
354fi
355AM_CONDITIONAL([HAVE_LIBREMIX], [test "x${have_libremix}" = "xyes"])
356
357##vorbis/ogg library
358have_vorbis="no"
359want_vorbis="auto"
360AC_ARG_ENABLE([vorbisenc],
361 [AC_HELP_STRING([--disable-vorbis], [disable ogg-vorbis support. @<:@default=detect@:>@])],
362 [want_vorbis=$enableval], [])
363
364if test "x${want_multisense}" = "xyes" -a "x$want_vorbis" != "xno"; then
365 PKG_CHECK_MODULES([VORBISENC],
366 [
367 ogg >= 1.1.4
368 vorbis >= 1.2.3
369 vorbisenc >= 1.2.3
370 ],
371 [
372 AC_DEFINE(HAVE_VORBIS, 1, [vorbis support for Edje])
373 have_vorbis="yes"
374 requirement_edje="ogg >= 1.1.4 vorbis >= 1.2.3 vorbisenc >= 1.2.3 ${requirement_edje}"
375 ],
376 [have_vorbis="no"; want_multisense="no"]
377 )
378
379 if test "x$want_vorbis" = "xyes" -a "x$have_vorbis" = "xno"; then
380 AC_MSG_ERROR([vorbisenc support requested, but not found by pkg-config.])
381 fi
382fi
383
384##alsa library
385have_alsa_lib="no"
386want_alsa_lib="auto"
387AC_ARG_ENABLE([flac],
388 [AC_HELP_STRING([--disable-alsa], [disable alsa support. @<:@default=detect@:>@])],
389 [want_alsa_lib=$enableval], [])
390
391if test "x${want_multisense}" = "xyes" -a "x$want_alsa_lib" != "xno"; then
392 PKG_CHECK_MODULES([ALSA],
393 [
394 alsa >= 1.0.21
395 ],
396 [
397 AC_DEFINE(HAVE_LIBALSA, 1, [ALSA support for Edje])
398 have_alsa_lib="yes"
399 requirement_edje="alsa >= 1.0.21 ${requirement_edje}"
400 ],
401 [have_alsa_lib="no"; want_multisense="no"]
402 )
403
404 if test "x$want_alsa_lib" = "xyes" -a "x$have_alsa_lib" = "xno"; then
405 AC_MSG_ERROR([alsa support requested, but not found by pkg-config.])
406 fi
407fi
408AM_CONDITIONAL([HAVE_LIBALSA], [test "x${have_alsa_lib}" = "xyes"])
409
410
411##flac library
412have_flac_lib="no"
413want_flac_lib="auto"
414AC_ARG_ENABLE([flac],
415 [AC_HELP_STRING([--disable-flac], [disable flac support. @<:@default=detect@:>@])],
416 [want_flac_lib=$enableval], [])
417
418if test "x${want_multisense}" = "xyes" -a "x$want_flac_lib" != "xno"; then
419 PKG_CHECK_MODULES([FLAC],
420 [
421 flac >= 1.2.1
422 ],
423 [
424 AC_DEFINE(HAVE_LIBFLAC, 1, [flac support for Edje])
425 have_flac_lib="yes"
426 # disabled because this adds flac include dirs to cflags... and
427 # FLAC has an assert.h in its include dirs that ends up
428 # overriding the system assert.h and thus causes all sorts of
429 # mayhem
430 #requirement_edje="flac >= 1.2.1 ${requirement_edje}"
431 ],
432 [have_flac_lib="no"; want_multisense="no"]
433 )
434 if test "x$want_flac_lib" = "xyes" -a "x$have_flac_lib" = "xno"; then
435 AC_MSG_ERROR([flac support requested, but not found by pkg-config.])
436 fi
437fi
438
439if test "x${want_multisense}" = "xyes" ; then
440 AC_DEFINE([ENABLE_MULTISENSE], [1], [Use Multisense])
441fi
442
443# Dependencies for the binaries
444
445if test "x$have_edje_cc" = "xyes"; then
446 PKG_CHECK_MODULES([EDJE_CC], [ecore-file >= 1.1.0 ecore-evas >= 1.1.0 ecore >= 1.1.0 evas >= 1.1.0 eet >= 1.5.0 eina >= 1.1.0])
447 EDJE_CC_LIBS="${EDJE_CC_LIBS} ${LUA_LIBS} ${lua_libs}"
448fi
449
450AM_CONDITIONAL([BUILD_EPP], [test "x$have_edje_cc" = "xyes"])
451
452if test "x$have_edje_decc" = "xyes"; then
453 PKG_CHECK_MODULES([EDJE_DECC], [ecore-file >= 1.1.0 ecore-evas >= 1.1.0 ecore >= 1.1.0 evas >= 1.1.0 eet >= 1.5.0 eina >= 1.1.0])
454fi
455
456if test "x$have_edje_player" = "xyes"; then
457 PKG_CHECK_MODULES([EDJE_PLAYER], [ecore-evas >= 1.1.0 ecore >= 1.1.0 evas >= 1.1.0 eina >= 1.1.0])
458fi
459
460if test "x$have_edje_inspector" = "xyes"; then
461 PKG_CHECK_MODULES([EDJE_INSPECTOR], [ecore-evas >= 1.1.0 ecore >= 1.1.0 evas >= 1.1.0 eina >= 1.1.0])
462fi
463
464if test "x$have_edje_external_inspector" = "xyes"; then
465 PKG_CHECK_MODULES([EDJE_EXTERNAL_INSPECTOR], [ecore >= 1.1.0 evas >= 1.1.0 eina >= 1.1.0])
466fi
467
468
469### Checks for header files
470AC_CHECK_HEADERS([locale.h sys/resource.h])
471
472EFL_CHECK_PATH_MAX
473
474
475### Checks for types
476
477
478### Checks for structures
479
480
481### Checks for compiler characteristics
482AM_PROG_CC_C_O
483AC_C_CONST
484AC_PROG_CC_STDC
485AC_HEADER_STDC
486AC_C___ATTRIBUTE__
487
488case "$host_os" in
489 mingw32ce*)
490 EDJE_CFLAGS="${EDJE_CFLAGS} -D_WIN32_WCE=0x0420"
491 ;;
492 cegcc*)
493 EDJE_CFLAGS="${EDJE_CFLAGS} -mwin32 -D_WIN32_WCE=0x0420"
494 ;;
495esac
496
497
498### Checks for linker characteristics
499
500lt_enable_auto_import=""
501case "$host_os" in
502 mingw* | cegcc*)
503 lt_enable_auto_import="-Wl,--enable-auto-import"
504 ;;
505esac
506AC_SUBST(lt_enable_auto_import)
507
508
509### Checks for library functions
510
511AC_ISC_POSIX
512
513AC_FUNC_ALLOCA
514
515case "$host_os" in
516 mingw* | cegcc*)
517 AC_DEFINE([HAVE_REALPATH], [1], [Define to 1 if you have the `realpath' function.])
518 ;;
519 *)
520 AC_CHECK_FUNCS([realpath])
521 ;;
522esac
523
524### Unit tests, coverage and benchmarking
525
526EFL_CHECK_TESTS([enable_tests="yes"], [enable_tests="no"])
527
528EFL_CHECK_COVERAGE([${enable_tests}], [enable_coverage="yes"], [enable_coverage="no"])
529EDJE_CFLAGS="${EDJE_CFLAGS} ${EFL_COVERAGE_CFLAGS}"
530EDJE_LIBS="${EDJE_LIBS} ${EFL_COVERAGE_LIBS}"
531if test "x$enable_coverage" = "xyes" ; then
532 EDJE_CFLAGS="${EDJE_CFLAGS} ${EFL_DEBUG_CFLAGS}"
533fi
534
535## Examples
536
537install_examples="yes"
538AC_ARG_ENABLE([install-examples],
539 AC_HELP_STRING([--disable-install-examples],
540 [disable installing examples (compiled or just source).
541 @<:@default==enabled@:>@]),
542 [
543 if test "x${enableval}" = "xyes" ; then
544 install_examples="yes"
545 else
546 install_examples="no"
547 fi
548 ],
549 [install_examples="yes"])
550AM_CONDITIONAL([INSTALL_EXAMPLES], [test "x${install_examples}" = "xyes"])
551
552build_examples="no"
553AC_ARG_ENABLE([build-examples],
554 AC_HELP_STRING([--enable-build-examples],
555 [Enable building examples. This requires extra denpendencies. If you don't have them installed yet, don't build with this option or it will fail. Build again when you have it, overriding the previous installation). @<:@default==disabled@:>@]),
556 [
557 if test "x${enableval}" = "xyes" ; then
558 build_examples="yes"
559 edje_cc=$($PKG_CONFIG --variable=prefix edje)/bin/edje_cc
560 # put in here the dependencies for Edje' examples. They are
561 # meant to be 'real world' usage examples, thus one will be
562 # using higher level libraries on these programs
563 AC_SUBST(edje_cc)
564 else
565 build_examples="no"
566 fi
567 ],
568 [build_examples="no"])
569AM_CONDITIONAL([BUILD_EXAMPLES], [test "x${build_examples}" = "xyes"])
570
571AC_SUBST(requirement_edje)
572
573AC_OUTPUT([
574edje.pc
575edje.spec
576Makefile
577data/Makefile
578data/include/Makefile
579doc/Makefile
580doc/Doxyfile
581src/Makefile
582src/lib/Makefile
583src/bin/Makefile
584src/bin/epp/Makefile
585src/modules/Makefile
586src/modules/alsa_snd_player/Makefile
587src/modules/eet_snd_reader/Makefile
588src/modules/multisense_factory/Makefile
589src/tests/Makefile
590utils/Makefile
591src/examples/Makefile
592])
593
594
595#####################################################################
596## Info
597
598echo
599echo
600echo
601echo "------------------------------------------------------------------------"
602echo "$PACKAGE $VERSION"
603echo "------------------------------------------------------------------------"
604echo
605echo "Configuration Options Summary:"
606echo
607echo " Amalgamation.........: ${do_amalgamation}"
608echo " Ecore IMF............: $have_ecore_imf"
609echo " Multisense...........: $want_multisense"
610
611if test "x${want_multisense}" = "xyes" ; then
612echo " LibRemix.............: $have_libremix"
613echo " Libsndfile...........: $have_sndfile"
614echo " Ogg/Vorbis...........: $have_vorbis"
615echo " LibFLAC..............: $have_flac_lib"
616echo " LibALSA..............: $have_alsa_lib"
617fi
618
619echo " EDJE_PROGRAM_CACHE...: $want_edje_program_cache"
620echo " EDJE_CALC_CACHE......: $want_edje_calc_cache"
621echo " Fixed point..........: $want_fixed_point"
622echo " Documentation........: ${build_doc}"
623echo " Tests................: ${enable_tests}"
624echo " Coverage.............: ${enable_coverage}"
625echo " Examples.............: install:${install_examples} build:${build_examples}"
626echo
627echo "Programs:"
628echo
629echo " Build edje_cc................: $have_edje_cc"
630echo " Build edje_decc..............: $have_edje_decc"
631echo " Build edje_recc..............: $have_edje_recc"
632echo " Build edje_player............: $have_edje_player"
633echo " Build edje_inspector.........: $have_edje_inspector"
634echo " Build edje_external_inspector: $have_edje_external_inspector"
635echo
636echo "Compilation............: make (or gmake)"
637echo " CPPFLAGS.............: $CPPFLAGS"
638echo " CFLAGS...............: $CFLAGS"
639echo " LDFLAGS..............: $LDFLAGS"
640echo
641echo "Installation...........: make install (as root if needed, with 'su' or 'sudo')"
642echo " prefix...............: $prefix"
643echo